summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/sysrqd')
-rw-r--r--app-admin/sysrqd/metadata.xml6
-rw-r--r--app-admin/sysrqd/sysrqd-17-r2.ebuild (renamed from app-admin/sysrqd/sysrqd-17-r1.ebuild)5
-rw-r--r--app-admin/sysrqd/sysrqd-17.ebuild53
3 files changed, 8 insertions, 56 deletions
diff --git a/app-admin/sysrqd/metadata.xml b/app-admin/sysrqd/metadata.xml
index ff003efefc85..a26fea148238 100644
--- a/app-admin/sysrqd/metadata.xml
+++ b/app-admin/sysrqd/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
<longdescription>
@@ -7,5 +7,7 @@
Its philosophy is to be very responsive under heavy load and try to
be somehow reliable. Authentication is made by clear password.
</longdescription>
+ <upstream>
+ <remote-id type="github">jd/sysrqd</remote-id>
+ </upstream>
</pkgmetadata>
-
diff --git a/app-admin/sysrqd/sysrqd-17-r1.ebuild b/app-admin/sysrqd/sysrqd-17-r2.ebuild
index 337bac7f13dc..e9ef978e77af 100644
--- a/app-admin/sysrqd/sysrqd-17-r1.ebuild
+++ b/app-admin/sysrqd/sysrqd-17-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,6 +13,9 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+RDEPEND="virtual/libcrypt:="
+DEPEND="${RDEPEND}"
+
PATCHES=(
"${FILESDIR}"/${PN}-config.patch
"${FILESDIR}"/${P}-fix-build-system.patch
diff --git a/app-admin/sysrqd/sysrqd-17.ebuild b/app-admin/sysrqd/sysrqd-17.ebuild
deleted file mode 100644
index 541c67095fc1..000000000000
--- a/app-admin/sysrqd/sysrqd-17.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="Daemon providing access to the kernel sysrq functions via network"
-HOMEPAGE="https://github.com/jd/sysrqd"
-SRC_URI="https://github.com/jd/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-config.patch
- "${FILESDIR}"/${P}-fix-build-system.patch
-)
-
-src_configure() {
- tc-export CC
-}
-
-src_install() {
- dosbin sysrqd
- newinitd "${FILESDIR}/sysrqd.init" sysrqd
-
- local bindip='127.0.0.1' secret
- declare -i secret
- let secret="${RANDOM}*${RANDOM}*${RANDOM}*${RANDOM}"
- echo "${bindip}" > sysrqd.bind || die
- echo "${secret}" > sysrqd.secret || die
-
- diropts -m 0700 -o root -g root
- dodir /etc/sysrqd
- insinto /etc/sysrqd
- insopts -m 0600 -o root -g root
- doins sysrqd.bind
- doins sysrqd.secret
-
- einstalldocs
-}
-
-pkg_postinst() {
- elog
- elog "Be sure to change the initial secret in /etc/sysrqd/sysrqd.secret !"
- elog "As a security precaution, sysrqd is configured to only listen on"
- elog "127.0.0.1 by default. Change the content of /etc/sysrqd/sysrqd.bind"
- elog "to an IPv4 address you want it to listen on or remove the file"
- elog "to make it listen on any IP address (0.0.0.0)."
- elog
-}