summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/sysstat/sysstat-12.0.5.ebuild')
-rw-r--r--app-admin/sysstat/sysstat-12.0.5.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/app-admin/sysstat/sysstat-12.0.5.ebuild b/app-admin/sysstat/sysstat-12.0.5.ebuild
index b9ca3b9892bd..a5698a451e73 100644
--- a/app-admin/sysstat/sysstat-12.0.5.ebuild
+++ b/app-admin/sysstat/sysstat-12.0.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils flag-o-matic multilib systemd toolchain-funcs
+EAPI=7
+inherit eutils flag-o-matic systemd toolchain-funcs
DESCRIPTION="System performance tools for Linux"
HOMEPAGE="http://pagesperso-orange.fr/sebastien.godard/"
@@ -30,8 +30,6 @@ PATCHES=(
"${FILESDIR}"/${PN}-11.7.3-flags.patch
)
-SYSSTAT_FAKE_RC_DIR=Gentoo-does-not-use-rc.d
-
src_prepare() {
if use nls; then
strip-linguas -i nls/
@@ -52,9 +50,8 @@ src_configure() {
tc-export AR
use static && append-ldflags -static
- sa_lib_dir=/usr/$(get_libdir)/sa \
+ sa_lib_dir=/usr/lib/sa \
conf_dir=/etc \
- rcdir=${SYSSTAT_FAKE_RC_DIR} \
econf \
$(use_enable debug debuginfo) \
$(use_enable lm_sensors sensors) \
@@ -77,7 +74,6 @@ src_install() {
dodoc -r contrib/
- rm -r "${D}/${SYSSTAT_FAKE_RC_DIR}" || die
newinitd "${FILESDIR}"/${PN}.init.d ${PN}
systemd_dounit ${PN}.service