summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/systemrescuecd-x86/systemrescuecd-x86-6.0.0.ebuild')
-rw-r--r--app-admin/systemrescuecd-x86/systemrescuecd-x86-6.0.0.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/app-admin/systemrescuecd-x86/systemrescuecd-x86-6.0.0.ebuild b/app-admin/systemrescuecd-x86/systemrescuecd-x86-6.0.0.ebuild
new file mode 100644
index 000000000000..58953e3649e7
--- /dev/null
+++ b/app-admin/systemrescuecd-x86/systemrescuecd-x86-6.0.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P=${P/-x86/}
+DESCRIPTION="The .iso image of SystemRescueCD rescue disk, amd64 variant"
+HOMEPAGE="http://www.sysresccd.org/"
+# Large ISO mirroring explicitly approved by infra in bug #588766
+SRC_URI="mirror://sourceforge/systemrescuecd/sysresccd-${PN#*-}/${PV}/${MY_P}.iso"
+
+LICENSE="GPL-2"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+isohybrid"
+
+DEPEND="isohybrid? ( >=sys-boot/syslinux-4 )"
+
+S=${WORKDIR}
+
+pkg_pretend() {
+ ewarn "Please note that starting with version 6.0.0, upstream has switched"
+ ewarn "to Arch Linux as base of their distribution, and running on 32-bit"
+ ewarn "systems is no longer supported."
+}
+
+src_install() {
+ insinto "/usr/share/${PN%-*}"
+ doins "${DISTDIR}/${MY_P}.iso"
+
+ if use isohybrid; then
+ set -- isohybrid -u "${ED%/}/usr/share/${PN%-*}/${MY_P}.iso"
+ echo "${@}"
+ "${@}" || die "${*} failed"
+ fi
+}
+
+pkg_postinst() {
+ local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # no version newer than ours? we're the newest!
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ ln -f -s -v "${MY_P}.iso" "${f}" || die
+ fi
+}
+
+pkg_postrm() {
+ local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # if there is no version newer than ours installed
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ # and we are truly and completely uninstalled...
+ if [[ ! ${REPLACED_BY_VERSION} ]]; then
+ # then find an older version to set the symlink to
+ local newest_version=$(best_version "<${CATEGORY}/${PF}")
+
+ if [[ ${newest_version} ]]; then
+ # update the symlink
+ ln -f -s -v "${newest_version%-r*}.iso" "${f}" || die
+ else
+ # last version removed? clean up the symlink
+ rm -v "${f}" || die
+ # and the parent directory
+ rmdir "${f%/*}" || die
+ fi
+ fi
+ fi
+}