summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ttyplot')
-rw-r--r--app-admin/ttyplot/Manifest3
-rw-r--r--app-admin/ttyplot/metadata.xml11
-rw-r--r--app-admin/ttyplot/ttyplot-1.6.2-r1.ebuild31
-rw-r--r--app-admin/ttyplot/ttyplot-1.6.4.ebuild31
-rw-r--r--app-admin/ttyplot/ttyplot-1.6.5.ebuild31
5 files changed, 107 insertions, 0 deletions
diff --git a/app-admin/ttyplot/Manifest b/app-admin/ttyplot/Manifest
new file mode 100644
index 000000000000..57ac35fac801
--- /dev/null
+++ b/app-admin/ttyplot/Manifest
@@ -0,0 +1,3 @@
+DIST ttyplot-1.6.2.gh.tar.gz 56277 BLAKE2B c7a818a69774fc7c5f6b498e5bf2f9c3ec644dc23d54daf59adaf13962f614c23918ca1d84614e27c60e75d1b98b3eb3c548dc14b59b539acceb3327dafabe0c SHA512 7ede447667a0a8f4b164a2a409e1264c36c95c22eeeda348c894678cb8d7209e742bb90f48a8a5260dd457ae7ff0a090a7d8b7eb25b20e20ada575e00cc4eb0b
+DIST ttyplot-1.6.4.gh.tar.gz 56541 BLAKE2B b05fffd2a7903ec94d516c7e970db4dd2dd90ac2568c6c3e3b6608e40ab65a18ac6a9a9693e189328bfebdd120fb50efd8bedcb260329d5ad28d0c7a81c390dd SHA512 51d8cc7dfa281f66e92b0f508f9db413869bb559aa6d1f4a54eb658f3564e2552b622e8667587bbe9e7c85063b03704a03e8eb004b979c68bf874453b5c3cbb5
+DIST ttyplot-1.6.5.gh.tar.gz 56538 BLAKE2B 1119012b170cde84b904f34c3bcf7d7c3e1adbf1ae5a465dffb74be11ad073251c40c508d4ced7f36db6a3e96336e04c61e0f402bb5f0d7ee6c5ca8e9451d900 SHA512 93512777f0371857cadb43a836538cb9e946b7110157534c9c76c090852ea5c9ee6085742f9c6d501f8c7a62f05967309e24e1a3bad96eac4b726f946053b0ab
diff --git a/app-admin/ttyplot/metadata.xml b/app-admin/ttyplot/metadata.xml
new file mode 100644
index 000000000000..ae2c63465dde
--- /dev/null
+++ b/app-admin/ttyplot/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tenox7/ttyplot</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/ttyplot/ttyplot-1.6.2-r1.ebuild b/app-admin/ttyplot/ttyplot-1.6.2-r1.ebuild
new file mode 100644
index 000000000000..a0e31d253379
--- /dev/null
+++ b/app-admin/ttyplot/ttyplot-1.6.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Realtime plotting utility with data input from stdin"
+HOMEPAGE="https://github.com/tenox7/ttyplot"
+SRC_URI="https://github.com/tenox7/ttyplot/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="virtual/pkgconfig"
+DEPEND="${RDEPEND}
+ sys-libs/ncurses[tinfo]"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ local args=(
+ PREFIX=/usr
+ MANPREFIX=/usr/share/man
+ DESTDIR="${D}"
+ )
+ emake "${args[@]}" install
+}
diff --git a/app-admin/ttyplot/ttyplot-1.6.4.ebuild b/app-admin/ttyplot/ttyplot-1.6.4.ebuild
new file mode 100644
index 000000000000..a0e31d253379
--- /dev/null
+++ b/app-admin/ttyplot/ttyplot-1.6.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Realtime plotting utility with data input from stdin"
+HOMEPAGE="https://github.com/tenox7/ttyplot"
+SRC_URI="https://github.com/tenox7/ttyplot/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="virtual/pkgconfig"
+DEPEND="${RDEPEND}
+ sys-libs/ncurses[tinfo]"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ local args=(
+ PREFIX=/usr
+ MANPREFIX=/usr/share/man
+ DESTDIR="${D}"
+ )
+ emake "${args[@]}" install
+}
diff --git a/app-admin/ttyplot/ttyplot-1.6.5.ebuild b/app-admin/ttyplot/ttyplot-1.6.5.ebuild
new file mode 100644
index 000000000000..a0e31d253379
--- /dev/null
+++ b/app-admin/ttyplot/ttyplot-1.6.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Realtime plotting utility with data input from stdin"
+HOMEPAGE="https://github.com/tenox7/ttyplot"
+SRC_URI="https://github.com/tenox7/ttyplot/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="virtual/pkgconfig"
+DEPEND="${RDEPEND}
+ sys-libs/ncurses[tinfo]"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ local args=(
+ PREFIX=/usr
+ MANPREFIX=/usr/share/man
+ DESTDIR="${D}"
+ )
+ emake "${args[@]}" install
+}