summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ulogd')
-rw-r--r--app-admin/ulogd/Manifest2
-rw-r--r--app-admin/ulogd/files/patches/ulogd.patch10
-rw-r--r--app-admin/ulogd/metadata.xml2
-rw-r--r--app-admin/ulogd/ulogd-2.0.8.ebuild (renamed from app-admin/ulogd/ulogd-2.0.7-r2.ebuild)31
4 files changed, 19 insertions, 26 deletions
diff --git a/app-admin/ulogd/Manifest b/app-admin/ulogd/Manifest
index 04c8ace89f14..d2c098172f03 100644
--- a/app-admin/ulogd/Manifest
+++ b/app-admin/ulogd/Manifest
@@ -1 +1 @@
-DIST ulogd-2.0.7.tar.bz2 394573 BLAKE2B bec028a3b35038a8cc0f3f8b81b3e19addb66fce09e4ea0f3b2cd29b20cdb28025a576badd0765d9bb15f9d097799b6f55ff45058f8a838daa836c3fe878eef0 SHA512 1ad12bcf91bebe8bf8580de38693318cdabd17146f1f65acf714334885cf13adf5f783abdf2dd67474ef12f82d2cfb84dd4859439bc7af10a0df58e4c7e48b09
+DIST ulogd-2.0.8.tar.bz2 435434 BLAKE2B 8922a722d635b24dd8bed9bff9e96cbbdf1ac790defd3b205b6867f32d7abcd6dff1c37097305ed3ed627d66da1bdb1f7aa2a9fe7e29a2b2104959a986207478 SHA512 9f99f6f35bad5da4559d788dc3ba3dae17d4ae972737cae3313ecf68f08eaf5f55514fce6f30503437e4158fd30a06438b9249d5d20f6343964cbf690f87309d
diff --git a/app-admin/ulogd/files/patches/ulogd.patch b/app-admin/ulogd/files/patches/ulogd.patch
deleted file mode 100644
index c82e5022ed35..000000000000
--- a/app-admin/ulogd/files/patches/ulogd.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/src/ulogd.c
-+++ b/src/ulogd.c
-@@ -65,6 +65,7 @@
- #include <sys/time.h>
- #include <sys/stat.h>
- #include <sched.h>
-+#include <limits.h>
- #include <ulogd/conffile.h>
- #include <ulogd/ulogd.h>
- #ifdef DEBUG
diff --git a/app-admin/ulogd/metadata.xml b/app-admin/ulogd/metadata.xml
index b155d9e37204..884957b63931 100644
--- a/app-admin/ulogd/metadata.xml
+++ b/app-admin/ulogd/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
<use>
diff --git a/app-admin/ulogd/ulogd-2.0.7-r2.ebuild b/app-admin/ulogd/ulogd-2.0.8.ebuild
index c252351ca7ea..3768bedeb734 100644
--- a/app-admin/ulogd/ulogd-2.0.7-r2.ebuild
+++ b/app-admin/ulogd/ulogd-2.0.8.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit flag-o-matic linux-info readme.gentoo-r1 systemd
@@ -11,14 +11,14 @@ SRC_URI="https://www.netfilter.org/projects/ulogd/files/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc x86"
+KEYWORDS="amd64 ~ia64 ~ppc x86"
IUSE="dbi doc json mysql nfacct +nfct +nflog pcap postgres selinux sqlite ulog"
DEPEND="
|| ( net-firewall/iptables net-firewall/nftables )
>=net-libs/libnfnetlink-1.0.1
dbi? ( dev-db/libdbi )
- json? ( dev-libs/jansson )
+ json? ( dev-libs/jansson:= )
nfacct? (
>=net-libs/libmnl-1.0.4
>=net-libs/libnetfilter_acct-1.0.3
@@ -37,8 +37,10 @@ RDEPEND="
selinux? ( sec-policy/selinux-ulogd )
"
BDEPEND="
+ virtual/pkgconfig
doc? (
app-text/linuxdoc-tools
+ app-text/openjade
app-text/texlive-core
dev-texlive/texlive-fontsrecommended
virtual/latex-base
@@ -51,8 +53,6 @@ DOC_CONTENTS="
Please edit the example configuration located at '${EPREFIX}/etc/ulogd.conf'.
"
-PATCHES=( "${FILESDIR}"/patches/ulogd.patch )
-
pkg_setup() {
linux-info_pkg_setup
@@ -80,23 +80,25 @@ src_prepare() {
src_configure() {
append-lfs-flags
+
local myeconfargs=(
- $(use_with dbi)
- $(use_with json jansson)
+ $(use_enable dbi)
+ $(use_enable json)
$(use_enable nfacct)
$(use_enable nfct)
$(use_enable nflog)
- $(use_with mysql)
- $(use_with pcap)
- $(use_with postgres pgsql)
- $(use_with sqlite)
+ $(use_enable mysql)
+ $(use_enable pcap)
+ $(use_enable postgres pgsql)
+ $(use_enable sqlite sqlite3)
$(use_enable ulog)
)
+
econf "${myeconfargs[@]}"
}
src_compile() {
- default_src_compile
+ default
if use doc; then
# Prevent access violations from bitmap font files generation.
@@ -108,7 +110,8 @@ src_compile() {
src_install() {
use doc && HTML_DOCS=( doc/${PN}.html )
- default_src_install
+ default
+
find "${ED}" -name '*.la' -delete || die
readme.gentoo_create_doc