summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/watchfolder')
-rw-r--r--app-admin/watchfolder/files/0.3.3-implicit-decl.patch14
-rw-r--r--app-admin/watchfolder/metadata.xml3
-rw-r--r--app-admin/watchfolder/watchfolder-0.3.3-r2.ebuild (renamed from app-admin/watchfolder/watchfolder-0.3.3-r1.ebuild)2
3 files changed, 15 insertions, 4 deletions
diff --git a/app-admin/watchfolder/files/0.3.3-implicit-decl.patch b/app-admin/watchfolder/files/0.3.3-implicit-decl.patch
index 1b8e72d72bf8..f2fc0b367d48 100644
--- a/app-admin/watchfolder/files/0.3.3-implicit-decl.patch
+++ b/app-admin/watchfolder/files/0.3.3-implicit-decl.patch
@@ -38,3 +38,17 @@
#include <sys/wait.h>
#include <stdio.h>
#include <stdlib.h>
+diff --git a/watchd.c b/watchd.c
+index 842e186..49edb64 100644
+--- a/watchd.c
++++ b/watchd.c
+@@ -52,6 +52,9 @@ Syntax : watchd
+ #define FL_LOG_MAIL 256
+ #define FL_LOG_ALWAYS 512
+
++int isdir(char *name);
++void ini_close(inifile *i);
++
+ typedef struct Twatchfolder
+ {
+ char* runprg;
diff --git a/app-admin/watchfolder/metadata.xml b/app-admin/watchfolder/metadata.xml
index 5110520fa1d3..115e9d64a669 100644
--- a/app-admin/watchfolder/metadata.xml
+++ b/app-admin/watchfolder/metadata.xml
@@ -2,7 +2,4 @@
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
- <upstream>
- <remote-id type="freshmeat">watchd</remote-id>
- </upstream>
</pkgmetadata>
diff --git a/app-admin/watchfolder/watchfolder-0.3.3-r1.ebuild b/app-admin/watchfolder/watchfolder-0.3.3-r2.ebuild
index 1622add191e4..9a93d1579f8a 100644
--- a/app-admin/watchfolder/watchfolder-0.3.3-r1.ebuild
+++ b/app-admin/watchfolder/watchfolder-0.3.3-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7