summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/webalizer')
-rw-r--r--app-admin/webalizer/files/webalizer-2.23.08-broken-disable-static.patch16
-rw-r--r--app-admin/webalizer/metadata.xml6
-rw-r--r--app-admin/webalizer/webalizer-2.23.08-r1.ebuild (renamed from app-admin/webalizer/webalizer-2.23.08.ebuild)39
3 files changed, 42 insertions, 19 deletions
diff --git a/app-admin/webalizer/files/webalizer-2.23.08-broken-disable-static.patch b/app-admin/webalizer/files/webalizer-2.23.08-broken-disable-static.patch
new file mode 100644
index 000000000000..109740a33ccb
--- /dev/null
+++ b/app-admin/webalizer/files/webalizer-2.23.08-broken-disable-static.patch
@@ -0,0 +1,16 @@
+--- a/configure
++++ b/configure
+@@ -3939,13 +3939,6 @@
+
+
+ if test "$GCC" = "yes"; then
+-
+- # Check whether --enable-static was given.
+-if test "${enable_static+set}" = set; then
+- enableval=$enable_static; LDFLAGS="--static ${LDFLAGS}"
+-fi
+-
+-
+ if test "$IN_CFLAGS" = ""; then
+ CFLAGS="-Wall -O2"
+ fi
diff --git a/app-admin/webalizer/metadata.xml b/app-admin/webalizer/metadata.xml
index dc3cf7c59bb9..1a74f43590a2 100644
--- a/app-admin/webalizer/metadata.xml
+++ b/app-admin/webalizer/metadata.xml
@@ -1,10 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>blueness@gentoo.org</email>
- <name>Anthony G. Basile</name>
- </maintainer>
<maintainer type="project">
<email>web-apps@gentoo.org</email>
<name>Gentoo Webapps</name>
diff --git a/app-admin/webalizer/webalizer-2.23.08.ebuild b/app-admin/webalizer/webalizer-2.23.08-r1.ebuild
index dfa19a5d9eeb..06ed7a36b4d5 100644
--- a/app-admin/webalizer/webalizer-2.23.08.ebuild
+++ b/app-admin/webalizer/webalizer-2.23.08-r1.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# uses webapp.eclass to create directories with right permissions
# probably slight overkill but works well
-EAPI="5"
+EAPI=8
-inherit versionator epatch webapp db-use
+inherit flag-o-matic webapp db-use
WEBAPP_MANUAL_SLOT="yes"
XTENDED_VER="RB30"
XTENDED_URL="rb30"
-MY_PV="$(get_version_component_range 1-2)-$(get_version_component_range 3)"
+MY_PV="$(ver_cut 1-2)-$(ver_cut 3)"
MY_P="${PN}-${MY_PV}"
GEODB_DATE="20140201"
@@ -21,25 +21,30 @@ GEODB_DIR="/usr/share/webalizer/geodb"
DESCRIPTION="Webserver log file analyzer"
HOMEPAGE="http://www.webalizer.org/"
-SRC_URI="ftp://ftp.mrunix.net/pub/webalizer/${MY_P}-src.tar.bz2
+SRC_URI="
+ ftp://ftp.mrunix.net/pub/webalizer/${MY_P}-src.tar.bz2
xtended? ( http://patrickfrei.ch/webalizer/${XTENDED_URL}/${PN}-${MY_PV}-${XTENDED_VER}-patch.tar.gz )
https://dev.gentoo.org/~blueness/webalizer/webalizer.conf.gz
${GEODB_URL}/webalizer-geodb-${GEODB_DATE}.tgz"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
-KEYWORDS="~alpha amd64 ~arm ~hppa ppc ppc64 ~sparc x86"
-IUSE="bzip2 xtended geoip nls"
SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~hppa ppc ppc64 ~sparc x86"
+IUSE="bzip2 xtended geoip nls selinux"
-DEPEND=">=sys-libs/db-4.2:*
+DEPEND="
+ >=sys-libs/db-4.2:*
>=sys-libs/zlib-1.1.4
>=media-libs/libpng-1.2:0=
>=media-libs/gd-1.8.3[png]
dev-libs/geoip
- bzip2? ( app-arch/bzip2 )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}"/${MY_P}
+ bzip2? ( app-arch/bzip2 )
+"
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-webalizer )
+"
pkg_setup() {
webapp_pkg_setup
@@ -53,10 +58,13 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.23.08-gcc-10.patch
+ eapply "${FILESDIR}"/${PN}-2.23.08-broken-disable-static.patch
+ eapply "${FILESDIR}"/${PN}-2.23.08-gcc-10.patch
if use xtended; then
- epatch "${WORKDIR}"/${PN}-${MY_PV}-${XTENDED_VER}-patch
+ eapply "${WORKDIR}"/${PN}-${MY_PV}-${XTENDED_VER}-patch
fi
+
+ eapply_user
}
src_configure() {
@@ -71,6 +79,9 @@ src_configure() {
local myconf="${myconf} --with-language=english"
fi
+ # bug #779016 and bug #737694
+ append-flags -fcommon
+
econf --enable-dns \
--with-db=$(db_includedir) \
--with-dblib=$(db_libname) \