summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/webapp-config')
-rw-r--r--app-admin/webapp-config/files/webapp-config-1.55-py3.122-invalid-escape-sequence.patch11
-rw-r--r--app-admin/webapp-config/metadata.xml8
-rw-r--r--app-admin/webapp-config/webapp-config-1.55-r4.ebuild (renamed from app-admin/webapp-config/webapp-config-1.55-r2.ebuild)47
-rw-r--r--app-admin/webapp-config/webapp-config-9999.ebuild43
4 files changed, 80 insertions, 29 deletions
diff --git a/app-admin/webapp-config/files/webapp-config-1.55-py3.122-invalid-escape-sequence.patch b/app-admin/webapp-config/files/webapp-config-1.55-py3.122-invalid-escape-sequence.patch
new file mode 100644
index 000000000000..cb1ba1a8593e
--- /dev/null
+++ b/app-admin/webapp-config/files/webapp-config-1.55-py3.122-invalid-escape-sequence.patch
@@ -0,0 +1,11 @@
+--- a/WebappConfig/protect.py
++++ b/WebappConfig/protect.py
+@@ -78,7 +78,7 @@
+
+ numbers = []
+ prefix = self.protect_prefix
+- rep = re.compile(prefix.replace('.','\.') + '(\d{4})_')
++ rep = re.compile(prefix.replace('.',r'\.') + r'(\d{4})_')
+
+ for i in entries:
+ rem = rep.match(i)
diff --git a/app-admin/webapp-config/metadata.xml b/app-admin/webapp-config/metadata.xml
index cbf8aeabe119..580c8fc2eb7a 100644
--- a/app-admin/webapp-config/metadata.xml
+++ b/app-admin/webapp-config/metadata.xml
@@ -1,16 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>blueness@gentoo.org</email>
- <name>Anthony G. Basile</name>
- </maintainer>
<maintainer type="project">
<email>web-apps@gentoo.org</email>
<name>Gentoo Webapps</name>
</maintainer>
<use>
- <flag name="portage">Propagate python_targets dependencies to sys-apps/portage</flag>
+ <flag name="portage">Propagate python_targets dependencies to <pkg>sys-apps/portage</pkg></flag>
</use>
<upstream>
<remote-id type="sourceforge">webapp-config</remote-id>
diff --git a/app-admin/webapp-config/webapp-config-1.55-r2.ebuild b/app-admin/webapp-config/webapp-config-1.55-r4.ebuild
index 08e686f810cf..171bf028c53a 100644
--- a/app-admin/webapp-config/webapp-config-1.55-r2.ebuild
+++ b/app-admin/webapp-config/webapp-config-1.55-r4.ebuild
@@ -1,15 +1,21 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 prefix
-SRC_URI="https://dev.gentoo.org/~twitch153/${PN}/${P}.tar.bz2"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
+if [[ ${PV} = 9999* ]]
+then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~ceamac/${CATEGORY}/${PN}/${P}.tar.bz2"
+ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+fi
DESCRIPTION="Gentoo's installer for web-based applications"
HOMEPAGE="https://sourceforge.net/projects/webapp-config/"
@@ -23,7 +29,23 @@ DEPEND="app-text/xmlto
RDEPEND="
portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
+PATCHES=(
+ "${FILESDIR}"/webapp-config-1.55-py3.122-invalid-escape-sequence.patch
+)
+
python_prepare_all() {
+ # make the source from svn mirror the one in the tarball
+ if [[ ${PV} == 9999* ]]; then
+ mkdir ../webapp-config || die "Cannot create temp directory."
+ cp -r * ../webapp-config || die "Cannot copy all into the temp directory."
+ mv ../webapp-config . || die "Cannot move temp directory to its final position."
+
+ # Installation fails if version is 1.55-git
+ sed -e 's/-git//' \
+ -i webapp-config/WebappConfig/version.py \
+ -i WebappConfig/version.py || die "Cannot fix version."
+ fi
+
distutils-r1_python_prepare_all
eprefixify WebappConfig/eprefix.py config/webapp-config
}
@@ -32,6 +54,11 @@ python_compile_all() {
emake -C doc/
}
+python_test() {
+ PYTHONPATH="." "${EPYTHON}" WebappConfig/tests/external.py -v ||
+ die "Testing failed with ${EPYTHON}"
+}
+
python_install() {
# According to this discussion:
# http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
@@ -44,6 +71,9 @@ python_install() {
python_install_all() {
distutils-r1_python_install_all
+ # distutils-r1 installs the scripts in /usr/bin in PEP517 mode
+ mv "${ED}"/usr/bin "${ED}"/usr/sbin || die "Cannot rename scripts directory to /usr/sbin"
+
insinto /etc/vhosts
doins config/webapp-config
@@ -54,11 +84,6 @@ python_install_all() {
doman doc/*.[58]
}
-python_test() {
- PYTHONPATH="." "${EPYTHON}" WebappConfig/tests/external.py -v ||
- die "Testing failed with ${EPYTHON}"
-}
-
pkg_postinst() {
elog "Now that you have upgraded webapp-config, you **must** update your"
elog "config files in /etc/vhosts/webapp-config before you emerge any"
diff --git a/app-admin/webapp-config/webapp-config-9999.ebuild b/app-admin/webapp-config/webapp-config-9999.ebuild
index 611a6da21acf..cc2e8028b578 100644
--- a/app-admin/webapp-config/webapp-config-9999.ebuild
+++ b/app-admin/webapp-config/webapp-config-9999.ebuild
@@ -1,20 +1,20 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 prefix
if [[ ${PV} = 9999* ]]
then
- EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/${PN}.git"
inherit git-r3
else
- SRC_URI="https://dev.gentoo.org/~blueness/${PN}/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+ SRC_URI="https://dev.gentoo.org/~ceamac/${CATEGORY}/${PN}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
DESCRIPTION="Gentoo's installer for web-based applications"
@@ -29,7 +29,23 @@ DEPEND="app-text/xmlto
RDEPEND="
portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
+PATCHES=(
+ "${FILESDIR}"/webapp-config-1.55-py3.122-invalid-escape-sequence.patch
+)
+
python_prepare_all() {
+ # make the source from svn mirror the one in the tarball
+ if [[ ${PV} == 9999* ]]; then
+ mkdir ../webapp-config || die "Cannot create temp directory."
+ cp -r * ../webapp-config || die "Cannot copy all into the temp directory."
+ mv ../webapp-config . || die "Cannot move temp directory to its final position."
+
+ # Installation fails if version is 1.55-git
+ sed -e 's/-git//' \
+ -i webapp-config/WebappConfig/version.py \
+ -i WebappConfig/version.py || die "Cannot fix version."
+ fi
+
distutils-r1_python_prepare_all
eprefixify WebappConfig/eprefix.py config/webapp-config
}
@@ -38,6 +54,11 @@ python_compile_all() {
emake -C doc/
}
+python_test() {
+ PYTHONPATH="." "${EPYTHON}" WebappConfig/tests/external.py -v ||
+ die "Testing failed with ${EPYTHON}"
+}
+
python_install() {
# According to this discussion:
# http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
@@ -50,6 +71,9 @@ python_install() {
python_install_all() {
distutils-r1_python_install_all
+ # distutils-r1 installs the scripts in /usr/bin in PEP517 mode
+ mv "${ED}"/usr/bin "${ED}"/usr/sbin || die "Cannot rename scripts directory to /usr/sbin"
+
insinto /etc/vhosts
doins config/webapp-config
@@ -60,11 +84,6 @@ python_install_all() {
doman doc/*.[58]
}
-python_test() {
- PYTHONPATH="." "${EPYTHON}" WebappConfig/tests/external.py -v ||
- die "Testing failed with ${EPYTHON}"
-}
-
pkg_postinst() {
elog "Now that you have upgraded webapp-config, you **must** update your"
elog "config files in /etc/vhosts/webapp-config before you emerge any"