summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/xstow/xstow-1.0.1.ebuild')
-rw-r--r--app-admin/xstow/xstow-1.0.1.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/app-admin/xstow/xstow-1.0.1.ebuild b/app-admin/xstow/xstow-1.0.1.ebuild
index 8bc68e8c4517..5625fbef7050 100644
--- a/app-admin/xstow/xstow-1.0.1.ebuild
+++ b/app-admin/xstow/xstow-1.0.1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit autotools eutils
+inherit autotools
-DESCRIPTION="replacement for GNU stow with extensions"
+DESCRIPTION="Replacement for GNU stow with extensions"
HOMEPAGE="http://xstow.sourceforge.net/"
SRC_URI="mirror://sourceforge/xstow/${P}.tar.bz2"
@@ -17,8 +17,12 @@ IUSE="ncurses"
DEPEND="ncurses? ( sys-libs/ncurses:0= )"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-ncurses.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-ncurses.patch
+ default
eautoreconf
}
@@ -27,11 +31,11 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}/html" install
+ emake DESTDIR="${D}" docdir="${EPREFIX}/usr/share/doc/${PF}/html" install
dodoc AUTHORS ChangeLog NEWS README TODO
# create new STOWDIR
- dodir /var/lib/xstow
+ keepdir /var/lib/xstow
# install env.d file to add STOWDIR to PATH and LDPATH
doenvd "${FILESDIR}/99xstow"