summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/system-config-printer/Manifest1
-rw-r--r--app-admin/system-config-printer/files/system-config-printer-1.5.12-check-for-null.patch46
-rw-r--r--app-admin/system-config-printer/files/system-config-printer-1.5.12-fix-abrt-in-udev-configure-printer.patch72
-rw-r--r--app-admin/system-config-printer/system-config-printer-1.5.12-r1.ebuild83
4 files changed, 0 insertions, 202 deletions
diff --git a/app-admin/system-config-printer/Manifest b/app-admin/system-config-printer/Manifest
index 22c632e36fb2..985f7b1a4786 100644
--- a/app-admin/system-config-printer/Manifest
+++ b/app-admin/system-config-printer/Manifest
@@ -1,2 +1 @@
-DIST system-config-printer-1.5.12.tar.xz 955756 BLAKE2B 766cc7307382a7b0ab65387650f1568fd5108dae2693dfc93684c6593e28837d513e4c823bf4e07c3ba2123eea8aba0649135020318f06f38633b9837683d7f7 SHA512 c8b0702dcdf99c4e8a19274dd4a3f82d9263bd5f51d0c19edf7d71fb13095f57a35e643ddbe161ffb5805e72bf7da0cb6a3de44a554854390ac05d8e56644c32
DIST system-config-printer-1.5.13.tar.xz 974532 BLAKE2B 44e748d2fc20edefe58e1c8dd3781aff28af93e57356a9969e051813bf4f04f72c4e895b587e86614df6fb4984a4d610e8e1a1e17777801ae8912b6904679c72 SHA512 f4fbc1b20b35aa5b33bafdffc8a7490cc3c55e0b33bd9e925f1d3e01532c0a7bb87f80a04dd6da6fc492edd9fea74bacb0ce16ff64ceac622722fe1f9a77a6b7
diff --git a/app-admin/system-config-printer/files/system-config-printer-1.5.12-check-for-null.patch b/app-admin/system-config-printer/files/system-config-printer-1.5.12-check-for-null.patch
deleted file mode 100644
index b0df809c9398..000000000000
--- a/app-admin/system-config-printer/files/system-config-printer-1.5.12-check-for-null.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From cf9903466c1a2d18a701f3b5e8c7e03483e1244d Mon Sep 17 00:00:00 2001
-From: Zdenek Dohnal <zdohnal@redhat.com>
-Date: Mon, 14 Oct 2019 16:39:28 +0200
-Subject: [PATCH] udev-configure-printer: Add checks for NULL
-
----
- udev/udev-configure-printer.c | 12 +++++++++---
- 1 file changed, 9 insertions(+), 3 deletions(-)
-
-diff --git a/udev/udev-configure-printer.c b/udev/udev-configure-printer.c
-index 83092fc21..d753bbeaf 100644
---- a/udev/udev-configure-printer.c
-+++ b/udev/udev-configure-printer.c
-@@ -1411,7 +1411,7 @@ for_each_matching_queue (struct device_uris *device_uris,
- const char *printer_state_message = NULL;
- int state = 0;
- size_t i, l;
-- char *this_device_uri_n, *device_uri_n;
-+ char *this_device_uri_n = NULL, *device_uri_n = NULL;
- const char *ps1, *ps2, *pi1, *pi2;
-
- while (attr && ippGetGroupTag (attr) != IPP_TAG_PRINTER)
-@@ -1448,6 +1448,8 @@ for_each_matching_queue (struct device_uris *device_uris,
- for (i = 0; i < device_uris->n_uris; i++)
- {
- device_uri_n = normalize_device_uri(device_uris->uri[i]);
-+ if (this_device_uri_n == NULL || device_uri_n == NULL)
-+ goto skip;
- /* As for the same device different URIs can come out when the
- device is accessed via the usblp kernel module or via low-
- level USB (libusb) we cannot simply compare URIs, must
-@@ -1512,8 +1514,12 @@ for_each_matching_queue (struct device_uris *device_uris,
- firstqueue = 0;
-
- skip:
-- free(device_uri_n);
-- free(this_device_uri_n);
-+ if (device_uri_n != NULL)
-+ free(device_uri_n);
-+ device_uri_n = NULL;
-+ if (this_device_uri_n != NULL)
-+ free(this_device_uri_n);
-+ this_device_uri_n = NULL;
- if (!attr)
- break;
- }
diff --git a/app-admin/system-config-printer/files/system-config-printer-1.5.12-fix-abrt-in-udev-configure-printer.patch b/app-admin/system-config-printer/files/system-config-printer-1.5.12-fix-abrt-in-udev-configure-printer.patch
deleted file mode 100644
index 7aed67584f70..000000000000
--- a/app-admin/system-config-printer/files/system-config-printer-1.5.12-fix-abrt-in-udev-configure-printer.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-From b9289dfe105bdb502f183f0afe7a115ecae5f2af Mon Sep 17 00:00:00 2001
-From: Zdenek Dohnal <zdohnal@redhat.com>
-Date: Fri, 1 Nov 2019 15:55:34 +0100
-Subject: [PATCH] Fix abrt in udev-configure-printer
-
-The abrt was due invalid free - several printer models have its normalized uri cropped.
-The original pointer from strdup() was lost so its freeing was invalid.
----
- udev/udev-configure-printer.c | 21 ++++++++++++++-------
- 1 file changed, 14 insertions(+), 7 deletions(-)
-
-diff --git a/udev/udev-configure-printer.c b/udev/udev-configure-printer.c
-index d753bbeaf..a44520f9c 100644
---- a/udev/udev-configure-printer.c
-+++ b/udev/udev-configure-printer.c
-@@ -1285,7 +1285,8 @@ normalize_device_uri(const char *str_orig)
- {
- int i, j;
- int havespace = 0;
-- char *str;
-+ char *str = NULL;
-+ char *cropped_str = NULL;
-
- if (str_orig == NULL)
- return NULL;
-@@ -1333,7 +1334,11 @@ normalize_device_uri(const char *str_orig)
- (strstr(str, "packard ") == str) ||
- (strstr(str, "apollo ") == str) ||
- (strstr(str, "usb ") == str))
-- str = strchr(str, ' ') + 1;
-+ {
-+ cropped_str = strdup(strchr(str, ' ') + 1);
-+ free(str);
-+ str = cropped_str;
-+ }
-
- return str;
- }
-@@ -1448,8 +1453,6 @@ for_each_matching_queue (struct device_uris *device_uris,
- for (i = 0; i < device_uris->n_uris; i++)
- {
- device_uri_n = normalize_device_uri(device_uris->uri[i]);
-- if (this_device_uri_n == NULL || device_uri_n == NULL)
-- goto skip;
- /* As for the same device different URIs can come out when the
- device is accessed via the usblp kernel module or via low-
- level USB (libusb) we cannot simply compare URIs, must
-@@ -1509,17 +1512,21 @@ for_each_matching_queue (struct device_uris *device_uris,
- break;
- }
- }
-+ if (device_uri_n != NULL)
-+ {
-+ free(device_uri_n);
-+ device_uri_n = NULL;
-+ }
- }
-
- firstqueue = 0;
-
- skip:
-- if (device_uri_n != NULL)
-- free(device_uri_n);
-- device_uri_n = NULL;
- if (this_device_uri_n != NULL)
-+ {
- free(this_device_uri_n);
- this_device_uri_n = NULL;
-+ }
- if (!attr)
- break;
- }
diff --git a/app-admin/system-config-printer/system-config-printer-1.5.12-r1.ebuild b/app-admin/system-config-printer/system-config-printer-1.5.12-r1.ebuild
deleted file mode 100644
index 9a157f3b5f00..000000000000
--- a/app-admin/system-config-printer/system-config-printer-1.5.12-r1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-PYTHON_REQ_USE="xml"
-inherit gnome2 python-single-r1 systemd
-
-DESCRIPTION="Graphical user interface for CUPS administration"
-HOMEPAGE="https://github.com/OpenPrinting/system-config-printer"
-SRC_URI="https://github.com/OpenPrinting/${PN}/releases/download/${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2+"
-KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ppc ppc64 ~sparc x86"
-SLOT="0"
-IUSE="gnome-keyring policykit"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-# Needs cups running, bug 284005
-RESTRICT="test"
-
-# Additional unhandled dependencies
-# gnome-extra/gnome-packagekit[${PYTHON_USEDEP}] with pygobject:2 ?
-# python samba client: smbc
-# selinux: needed for troubleshooting
-COMMON_DEPEND="${PYTHON_DEPS}
- dev-libs/glib:2
- net-print/cups[dbus]
- virtual/libusb:1
- >=virtual/udev-172
- x11-libs/gtk+:3[introspection]
- x11-libs/libnotify[introspection]
- x11-libs/pango[introspection]
-"
-DEPEND="${COMMON_DEPEND}
- app-text/docbook-xml-dtd:4.1.2
- >=app-text/xmlto-0.0.22
- dev-perl/XML-Parser
- dev-util/desktop-file-utils
- dev-util/intltool
- sys-devel/gettext
- virtual/pkgconfig
-"
-RDEPEND="${COMMON_DEPEND}
- $(python_gen_cond_dep '
- dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
- dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
- dev-python/pycups[${PYTHON_MULTI_USEDEP}]
- dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
- dev-python/requests[${PYTHON_MULTI_USEDEP}]
- dev-python/urllib3[${PYTHON_MULTI_USEDEP}]
- ')
- gnome-keyring? ( app-crypt/libsecret[introspection] )
- policykit? ( net-print/cups-pk-helper )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-check-for-null.patch
- "${FILESDIR}"/${P}-fix-abrt-in-udev-configure-printer.patch
-)
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_configure() {
- gnome2_src_configure \
- --enable-nls \
- --with-desktop-vendor=Gentoo \
- --with-udev-rules \
- --with-systemdsystemunitdir=$(systemd_get_systemunitdir)
-}
-
-src_compile() {
- gnome2_src_compile
-}
-
-src_install() {
- gnome2_src_install
- python_fix_shebang "${ED}"
- python_optimize
-}