summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/consul/Manifest1
-rw-r--r--app-admin/consul/consul-1.15.10.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-admin/consul/Manifest b/app-admin/consul/Manifest
index 515723581d44..7d80f2efa108 100644
--- a/app-admin/consul/Manifest
+++ b/app-admin/consul/Manifest
@@ -1,2 +1,3 @@
+DIST consul-1.15.10-vendor.tar.gz 46702348 BLAKE2B a04d6f5a4d2f6f8885207f9f72537d4ea1a3adc5aab64873edf7f710984d3b25a602fb93cecc44ed82249280b51bbe1131701ab09f7ebb1b444c80e013fe271d SHA512 7aade3f90ee689ddca3058f12e7c9f2a691c4eba966993d770d8dc7b171cad54c3c8b6c3f52e03128a8d1b159dd66b6c8b284050c5475d77b51f9a22c4a6af8a
DIST consul-1.15.3-vendor.tar.gz 43434721 BLAKE2B 7595c98cdecf67e9fb412d8fea1d790dc6b1c29f7bc427e1d0872045a05f8873dc6107f196cea04fe0a2f2553d4fbb1f8d501e5e107b2bea3ae841e5d94eda64 SHA512 b69e3a7c1ebb01c7a64f2c6167e63e8a530b81be9aad8b591d0a71f512f5157ba9a564b46f9effe52a5abd3ae61732e7af10c5ba002110f745eb3d94ebcec256
DIST consul-1.15.7-vendor.tar.gz 46252048 BLAKE2B c63d69fb206895c535ffd60ada3589d99ec6aec81d7abe6b27169d4638bcc272f5d7c0b37d0bbe6be54f5e2d32f1e40fa1f4088da7fb4931f0c5c10007838197 SHA512 1e52f133f822cf11ee8498b7e92a7460c74d3ed4736c02e0957e3d950608f4aeaec8e8df7e9eb72ae7d4c31c4dcf5d827c9c42bdc7c4b991be53df22c150658a
diff --git a/app-admin/consul/consul-1.15.10.ebuild b/app-admin/consul/consul-1.15.10.ebuild
new file mode 100644
index 000000000000..7fbf1eb317a7
--- /dev/null
+++ b/app-admin/consul/consul-1.15.10.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd
+
+DESCRIPTION="A tool for service discovery, monitoring and configuration"
+HOMEPAGE="https://www.consul.io"
+GIT_COMMIT="a8dca2405236750fc23fb31dac21507882d111f6"
+
+SRC_URI="https://github.com/zmedico/consul/archive/v${PV}-vendor.tar.gz -> ${P}-vendor.tar.gz"
+
+LICENSE="MPL-2.0 Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT"
+RESTRICT="test"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="dev-go/gox"
+COMMON_DEPEND="
+ acct-group/consul
+ acct-user/consul"
+ DEPEND="${COMMON_DEPEND}"
+ RDEPEND="${COMMON_DEPEND}"
+
+S=${WORKDIR}/${P}-vendor
+
+src_prepare() {
+ default
+ sed -e 's|^GIT_DATE=.*|GIT_DATE=2023-10-31T14:10:44Z|' -i GNUmakefile || die
+}
+
+src_compile() {
+ if use x86; then
+ #924629 pie breaks build on x86
+ GOFLAGS=${GOFLAGS//-buildmode=pie}
+ fi
+ # The dev target sets causes build.sh to set appropriate XC_OS
+ # and XC_ARCH, and skips generation of an unused zip file,
+ # avoiding a dependency on app-arch/zip.
+ GIT_DESCRIBE="v${PV}" \
+ GIT_DIRTY="" \
+ GIT_COMMIT="${GIT_COMMIT}" \
+ emake dev-build
+}
+
+src_install() {
+ dobin bin/consul
+
+ keepdir /etc/consul.d
+ insinto /etc/consul.d
+ doins "${FILESDIR}/"*.json.example
+
+ keepdir /var/log/consul
+ fowners consul:consul /var/log/consul
+
+ newinitd "${FILESDIR}/consul.initd" "${PN}"
+ newconfd "${FILESDIR}/consul.confd" "${PN}"
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+ systemd_dounit "${FILESDIR}/consul.service"
+}