summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.32.53.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 22be21cb8877..9980a34362b9 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -4,3 +4,4 @@ DIST aws-cli-1.32.49.gh.tar.gz 2654398 BLAKE2B fc2e9052b777e1e8bac60621993b55aa0
DIST aws-cli-1.32.50.gh.tar.gz 2654655 BLAKE2B 037a252fcf5b431e63c9c95c8bfeb35df4fa736e49ddd77417b8befeaac97879d859656f0630508fef50da2187dee31ed1bdfe370053b0e5432adbebba4a9b0b SHA512 2528f431a650625b51b2c67dd998163dacd26729bfbc2b03c494c971e106b5652685c1859dba75ec51e5bc33d4b9effd4581aba901626c2a8c665478ba3b6030
DIST aws-cli-1.32.51.gh.tar.gz 2654652 BLAKE2B c245e6435bdd7827399b2076d6c4d50c1fe159f1e4c47fb5974ce149e6d8223db890176e823b1ab58e0844c9fea749a43025b45ae87aa2549f9bf039f2bb4403 SHA512 bd51056e03edc996e5add9bff163f82c8136908c074c3fca0567cbebdbd9bd8c54f14ebd24d2d35ccb8d47312c8c93600ed755efbb07358153262f2815dfd872
DIST aws-cli-1.32.52.gh.tar.gz 2655351 BLAKE2B 625c478990008060edf4c4e523fbca3ec301363b56a43c3724282bcd2f71e796b8de739d1762a2a1c970bc6db0b7e39c57da0abef557dd0e50c8b353f6c2aeb7 SHA512 b4e6b1c50a3b87729c7cd1a7a23ae71d96ce4eb643e8c73be2275f04251873d7af368db98f2cdcea99c9fb6cfae9b9722615c79cb575b0be9a37a77f89485f98
+DIST aws-cli-1.32.53.gh.tar.gz 2656312 BLAKE2B ec9061b4983f7cae038221546376665a1368d017a60f411d8566f45cff5b1a653e7c999cb61d0486f77c6e6b2e0edf73110ab6bda283bdeafbdf5acb88719619 SHA512 2f718538f946c8df11740a5818b4f47170d73d1028aebd8813861ce5d4503046d3cae75d60e64cbb236fd5622240192cb68e61ecd5085e96d13fa6766a92004e
diff --git a/app-admin/awscli/awscli-1.32.53.ebuild b/app-admin/awscli/awscli-1.32.53.ebuild
new file mode 100644
index 000000000000..4a677affdbc4
--- /dev/null
+++ b/app-admin/awscli/awscli-1.32.53.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}