summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/exo/Manifest1
-rw-r--r--app-admin/exo/exo-1.61.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/exo/Manifest b/app-admin/exo/Manifest
index 426f4ddec0b3..a50e06745502 100644
--- a/app-admin/exo/Manifest
+++ b/app-admin/exo/Manifest
@@ -1 +1,2 @@
DIST exo-1.60.0.tar.gz 5506221 BLAKE2B 5b3f424e8572f33b5571582de7c2154edd8d52c9225947623b83bcf6d93dd32529785602aa89184c0083c1a2c7c5a7541ba847d5e6849c53033bebcb210fa3f6 SHA512 18041184e14b5f353477331f9f4fe83834f73e5996ba8124b109518dcaaf3d36b8e8727a011603c4a5e7836f9d4d7380041665317598d470f0456dfb87f2e284
+DIST exo-1.61.0.tar.gz 5536720 BLAKE2B 3828a20d61d8e8c0c37cba4cc2846372ae1174ea1bdb6e99a30f6e526f304cc967dbf1d71be793bda0f666f174d54e694c159d0e2963a83f2b904e70f701eb44 SHA512 eba7b29de67782e560c3d23bbe0008980bd7ac4de1485ec885cf9563d122ff784dad4b55a94d3000064258eb5000041bcf6ed71f10383b212684e1c0bb292b84
diff --git a/app-admin/exo/exo-1.61.0.ebuild b/app-admin/exo/exo-1.61.0.ebuild
new file mode 100644
index 000000000000..6149acedfa18
--- /dev/null
+++ b/app-admin/exo/exo-1.61.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns"
+HOMEPAGE="https://github.com/exoscale/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND="dev-lang/go:="
+RESTRICT="strip"
+QA_FLAGS_IGNORED=".*"
+
+S="${WORKDIR}/cli-${PV}"
+
+src_compile() {
+ go build -mod vendor -o ${PN} || die "build failed"
+}
+
+src_test() {
+ # run at least 'exo version' for test
+ ./exo version > /dev/null 2>&1
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}