summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/alien')
-rw-r--r--app-arch/alien/Manifest1
-rw-r--r--app-arch/alien/alien-8.95-r2.ebuild (renamed from app-arch/alien/alien-8.95-r1.ebuild)17
-rw-r--r--app-arch/alien/alien-8.95.6.ebuild25
-rw-r--r--app-arch/alien/metadata.xml5
4 files changed, 31 insertions, 17 deletions
diff --git a/app-arch/alien/Manifest b/app-arch/alien/Manifest
index fd59649f095b..8dcb3ef90dc6 100644
--- a/app-arch/alien/Manifest
+++ b/app-arch/alien/Manifest
@@ -1 +1,2 @@
+DIST alien-8.95.6.tar.xz 58088 BLAKE2B 5b7467552856d809fc1b43af7de905d7f52629799bfd01dfb7ab61dfbd1c27e0f6f6b8364aa03a925cc6bea74616bf497f4fd195c637d6d1bcd7847a17ab5ccd SHA512 29ed80f249b38b47a26ee9d058d057be8728d18d771c1f847919f296d2c8359fcc33a32912749f2ed77b1214e61f101b75960a82cbd3d76bbb7f205acfd4f152
DIST alien-8.95.tar.xz 56940 BLAKE2B c2f6b71d39800a7bc4ab00bcd50d165855bad4eb1a17fe217aeb302c6b7af701bcd9445276d7e522db7e6c81f1e8d7e9e2ada99f9d7505e6ec958ae87df7c9f7 SHA512 c46d3c82542dc3d96eeabea0f0c7ab5b572acaf67d15e2064ea01df32d69a2cf6e083754be49269df6cd7431ec5b3e09ddcb83fbe2ee17843b22e9cd3e73073c
diff --git a/app-arch/alien/alien-8.95-r1.ebuild b/app-arch/alien/alien-8.95-r2.ebuild
index fac253c4e118..9155c848fb61 100644
--- a/app-arch/alien/alien-8.95-r1.ebuild
+++ b/app-arch/alien/alien-8.95-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit perl-module
@@ -11,7 +11,7 @@ SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${PV}.tar.xz -> ${P}.tar.xz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~alpha amd64 ~hppa ppc ppc64 x86"
+KEYWORDS="~alpha amd64 ~hppa ppc ppc64 ~riscv x86"
IUSE="+bzip2"
RDEPEND="
@@ -19,16 +19,7 @@ RDEPEND="
app-arch/dpkg
dev-util/debhelper
>=app-arch/tar-1.14.91
- bzip2? (
- app-arch/bzip2
- )"
-
+ bzip2? ( app-arch/bzip2 )"
DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}/${P}-tar-extensions.patch" )
-
-src_prepare() {
- default
- sed -e s%'$(VARPREFIX)'%${D}% -e s%'$(PREFIX)'%${D}/usr%g \
- -i "${S}"/Makefile.PL || die "sed failed"
-}
diff --git a/app-arch/alien/alien-8.95.6.ebuild b/app-arch/alien/alien-8.95.6.ebuild
new file mode 100644
index 000000000000..f2d6dfad91e1
--- /dev/null
+++ b/app-arch/alien/alien-8.95.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DESCRIPTION="Converts between the rpm, dpkg, stampede slp, and slackware tgz file formats"
+HOMEPAGE="https://sourceforge.net/projects/alien-pkg-convert"
+SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${PV}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+bzip2"
+
+RDEPEND="
+ app-arch/rpm
+ app-arch/dpkg
+ dev-util/debhelper
+ >=app-arch/tar-1.14.91
+ bzip2? ( app-arch/bzip2 )"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-8.95-tar-extensions.patch" )
diff --git a/app-arch/alien/metadata.xml b/app-arch/alien/metadata.xml
index a71d1bc12f7a..6cab649acb8d 100644
--- a/app-arch/alien/metadata.xml
+++ b/app-arch/alien/metadata.xml
@@ -1,11 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>lordvan@gentoo.org</email>
<name>Thomas Raschbacher</name>
</maintainer>
- <maintainer type="person">
- <email>monsieurp@gentoo.org</email>
- </maintainer>
</pkgmetadata>