summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/file-roller')
-rw-r--r--app-arch/file-roller/Manifest4
-rw-r--r--app-arch/file-roller/file-roller-44.1.ebuild103
-rw-r--r--app-arch/file-roller/file-roller-44.3.ebuild103
-rw-r--r--app-arch/file-roller/file-roller-44.ebuild (renamed from app-arch/file-roller/file-roller-3.32.4.ebuild)51
-rw-r--r--app-arch/file-roller/files/3.36-packages.match (renamed from app-arch/file-roller/files/3.32-packages.match)9
-rw-r--r--app-arch/file-roller/files/file-roller-3.32.4-fno-common.patch27
-rw-r--r--app-arch/file-roller/metadata.xml27
7 files changed, 255 insertions, 69 deletions
diff --git a/app-arch/file-roller/Manifest b/app-arch/file-roller/Manifest
index 181129e97cbe..06e2e2041ad3 100644
--- a/app-arch/file-roller/Manifest
+++ b/app-arch/file-roller/Manifest
@@ -1 +1,3 @@
-DIST file-roller-3.32.4.tar.xz 854444 BLAKE2B 04264e64af8ab4376fa6985683b16be7fef730a4e24044f726933b885aaaa6b630f347a256b09c2ce6183d0a0a392b33b4328715bf6d19cf7128c1980f9f4792 SHA512 16b5ddbdeacf4e9e61265ecff05e8f2e0034147c67ae7355d2442f9b26098ff253d24cb34c8e686c2ac031da6acac8e1e3c8a9f978e1eb2b446b1e045babafc7
+DIST file-roller-44.1.tar.xz 927156 BLAKE2B 60ced1711298989eda90a675095b5e7b8f1e9b84b5f4cf364bce4683ba9eac6a8a4a1857b0248cd9a49ea2161cbc5c2c36df94ebc164e195de528ba50220d1da SHA512 de0d0ce93ecba822ec495227cd484cb164a81f8b5349033d80207acc19584985f0c88bfa766a46468349e2b16b020371e2e6b73b4fb7f2f18f40f115f2391b30
+DIST file-roller-44.3.tar.xz 1042572 BLAKE2B 8fa5c474f96e739f141ee3c94ed002a127c09e941125832f043c914fcdbc1a2306ad1649bb51e9a6207ad7147c7862f0fdc5ad3703a244b447fe4262801107a3 SHA512 940e67cef0a3e71f7c60aea67419666d92c3861b6c7e20dfd50cd055ec590013702b941c938eea3375878a997c377102bc8480d06fd28e0eb8d8f6660ba1df38
+DIST file-roller-44.tar.xz 924236 BLAKE2B 12eebd312afdec8f87141d384d1476be7296073f911791328158af1ab93fcb4092ee79e0c65743c36eaa28e06b5b59503357b6c4cff87b4896d3969a67d08e45 SHA512 d40ac036161397828ded2bab7bdf1c029ef0b53fad65e0922e6eeec40442eb7a9898a7d5c3208f6dfda3ad6f51b0771f248ab64c177769b655493a44c403f824
diff --git a/app-arch/file-roller/file-roller-44.1.ebuild b/app-arch/file-roller/file-roller-44.1.ebuild
new file mode 100644
index 000000000000..6b9c0f7cfa2c
--- /dev/null
+++ b/app-arch/file-roller/file-roller-44.1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson readme.gentoo-r1 xdg
+
+DESCRIPTION="Archive manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/FileRoller"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="gtk-doc +introspection nautilus"
+REQUIRED_USE="gtk-doc? ( introspection )"
+
+# gdk-pixbuf used extensively in the source
+# cairo used in eggtreemultidnd.c
+# pango used in fr-window
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=gui-libs/gtk-4.8.1:4[introspection?]
+ >=gui-libs/libadwaita-1.2:1
+ nautilus? ( >=gnome-base/nautilus-43.0 )
+ >=dev-libs/json-glib-0.14
+ >=app-arch/libarchive-3.2:=
+ introspection? ( dev-libs/gobject-introspection )
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gi-docgen )
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+${PN} is a frontend for several archiving utilities. If you want a
+particular archive format support, see ${HOMEPAGE}
+and install the relevant package. For example:
+7-zip - app-arch/p7zip
+ace - app-arch/unace
+arj - app-arch/arj
+brotli - app-arch/brotli
+cpio - app-alternatives/cpio
+deb - app-arch/dpkg
+iso - app-cdr/cdrtools
+jar,zip - app-arch/zip and app-arch/unzip
+lha - app-arch/lha
+lzop - app-arch/lzop
+lz4 - app-arch/lz4
+rar - app-arch/unrar or app-arch/unar
+rpm - app-arch/rpm
+unstuff - app-arch/stuffit
+zstd - app-arch/zstd
+zoo - app-arch/zoo"
+
+src_prepare() {
+ # File providing Gentoo package names for various archivers
+ cp -v "${FILESDIR}"/3.36-packages.match data/packages.match || die
+
+ default
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Drun-in-place=false
+ $(meson_feature nautilus nautilus-actions)
+ -Dnotification=enabled
+ -Duse_native_appchooser=false
+ -Dpackagekit=false
+ -Dlibarchive=enabled
+ $(meson_feature introspection)
+ $(meson_feature gtk-doc api_docs)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/ || die
+ mv "${ED}"/usr/share/doc/file-roller "${ED}"/usr/share/gtk-doc/file-roller || die
+ fi
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/app-arch/file-roller/file-roller-44.3.ebuild b/app-arch/file-roller/file-roller-44.3.ebuild
new file mode 100644
index 000000000000..6b9c0f7cfa2c
--- /dev/null
+++ b/app-arch/file-roller/file-roller-44.3.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson readme.gentoo-r1 xdg
+
+DESCRIPTION="Archive manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/FileRoller"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="gtk-doc +introspection nautilus"
+REQUIRED_USE="gtk-doc? ( introspection )"
+
+# gdk-pixbuf used extensively in the source
+# cairo used in eggtreemultidnd.c
+# pango used in fr-window
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=gui-libs/gtk-4.8.1:4[introspection?]
+ >=gui-libs/libadwaita-1.2:1
+ nautilus? ( >=gnome-base/nautilus-43.0 )
+ >=dev-libs/json-glib-0.14
+ >=app-arch/libarchive-3.2:=
+ introspection? ( dev-libs/gobject-introspection )
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gi-docgen )
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+${PN} is a frontend for several archiving utilities. If you want a
+particular archive format support, see ${HOMEPAGE}
+and install the relevant package. For example:
+7-zip - app-arch/p7zip
+ace - app-arch/unace
+arj - app-arch/arj
+brotli - app-arch/brotli
+cpio - app-alternatives/cpio
+deb - app-arch/dpkg
+iso - app-cdr/cdrtools
+jar,zip - app-arch/zip and app-arch/unzip
+lha - app-arch/lha
+lzop - app-arch/lzop
+lz4 - app-arch/lz4
+rar - app-arch/unrar or app-arch/unar
+rpm - app-arch/rpm
+unstuff - app-arch/stuffit
+zstd - app-arch/zstd
+zoo - app-arch/zoo"
+
+src_prepare() {
+ # File providing Gentoo package names for various archivers
+ cp -v "${FILESDIR}"/3.36-packages.match data/packages.match || die
+
+ default
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Drun-in-place=false
+ $(meson_feature nautilus nautilus-actions)
+ -Dnotification=enabled
+ -Duse_native_appchooser=false
+ -Dpackagekit=false
+ -Dlibarchive=enabled
+ $(meson_feature introspection)
+ $(meson_feature gtk-doc api_docs)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/ || die
+ mv "${ED}"/usr/share/doc/file-roller "${ED}"/usr/share/gtk-doc/file-roller || die
+ fi
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/app-arch/file-roller/file-roller-3.32.4.ebuild b/app-arch/file-roller/file-roller-44.ebuild
index ddcfe39897c2..dcb5b5610d53 100644
--- a/app-arch/file-roller/file-roller-3.32.4.ebuild
+++ b/app-arch/file-roller/file-roller-44.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit gnome.org gnome2-utils meson readme.gentoo-r1 xdg
DESCRIPTION="Archive manager for GNOME"
@@ -9,23 +10,24 @@ HOMEPAGE="https://wiki.gnome.org/Apps/FileRoller"
LICENSE="GPL-2+ CC-BY-SA-3.0"
SLOT="0"
-IUSE="libnotify nautilus packagekit"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ~arm arm64 ~loong ~ppc ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
+IUSE="gtk-doc +introspection nautilus"
+REQUIRED_USE="gtk-doc? ( introspection )"
# gdk-pixbuf used extensively in the source
# cairo used in eggtreemultidnd.c
# pango used in fr-window
RDEPEND="
- >=app-arch/libarchive-3:=
- >=dev-libs/glib-2.36:2
+ >=dev-libs/glib-2.38:2
+ >=gui-libs/gtk-4.8.1:4[introspection?]
+ >=gui-libs/libadwaita-1.2:1
+ nautilus? ( >=gnome-base/nautilus-43.0 )
>=dev-libs/json-glib-0.14
- >=x11-libs/gtk+-3.13.2:3
+ >=app-arch/libarchive-3.2:=
+ introspection? ( dev-libs/gobject-introspection )
x11-libs/cairo
x11-libs/gdk-pixbuf:2
x11-libs/pango
- libnotify? ( >=x11-libs/libnotify-0.4.3:= )
- nautilus? ( >=gnome-base/nautilus-2.22.2 )
- packagekit? ( app-admin/packagekit-base )
"
DEPEND="${RDEPEND}"
BDEPEND="
@@ -33,6 +35,7 @@ BDEPEND="
dev-util/itstool
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
+ gtk-doc? ( dev-util/gi-docgen )
"
DISABLE_AUTOFORMATTING="yes"
@@ -44,7 +47,7 @@ and install the relevant package. For example:
ace - app-arch/unace
arj - app-arch/arj
brotli - app-arch/brotli
-cpio - app-arch/cpio
+cpio - app-alternatives/cpio
deb - app-arch/dpkg
iso - app-cdr/cdrtools
jar,zip - app-arch/zip and app-arch/unzip
@@ -54,33 +57,37 @@ lz4 - app-arch/lz4
rar - app-arch/unrar or app-arch/unar
rpm - app-arch/rpm
unstuff - app-arch/stuffit
+zstd - app-arch/zstd
zoo - app-arch/zoo"
-PATCHES=(
- # https://gitlab.gnome.org/GNOME/file-roller/merge_requests/31
- "${FILESDIR}"/${PN}-3.32.4-fno-common.patch
-)
-
src_prepare() {
# File providing Gentoo package names for various archivers
- cp -v "${FILESDIR}"/3.32-packages.match data/packages.match || die
+ cp -v "${FILESDIR}"/3.36-packages.match data/packages.match || die
- xdg_src_prepare
+ default
+ xdg_environment_reset
}
src_configure() {
local emesonargs=(
-Drun-in-place=false
- $(meson_use nautilus nautilus-actions)
- $(meson_use libnotify notification)
- $(meson_use packagekit)
- -Dlibarchive=true
+ $(meson_feature nautilus nautilus-actions)
+ -Dnotification=enabled
+ -Duse_native_appchooser=false
+ -Dpackagekit=false
+ -Dlibarchive=enabled
+ $(meson_feature introspection)
+ $(meson_feature gtk-doc api_docs)
)
meson_src_configure
}
src_install() {
meson_src_install
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/ || die
+ mv "${ED}"/usr/share/doc/file-roller "${ED}"/usr/share/gtk-doc/file-roller || die
+ fi
readme.gentoo_create_doc
}
diff --git a/app-arch/file-roller/files/3.32-packages.match b/app-arch/file-roller/files/3.36-packages.match
index 09f1513968e3..c84d4517a59b 100644
--- a/app-arch/file-roller/files/3.32-packages.match
+++ b/app-arch/file-roller/files/3.36-packages.match
@@ -3,9 +3,9 @@ arj=app-arch/arj
binutils=sys-devel/binutils
brotli=app-arch/brotli
bzip2=app-arch/bzip2
-cpio=app-arch/cpio
+cpio=app-alternatives/cpio
dpkg=app-arch/dpkg
-genisoimage=virtual/cdrtools
+genisoimage=app-cdr/cdrtools
gzip=app-arch/gzip
lha=app-arch/lha
lrzip=app-arch/lrzip
@@ -20,8 +20,6 @@ p7zip-rar=
rar=app-arch/rar
rpm=app-arch/rpm
rzip=app-arch/rzip
-zip=app-arch/zip
-zoo=app-arch/zoo
tar=app-arch/tar
unace=app-arch/unace
unalz=
@@ -31,4 +29,7 @@ unsquashfs=sys-fs/squashfs-tools
unstaff=
unzip=app-arch/unzip
xz=app-arch/xz-utils
+zip=app-arch/zip
+zoo=app-arch/zoo
+zstd=app-arch/zstd
diff --git a/app-arch/file-roller/files/file-roller-3.32.4-fno-common.patch b/app-arch/file-roller/files/file-roller-3.32.4-fno-common.patch
deleted file mode 100644
index 9239810c901d..000000000000
--- a/app-arch/file-roller/files/file-roller-3.32.4-fno-common.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 55fa0fb287e7fb7cee336cac0a6c1a94e505dc84 Mon Sep 17 00:00:00 2001
-From: David Seifert <soap@gentoo.org>
-Date: Wed, 19 Feb 2020 13:18:18 +0100
-Subject: [PATCH] Fix compiling with GCC 10
-
-* GCC 10 defaults to `-fno-common`.
-
-Bug: https://bugs.gentoo.org/706728
----
- src/fr-application.c | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/src/fr-application.c b/src/fr-application.c
-index c148c4f9..00ebe552 100644
---- a/src/fr-application.c
-+++ b/src/fr-application.c
-@@ -42,7 +42,6 @@
- #define SERVICE_TIMEOUT 10
-
-
--gint ForceDirectoryCreation;
- static char **remaining_args;
- static char *arg_add_to = NULL;
- static int arg_add = FALSE;
---
-2.25.1
-
diff --git a/app-arch/file-roller/metadata.xml b/app-arch/file-roller/metadata.xml
index c6657ffe3f7f..95e520228548 100644
--- a/app-arch/file-roller/metadata.xml
+++ b/app-arch/file-roller/metadata.xml
@@ -1,18 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
- <use>
- <flag name="nautilus">Build contextual menu extension for
- <pkg>gnome-base/nautilus</pkg>.</flag>
- <flag name="packagekit">Enable support for the distro-neutral package
- manager GUI PackageKit</flag>
- </use>
- <upstream>
- <remote-id type="sourceforge">fileroller</remote-id>
- <remote-id type="cpe">cpe:/a:paolo_bacchilega:file_roller</remote-id>
- </upstream>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <use>
+ <flag name="nautilus">Build contextual menu extension for <pkg>gnome-base/nautilus</pkg>.</flag>
+ </use>
+ <upstream>
+ <remote-id type="cpe">cpe:/a:paolo_bacchilega:file_roller</remote-id>
+ <remote-id type="gnome-gitlab">GNOME/file-roller</remote-id>
+ </upstream>
</pkgmetadata>