summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/innoextract')
-rw-r--r--app-arch/innoextract/Manifest3
-rw-r--r--app-arch/innoextract/files/innoextract-1.9-boost-1.85.0.patch21
-rw-r--r--app-arch/innoextract/files/innoextract-1.9-fix-linkage.patch17
-rw-r--r--app-arch/innoextract/innoextract-1.7.ebuild35
-rw-r--r--app-arch/innoextract/innoextract-1.9.ebuild (renamed from app-arch/innoextract/innoextract-1.8.ebuild)11
-rw-r--r--app-arch/innoextract/metadata.xml10
6 files changed, 50 insertions, 47 deletions
diff --git a/app-arch/innoextract/Manifest b/app-arch/innoextract/Manifest
index 149c2f7dd31a..6bf2e9dbdd77 100644
--- a/app-arch/innoextract/Manifest
+++ b/app-arch/innoextract/Manifest
@@ -1,2 +1 @@
-DIST innoextract-1.7.tar.gz 195123 BLAKE2B 5dffb49da7ec3f8e48a70d0809e059179e84610dd50397b8ca472b9f5a96a5edd0cf36898f0e513b3f70685829e2b8edbd7d7932c9f1b47706c2929f596867e5 SHA512 5e92625a411a4351dd4639d4b63e8664519c6697122a0679c010412e94a1e5da95324c33be16211f91c2b25b8cea40fe4ba4da5e19c12d0c27a4916159465ca4
-DIST innoextract-1.8.tar.gz 205553 BLAKE2B 223f0997ae00f2a854912befca25595b275ece8e0fe4f4451d6aa3db14ad1ed98474a19c919c56d958e99c0175be647d3eb3c14d7869504405a7bf6db3a35957 SHA512 2c68009333f02a8a677c084e9c95c835d84a73e60c9b0c70fee5f23fd9a7a640cf2aa7e0476c55579774ac7079498fa24668f9388493bbc13415ff5a5b06ac9c
+DIST innoextract-1.9.tar.gz 206931 BLAKE2B 1d5f0d13a7cd52262b277263f061ecab85a3419197bceb22938a0d10000578603cc2c2b972a45474027cfea8e43b8bf89d680035034785210842477b147811fa SHA512 2b18f7bb7f50744bcb1bdcd25e57e0760193b179c77b55e0f63c537e55afc98de3b0380da3cae470ce97660ed41a7ffbb48c8c25329c9ce9b3811d9aec74bcde
diff --git a/app-arch/innoextract/files/innoextract-1.9-boost-1.85.0.patch b/app-arch/innoextract/files/innoextract-1.9-boost-1.85.0.patch
new file mode 100644
index 000000000000..23e4554fc53e
--- /dev/null
+++ b/app-arch/innoextract/files/innoextract-1.9-boost-1.85.0.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/930495
+https://github.com/dscharrer/innoextract/pull/169
+
+From 264c2fe6b84f90f6290c670e5f676660ec7b2387 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Bernhard=20Rosenkr=C3=A4nzer?= <bero@lindev.ch>
+Date: Thu, 28 Mar 2024 15:11:40 +0100
+Subject: [PATCH] Fix build with boost 1.85
+
+As of boost 1.85-beta1, boost/filesystem/directory.hpp is no longer
+implicitly included by boost/filesystem/operations.hpp. Include it
+explicitly.
+--- a/src/stream/slice.cpp
++++ b/src/stream/slice.cpp
+@@ -27,6 +27,7 @@
+ #include <boost/cstdint.hpp>
+ #include <boost/algorithm/string/predicate.hpp>
+ #include <boost/filesystem/operations.hpp>
++#include <boost/filesystem/directory.hpp>
+ #include <boost/range/size.hpp>
+
+ #include "util/console.hpp"
diff --git a/app-arch/innoextract/files/innoextract-1.9-fix-linkage.patch b/app-arch/innoextract/files/innoextract-1.9-fix-linkage.patch
new file mode 100644
index 000000000000..79ecd805f49d
--- /dev/null
+++ b/app-arch/innoextract/files/innoextract-1.9-fix-linkage.patch
@@ -0,0 +1,17 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index be9f08f..f7ce42a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -316,12 +316,6 @@ if(NOT MSVC)
+
+ endif()
+
+-if($ENV{PORTAGE_REPO_NAME} MATCHES "gentoo")
+- # Meh
+- unset(LIBRARIES)
+-endif()
+-
+-
+ # All sources:
+
+ set(DOCUMENTATION 0) # never build these
diff --git a/app-arch/innoextract/innoextract-1.7.ebuild b/app-arch/innoextract/innoextract-1.7.ebuild
deleted file mode 100644
index de8c21556274..000000000000
--- a/app-arch/innoextract/innoextract-1.7.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="A tool to unpack installers created by Inno Setup"
-HOMEPAGE="http://constexpr.org/innoextract/"
-SRC_URI="http://constexpr.org/innoextract/files/${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug +iconv +lzma"
-
-RDEPEND="
- dev-libs/boost:=
- iconv? ( virtual/libiconv )
- lzma? ( app-arch/xz-utils )"
-DEPEND="${RDEPEND}"
-
-DOCS=( README.md CHANGELOG )
-
-src_configure() {
- local mycmakeargs=(
- -DDEBUG=$(usex debug)
- -DSET_OPTIMIZATION_FLAGS=OFF
- -DSTRICT_USE=ON
- -DUSE_LZMA=$(usex lzma)
- -DWITH_CONV=$(usex iconv iconv builtin)
- )
-
- cmake-utils_src_configure
-}
diff --git a/app-arch/innoextract/innoextract-1.8.ebuild b/app-arch/innoextract/innoextract-1.9.ebuild
index 5cf62179ba29..2259b5ffb6d3 100644
--- a/app-arch/innoextract/innoextract-1.8.ebuild
+++ b/app-arch/innoextract/innoextract-1.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,15 +11,20 @@ SRC_URI="https://constexpr.org/innoextract/files/${P}.tar.gz"
LICENSE="ZLIB"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="amd64 ~arm arm64 ~m68k ppc64 x86"
IUSE="debug +iconv +lzma"
RDEPEND="
- dev-libs/boost:=
+ dev-libs/boost:=[bzip2,zlib]
iconv? ( virtual/libiconv )
lzma? ( app-arch/xz-utils )"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.9-fix-linkage.patch"
+ "${FILESDIR}/${PN}-1.9-boost-1.85.0.patch"
+)
+
src_configure() {
local mycmakeargs=(
-DDEBUG=$(usex debug)
diff --git a/app-arch/innoextract/metadata.xml b/app-arch/innoextract/metadata.xml
index 6d8f19bb3ddf..0500dc2295e4 100644
--- a/app-arch/innoextract/metadata.xml
+++ b/app-arch/innoextract/metadata.xml
@@ -1,13 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>daniel@constexpr.org</email>
- <name>Daniel Scharrer</name>
- </maintainer>
- <maintainer type="project">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
</maintainer>
<use>
<flag name="debug">Enable debug logging and the --debug command-line option</flag>