summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/lbzip2/lbzip2-2.5_p20181227-r2.ebuild')
-rw-r--r--app-arch/lbzip2/lbzip2-2.5_p20181227-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-arch/lbzip2/lbzip2-2.5_p20181227-r2.ebuild b/app-arch/lbzip2/lbzip2-2.5_p20181227-r2.ebuild
new file mode 100644
index 000000000000..4272c9ad02b3
--- /dev/null
+++ b/app-arch/lbzip2/lbzip2-2.5_p20181227-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Parallel bzip2 utility"
+HOMEPAGE="https://github.com/kjn/lbzip2/"
+SRC_URI="https://dev.gentoo.org/~whissi/dist/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="debug static"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.3-s_isreg.patch
+ "${FILESDIR}"/${P}-fix-unaligned.patch
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ local myeconfargs=(
+ $(use_enable debug tracing)
+ )
+ econf "${myeconfargs[@]}"
+}