summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/mt-st/mt-st-1.7.ebuild')
-rw-r--r--app-arch/mt-st/mt-st-1.7.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-arch/mt-st/mt-st-1.7.ebuild b/app-arch/mt-st/mt-st-1.7.ebuild
new file mode 100644
index 000000000000..82ebcff528b1
--- /dev/null
+++ b/app-arch/mt-st/mt-st-1.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Control magnetic tape drive operation"
+HOMEPAGE="https://github.com/iustin/mt-st"
+SRC_URI="https://github.com/iustin/mt-st/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dosbin mt stinit
+ doman mt.1 stinit.8
+ dodoc README* stinit.def.examples
+}