summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/pax')
-rw-r--r--app-arch/pax/files/pax-3.4-sysmacros.patch12
-rw-r--r--app-arch/pax/pax-3.4.12.16-r1.ebuild1
-rw-r--r--app-arch/pax/pax-3.4.12.16.ebuild1
3 files changed, 14 insertions, 0 deletions
diff --git a/app-arch/pax/files/pax-3.4-sysmacros.patch b/app-arch/pax/files/pax-3.4-sysmacros.patch
new file mode 100644
index 000000000000..3aede97ec06f
--- /dev/null
+++ b/app-arch/pax/files/pax-3.4-sysmacros.patch
@@ -0,0 +1,12 @@
+not all C libs pull in this header via sys/types.h for major()/etc...
+
+--- a/src/extern.h
++++ b/src/extern.h
+@@ -38,6 +38,7 @@
+ */
+
+ #include <sys/cdefs.h>
++#include <sys/sysmacros.h>
+
+ /*
+ * ar_io.c
diff --git a/app-arch/pax/pax-3.4.12.16-r1.ebuild b/app-arch/pax/pax-3.4.12.16-r1.ebuild
index 0e8133ff3ffc..a14e869a02b6 100644
--- a/app-arch/pax/pax-3.4.12.16-r1.ebuild
+++ b/app-arch/pax/pax-3.4.12.16-r1.ebuild
@@ -26,6 +26,7 @@ src_prepare() {
rpm_spec_epatch ../${PN}.spec
epatch "${FILESDIR}"/pax-3.4-x32.patch
epatch "${FILESDIR}"/pax-3.4-fix-fts-includes.patch
+ epatch "${FILESDIR}"/pax-3.4-sysmacros.patch
sed -i configure.in \
-e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' \
-e '/AC_PROG_RANLIB/a AC_PROG_MKDIR_P' \
diff --git a/app-arch/pax/pax-3.4.12.16.ebuild b/app-arch/pax/pax-3.4.12.16.ebuild
index 973229e65c8c..8d485e6dc3e7 100644
--- a/app-arch/pax/pax-3.4.12.16.ebuild
+++ b/app-arch/pax/pax-3.4.12.16.ebuild
@@ -25,6 +25,7 @@ S=${WORKDIR}/${MY_P}
src_prepare() {
rpm_spec_epatch ../${PN}.spec
epatch "${FILESDIR}"/pax-3.4-x32.patch
+ epatch "${FILESDIR}"/pax-3.4-sysmacros.patch
sed -i configure.in -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
eautoreconf
}