summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/rpm2targz/rpm2targz-2021.03.16.ebuild')
-rw-r--r--app-arch/rpm2targz/rpm2targz-2021.03.16.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-arch/rpm2targz/rpm2targz-2021.03.16.ebuild b/app-arch/rpm2targz/rpm2targz-2021.03.16.ebuild
new file mode 100644
index 000000000000..ee07654a10f6
--- /dev/null
+++ b/app-arch/rpm2targz/rpm2targz-2021.03.16.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Convert a .rpm file to a .tar.gz archive"
+HOMEPAGE="http://www.slackware.com/config/packages.php"
+SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+
+LICENSE="BSD-1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-arch/cpio"
+
+src_configure() {
+ tc-export CC
+}