summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/rzip')
-rw-r--r--app-arch/rzip/files/rzip-2.1-configure-clang16.patch13
-rw-r--r--app-arch/rzip/metadata.xml2
-rw-r--r--app-arch/rzip/rzip-2.1-r5.ebuild (renamed from app-arch/rzip/rzip-2.1-r3.ebuild)13
3 files changed, 20 insertions, 8 deletions
diff --git a/app-arch/rzip/files/rzip-2.1-configure-clang16.patch b/app-arch/rzip/files/rzip-2.1-configure-clang16.patch
new file mode 100644
index 000000000000..b2749ed45785
--- /dev/null
+++ b/app-arch/rzip/files/rzip-2.1-configure-clang16.patch
@@ -0,0 +1,13 @@
+See also: https://bugzilla.redhat.com/show_bug.cgi?id=2144458
+
+--- a/configure.in
++++ b/configure.in
+@@ -36,7 +36,7 @@ AC_CACHE_CHECK([for large file support],rzip_cv_HAVE_LARGE_FILES,[
+ AC_TRY_RUN([
+ #include <stdio.h>
+ #include <sys/types.h>
+-main() { return (sizeof(off_t) == 4); }],
++int main(void) { return (sizeof(off_t) == 4); }],
+ rzip_cv_HAVE_LARGE_FILES=yes,
+ rzip_cv_HAVE_LARGE_FILES=no,
+ rzip_cv_HAVE_LARGE_FILES=cross)])
diff --git a/app-arch/rzip/metadata.xml b/app-arch/rzip/metadata.xml
index 6f49eba8f496..85e4ed814fa2 100644
--- a/app-arch/rzip/metadata.xml
+++ b/app-arch/rzip/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
</pkgmetadata>
diff --git a/app-arch/rzip/rzip-2.1-r3.ebuild b/app-arch/rzip/rzip-2.1-r5.ebuild
index 915c6deeef2b..cf8b6d722684 100644
--- a/app-arch/rzip/rzip-2.1-r3.ebuild
+++ b/app-arch/rzip/rzip-2.1-r5.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
@@ -11,20 +11,19 @@ SRC_URI="https://rzip.samba.org/ftp/rzip/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 hppa ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
+KEYWORDS="amd64 ~hppa ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
RDEPEND="app-arch/bzip2:="
-DEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-2.1-darwin.patch
"${FILESDIR}"/${PN}-2.1-CVE-2017-8364.patch
+ "${FILESDIR}"/${PN}-2.1-configure-clang16.patch
)
src_prepare() {
default
- mv configure.{in,ac} || die
eautoreconf
}
@@ -33,7 +32,7 @@ pkg_postinst() {
ewarn "compression of large files it didn't set the right file size, so"
ewarn "if you have any reason to believe that your archive was compressed "
ewarn "with an old Gentoo rzip, please refer to "
- ewarn " https://bugs.gentoo.org/show_bug.cgi?id=217552 "
+ ewarn " https://bugs.gentoo.org/217552"
ewarn "for the rzip-handle-broken-archive.patch patch to rescue your"
ewarn "data."
ewarn