summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/stormlib')
-rw-r--r--app-arch/stormlib/Manifest3
-rw-r--r--app-arch/stormlib/files/stormlib-9.24-gnuinstalldirs.patch (renamed from app-arch/stormlib/files/stormlib-9.23-gnuinstalldirs.patch)24
-rw-r--r--app-arch/stormlib/metadata.xml5
-rw-r--r--app-arch/stormlib/stormlib-9.24.ebuild (renamed from app-arch/stormlib/stormlib-9.23-r1.ebuild)15
-rw-r--r--app-arch/stormlib/stormlib-9.25.ebuild44
5 files changed, 71 insertions, 20 deletions
diff --git a/app-arch/stormlib/Manifest b/app-arch/stormlib/Manifest
index 99bea60fa5bd..4081bddc12d0 100644
--- a/app-arch/stormlib/Manifest
+++ b/app-arch/stormlib/Manifest
@@ -1 +1,2 @@
-DIST StormLib-9.23.tar.gz 605295 BLAKE2B 2489e309f218f3e5c5069b56856415cc5985efb2352f36a33530442d539c786262b7c55d134dd67db3098981b1ad98ce8bfa77a16f86d28f326831b09752b705 SHA512 c851159596e252b42facdbac9c52f7477c61de35b44054ab608a22b42e7dc3b4179f50ba9d8cbd30448ed7787cc74e7efd2e08faafdd91289136cd91399d4f09
+DIST StormLib-9.24.tar.gz 625374 BLAKE2B 3647580b1b048e284ade2fb23aed53cac76a89a0180908f48fc99d571e702d876de37e42a47b3d351c72e6fa905fc02f4b8fa691a6840013637e1560e9acafcb SHA512 38694685edfc9c53ff1e303109831b6a791200b9db275043bca8b3bbe7cc928cf0ce9cf554c6758f693da453b85e6385d277ae9add7af867c13488d77432cde5
+DIST StormLib-9.25.tar.gz 603875 BLAKE2B c7da242d039f5a49e8abd295b42e639fc540c77ee4bf8f210610d56940d1d35f19ea267dccde89e50f744218527f4c521e1d320f24e8fe3a0e0739ee899aa023 SHA512 0da78bda4bb89637da892fc73a0673b8a5f852ede4fdceba1029431d24dd1e59db9bfceafab1c5fb642e4b5d0d15d9865f7a138bfb190ce0c2d3601b22dd3023
diff --git a/app-arch/stormlib/files/stormlib-9.23-gnuinstalldirs.patch b/app-arch/stormlib/files/stormlib-9.24-gnuinstalldirs.patch
index 66b8f91183f0..f50dcaa82601 100644
--- a/app-arch/stormlib/files/stormlib-9.23-gnuinstalldirs.patch
+++ b/app-arch/stormlib/files/stormlib-9.24-gnuinstalldirs.patch
@@ -1,6 +1,6 @@
-From f89f1341cf59f7098af985ecd683d5e0407d2dc7 Mon Sep 17 00:00:00 2001
+From 8cb9b76a5e85ffab436f7b01ecfc0a0dea7547af Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Sun, 20 Dec 2020 10:52:34 +0100
+Date: Mon, 3 Oct 2022 20:49:31 +0200
Subject: [PATCH] cmake: Use GNUInstallDirs for configurable install
directories
@@ -13,24 +13,24 @@ rather than 'lib'.
1 file changed, 7 insertions(+), 6 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index bd8d336..2b09191 100644
+index 9cf1050..b10c2c5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -4,6 +4,7 @@ cmake_minimum_required(VERSION 2.8.12)
- set(LIBRARY_NAME storm)
+@@ -7,6 +7,7 @@ set(CMAKE_CXX_EXTENSIONS OFF)
+ set(CMAKE_CXX_STANDARD_REQUIRED ON)
include(CMakeDependentOption)
+include(GNUInstallDirs)
option(BUILD_SHARED_LIBS "Compile shared libraries" OFF)
option(STORM_SKIP_INSTALL "Skip installing files" OFF)
-@@ -331,12 +332,12 @@ endif()
+@@ -357,12 +358,12 @@ endif()
if (NOT STORM_SKIP_INSTALL)
- install(TARGETS ${LIBRARY_NAME}
-- RUNTIME DESTINATION bin
-- LIBRARY DESTINATION lib
-- ARCHIVE DESTINATION lib
+ install(TARGETS ${LIBRARY_NAME}
+- RUNTIME DESTINATION bin
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
@@ -42,7 +42,7 @@ index bd8d336..2b09191 100644
#CPack configurtion
SET(CPACK_GENERATOR "DEB" "RPM")
-@@ -369,6 +370,6 @@ endif()
+@@ -395,6 +396,6 @@ endif()
if(STORM_BUILD_TESTS)
add_executable(StormLib_test ${TEST_SRC_FILES})
target_link_libraries(StormLib_test ${LIBRARY_NAME})
@@ -51,5 +51,5 @@ index bd8d336..2b09191 100644
endif()
--
-2.29.2
+2.37.3
diff --git a/app-arch/stormlib/metadata.xml b/app-arch/stormlib/metadata.xml
index 0319eec4c8be..5b84358fc1cd 100644
--- a/app-arch/stormlib/metadata.xml
+++ b/app-arch/stormlib/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>mgorny@gentoo.org</email>
<name>Michał Górny</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">ladislav-zezula/StormLib</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-arch/stormlib/stormlib-9.23-r1.ebuild b/app-arch/stormlib/stormlib-9.24.ebuild
index 484b8ef3e37f..fa8ef965a8f1 100644
--- a/app-arch/stormlib/stormlib-9.23-r1.ebuild
+++ b/app-arch/stormlib/stormlib-9.24.ebuild
@@ -1,7 +1,7 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake
@@ -9,10 +9,12 @@ MY_P=StormLib-${PV}
DESCRIPTION="Library to read and write MPQ archives (Diablo, StarCraft)"
HOMEPAGE="
http://www.zezula.net/en/mpq/stormlib.html
- https://github.com/ladislav-zezula/StormLib"
+ https://github.com/ladislav-zezula/StormLib/
+"
SRC_URI="
https://github.com/ladislav-zezula/StormLib/archive/v${PV}.tar.gz
- -> ${MY_P}.tar.gz"
+ -> ${MY_P}.tar.gz
+"
S=${WORKDIR}/${MY_P}
LICENSE="MIT"
@@ -22,11 +24,12 @@ KEYWORDS="~amd64 ~x86"
RDEPEND="
app-arch/bzip2:=
dev-libs/libtomcrypt:=[libtommath]
- sys-libs/zlib:="
+ sys-libs/zlib:=
+"
DEPEND=${RDEPEND}
PATCHES=(
- "${FILESDIR}"/stormlib-9.23-gnuinstalldirs.patch
+ "${FILESDIR}"/stormlib-9.24-gnuinstalldirs.patch
)
src_configure() {
diff --git a/app-arch/stormlib/stormlib-9.25.ebuild b/app-arch/stormlib/stormlib-9.25.ebuild
new file mode 100644
index 000000000000..dbb04664be09
--- /dev/null
+++ b/app-arch/stormlib/stormlib-9.25.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_P=StormLib-${PV}
+DESCRIPTION="Library to read and write MPQ archives (Diablo, StarCraft)"
+HOMEPAGE="
+ http://www.zezula.net/en/mpq/stormlib.html
+ https://github.com/ladislav-zezula/StormLib/
+"
+SRC_URI="
+ https://github.com/ladislav-zezula/StormLib/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-arch/bzip2:=
+ dev-libs/libtomcrypt:=[libtommath]
+ sys-libs/zlib:=
+"
+DEPEND=${RDEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/stormlib-9.24-gnuinstalldirs.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ # interactive test app
+ -DSTORM_BUILD_TESTS=OFF
+ -DWITH_LIBTOMCRYPT=ON
+ )
+
+ cmake_src_configure
+}