summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/stormlib')
-rw-r--r--app-arch/stormlib/Manifest2
-rw-r--r--app-arch/stormlib/files/stormlib-9.26-gnuinstalldirs.patch58
-rw-r--r--app-arch/stormlib/stormlib-9.26.ebuild (renamed from app-arch/stormlib/stormlib-9.24.ebuild)5
3 files changed, 62 insertions, 3 deletions
diff --git a/app-arch/stormlib/Manifest b/app-arch/stormlib/Manifest
index 4081bddc12d0..fbcc9dd070d8 100644
--- a/app-arch/stormlib/Manifest
+++ b/app-arch/stormlib/Manifest
@@ -1,2 +1,2 @@
-DIST StormLib-9.24.tar.gz 625374 BLAKE2B 3647580b1b048e284ade2fb23aed53cac76a89a0180908f48fc99d571e702d876de37e42a47b3d351c72e6fa905fc02f4b8fa691a6840013637e1560e9acafcb SHA512 38694685edfc9c53ff1e303109831b6a791200b9db275043bca8b3bbe7cc928cf0ce9cf554c6758f693da453b85e6385d277ae9add7af867c13488d77432cde5
DIST StormLib-9.25.tar.gz 603875 BLAKE2B c7da242d039f5a49e8abd295b42e639fc540c77ee4bf8f210610d56940d1d35f19ea267dccde89e50f744218527f4c521e1d320f24e8fe3a0e0739ee899aa023 SHA512 0da78bda4bb89637da892fc73a0673b8a5f852ede4fdceba1029431d24dd1e59db9bfceafab1c5fb642e4b5d0d15d9865f7a138bfb190ce0c2d3601b22dd3023
+DIST StormLib-9.26.tar.gz 610223 BLAKE2B 670296e5d1f9d2b22d5f6cad214ff7076fdc5078c7aa6d13458e06b4b44b62acf2bd68689a05c630db024ea3d54bbc5be14855d757a1b31475664a593fb5db60 SHA512 5f0ce75019cfbe3a2dfc07ea312825e2babf226dbf8aa77ed60456862ae739ac4689cbe7d4a185cdc148ad9910fd8137d3f11c04ffe6c532bbdacb08838ecfba
diff --git a/app-arch/stormlib/files/stormlib-9.26-gnuinstalldirs.patch b/app-arch/stormlib/files/stormlib-9.26-gnuinstalldirs.patch
new file mode 100644
index 000000000000..95c46221fece
--- /dev/null
+++ b/app-arch/stormlib/files/stormlib-9.26-gnuinstalldirs.patch
@@ -0,0 +1,58 @@
+From 2e1e371c0a9eeaa015615b5a9f6826ec071a2e4a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Mon, 10 Jun 2024 14:41:37 +0200
+Subject: [PATCH] cmake: Use GNUInstallDirs for configurable install
+ directories
+
+Use the standard GNUInstallDirs CMake module to provide configurable
+install directories rather than hardcoding `bin`, `lib`, etc. Most
+importantly, this fixes install on modern 64-bit systems that use
+`lib64` rather than `lib`.
+---
+ CMakeLists.txt | 15 ++++++++-------
+ 1 file changed, 8 insertions(+), 7 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4758091..6546b69 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -7,6 +7,7 @@ set(CMAKE_CXX_EXTENSIONS OFF)
+ set(CMAKE_CXX_STANDARD_REQUIRED ON)
+
+ include(CMakeDependentOption)
++include(GNUInstallDirs)
+
+ option(BUILD_SHARED_LIBS "Compile shared libraries" OFF)
+ option(STORM_SKIP_INSTALL "Skip installing files" OFF)
+@@ -360,14 +361,14 @@ endif()
+ if (NOT STORM_SKIP_INSTALL)
+ install(TARGETS ${LIBRARY_NAME}
+ EXPORT ${PROJECT_NAME}Config
+- RUNTIME DESTINATION bin
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib
++ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ FRAMEWORK DESTINATION /Library/Frameworks
+- PUBLIC_HEADER DESTINATION include
+- INCLUDES DESTINATION include)
++ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
++ INCLUDES DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+
+- install(EXPORT ${PROJECT_NAME}Config NAMESPACE ${PROJECT_NAME}:: DESTINATION share/${PROJECT_NAME})
++ install(EXPORT ${PROJECT_NAME}Config NAMESPACE ${PROJECT_NAME}:: DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/${PROJECT_NAME})
+
+ #CPack configurtion
+ SET(CPACK_GENERATOR "DEB" "RPM")
+@@ -401,6 +402,6 @@ if(STORM_BUILD_TESTS)
+ find_package(ALSA REQUIRED)
+ add_executable(StormLib_test ${TEST_SRC_FILES})
+ target_link_libraries(StormLib_test ${LIBRARY_NAME} ${ALSA_LIBRARIES})
+- install(TARGETS StormLib_test RUNTIME DESTINATION bin)
++ install(TARGETS StormLib_test RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+ endif()
+
+--
+2.45.2
+
diff --git a/app-arch/stormlib/stormlib-9.24.ebuild b/app-arch/stormlib/stormlib-9.26.ebuild
index fa8ef965a8f1..4987b7dfdfc8 100644
--- a/app-arch/stormlib/stormlib-9.24.ebuild
+++ b/app-arch/stormlib/stormlib-9.26.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2022 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -29,7 +29,8 @@ RDEPEND="
DEPEND=${RDEPEND}
PATCHES=(
- "${FILESDIR}"/stormlib-9.24-gnuinstalldirs.patch
+ # https://github.com/ladislav-zezula/StormLib/pull/352
+ "${FILESDIR}/${P}-gnuinstalldirs.patch"
)
src_configure() {