summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/unarj/unarj-2.65.ebuild')
-rw-r--r--app-arch/unarj/unarj-2.65.ebuild25
1 files changed, 12 insertions, 13 deletions
diff --git a/app-arch/unarj/unarj-2.65.ebuild b/app-arch/unarj/unarj-2.65.ebuild
index d579027e1d33..ec1cba73be8e 100644
--- a/app-arch/unarj/unarj-2.65.ebuild
+++ b/app-arch/unarj/unarj-2.65.ebuild
@@ -1,7 +1,9 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-inherit eutils toolchain-funcs
+EAPI=6
+
+inherit toolchain-funcs
DESCRIPTION="Utility for opening arj archives"
HOMEPAGE="http://www.arjsoftware.com/"
@@ -12,21 +14,18 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
IUSE=""
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-CAN-2004-0947.patch
- epatch "${FILESDIR}"/${P}-sanitation.patch
- epatch "${FILESDIR}"/${P}-gentoo-fbsd.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-CAN-2004-0947.patch
+ "${FILESDIR}"/${P}-sanitation.patch
+ "${FILESDIR}"/${P}-gentoo-fbsd.patch
+ "${FILESDIR}"/${PN}-2.65-Wformat-security.patch
+)
-src_compile() {
+src_configure() {
tc-export CC
- emake || die
}
src_install() {
- dobin unarj || die 'dobin failed'
- dodoc unarj.txt technote.txt || die 'dodoc failed'
+ dobin unarj
+ dodoc unarj.txt technote.txt
}