summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/unshield')
-rw-r--r--app-arch/unshield/Manifest1
-rw-r--r--app-arch/unshield/unshield-1.5.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/app-arch/unshield/Manifest b/app-arch/unshield/Manifest
index e577bd24fc38..a50d4d0da250 100644
--- a/app-arch/unshield/Manifest
+++ b/app-arch/unshield/Manifest
@@ -1 +1,2 @@
DIST unshield-1.4.3.tar.gz 58822 BLAKE2B 89e23462610d7ffd25358cb1d9f234b5c80a580deb60e85610ddacc8e3aa92420cb0e885e80375089e93786565824813f23c54f7c4d60b7773f23d174c98e5d7 SHA512 2f058e0a28d0497e2afe231ded1b1bb16745401398eb1035e628d263351b10a1343c9664f3937b8912755db9dc5236a1b43e9bcba596affb7aa8b036f49382aa
+DIST unshield-1.5.1.tar.gz 67454 BLAKE2B 7def714e8d74312de8b822b0add92a803fadda0394252587219c7379791ec33680bf9430c6811e71354fd2e9ccc91e28697e31a2377ecc16aa43edea1ce30e57 SHA512 acb130c461bed66dc3804394be067a68aea96a7cd20b348e713f64a11bf642b74f68fc172f220a9790b44573abbe01ed4585191158f27c40e863918a7342c1ca
diff --git a/app-arch/unshield/unshield-1.5.1.ebuild b/app-arch/unshield/unshield-1.5.1.ebuild
new file mode 100644
index 000000000000..5531273c3857
--- /dev/null
+++ b/app-arch/unshield/unshield-1.5.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="InstallShield CAB file extractor"
+HOMEPAGE="https://github.com/twogood/unshield"
+SRC_URI="https://github.com/twogood/unshield/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+# OpenSSL is detected at build time, and used to determine
+# whether or not a hand-rolled md5 implementation is used. The build
+# system prefers OpenSSL's implementation if it's available, and OpenSSL
+# is common enough, so we prefer it too. Since the dependency is
+# automagic (there's no way to hide it), we require OpenSSL
+# unconditionally.
+
+DEPEND="
+ dev-libs/openssl:0=
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"