summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/upx')
-rw-r--r--app-arch/upx/Manifest3
-rw-r--r--app-arch/upx/metadata.xml6
-rw-r--r--app-arch/upx/upx-4.1.0.ebuild30
-rw-r--r--app-arch/upx/upx-4.2.3.ebuild (renamed from app-arch/upx/upx-3.96.ebuild)40
4 files changed, 55 insertions, 24 deletions
diff --git a/app-arch/upx/Manifest b/app-arch/upx/Manifest
index 1464eec2d85e..58606ce802e6 100644
--- a/app-arch/upx/Manifest
+++ b/app-arch/upx/Manifest
@@ -1 +1,2 @@
-DIST upx-3.96-src.tar.xz 792524 BLAKE2B 21af85dbcfdd1bf0151a653c865db13c9f30b9de0b9b4b94557ddd55736c7053dd829c5d72b9a7e5aa94a71ecc0151145dd66d7d98ded178c50ff7357d0ba442 SHA512 2d4d1be21d274d9bfdee9b9815396f5e5ff0bcdfb781b7be5fafa4d1e224028e412ec5f5ba607c482671aae27ccf9069abb2db0fb58f78f3a102a51897df2b11
+DIST upx-4.1.0-src.tar.xz 1267708 BLAKE2B ef7884028a97b1d7e542fc27756b705582786a22d193b1eef40d0db16580958baddc3baa44429b5ba2c0f7b5d4d0f4f79fdeb777af016b962b07c7639a319090 SHA512 de8306e833198d7f470c050b05c6111a50ea94f2e757c1006433742871ccd93fd7412f942cd776e9eac6c91e379545d72f070f3fe928e75e5d5092b766474f8c
+DIST upx-4.2.3-src.tar.xz 1283824 BLAKE2B 2b53bf68196c35c05eb930760ad20446fbcde9b15e1e9261e2eb7553dc1c8ede48db952cd7c5bc6de5861ac98f9f62bb1d348806731fea7dad1e532fc7e1e636 SHA512 b9ebda5d3372132bb861e0dd035829b16e4c06900f68af182895f17975493707d78cbabc63060e581de1ce149bb5129d883f6e6abcde0413c0bf474db919f5fd
diff --git a/app-arch/upx/metadata.xml b/app-arch/upx/metadata.xml
index b1093ce78b05..066d2703e71d 100644
--- a/app-arch/upx/metadata.xml
+++ b/app-arch/upx/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
+ <maintainer type="person" proxied="yes">
<email>azamat.hackimov@gmail.com</email>
<name>Azamat H. Hackimov</name>
</maintainer>
- <maintainer type="project">
+ <maintainer type="project" proxied="proxy">
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
diff --git a/app-arch/upx/upx-4.1.0.ebuild b/app-arch/upx/upx-4.1.0.ebuild
new file mode 100644
index 000000000000..44d1747d853c
--- /dev/null
+++ b/app-arch/upx/upx-4.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Ultimate Packer for eXecutables (free version using UCL compression and not NRV)"
+HOMEPAGE="https://upx.github.io/"
+SRC_URI="https://github.com/upx/upx/releases/download/v${PV}/${P}-src.tar.xz"
+S="${WORKDIR}/${P}-src"
+
+LICENSE="GPL-2+ UPX-exception" # Read the exception before applying any patches
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc x86"
+
+RDEPEND="!app-arch/upx-bin"
+BDEPEND="app-arch/xz-utils[extra-filters]"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUPX_CONFIG_DISABLE_WERROR=ON
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ # Don't run tests in parallel, #878977
+ cmake_src_test -j1
+}
diff --git a/app-arch/upx/upx-3.96.ebuild b/app-arch/upx/upx-4.2.3.ebuild
index c9a668ebacec..83d85276513a 100644
--- a/app-arch/upx/upx-3.96.ebuild
+++ b/app-arch/upx/upx-4.2.3.ebuild
@@ -1,34 +1,34 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit toolchain-funcs
+inherit cmake
DESCRIPTION="Ultimate Packer for eXecutables (free version using UCL compression and not NRV)"
HOMEPAGE="https://upx.github.io/"
SRC_URI="https://github.com/upx/upx/releases/download/v${PV}/${P}-src.tar.xz"
+S="${WORKDIR}/${P}-src"
LICENSE="GPL-2+ UPX-exception" # Read the exception before applying any patches
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-RDEPEND=">=dev-libs/ucl-1.03
- sys-libs/zlib
- !app-arch/upx-bin"
-DEPEND="${RDEPEND}
- dev-lang/perl"
-
-S="${WORKDIR}/${P}-src"
-
-src_compile() {
- tc-export CXX
- emake CXXFLAGS_WERROR="" all
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="!app-arch/upx-bin"
+BDEPEND="app-arch/xz-utils[extra-filters]"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUPX_CONFIG_DISABLE_GITREV=ON
+ -DUPX_CONFIG_DISABLE_WERROR=ON
+ -DUPX_CONFIG_CMAKE_DISABLE_TEST=$(usex !test)
+ )
+ cmake_src_configure
}
-src_install() {
- newbin src/upx.out upx
- dodoc BUGS NEWS PROJECTS README* THANKS doc/*.txt doc/upx.html
- doman doc/upx.1
+src_test() {
+ # Don't run tests in parallel, #878977
+ cmake_src_test -j1
}