summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/zstd/zstd-1.0.0-r1.ebuild')
-rw-r--r--app-arch/zstd/zstd-1.0.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-arch/zstd/zstd-1.0.0-r1.ebuild b/app-arch/zstd/zstd-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..e1979156b186
--- /dev/null
+++ b/app-arch/zstd/zstd-1.0.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="zstd fast compression library"
+HOMEPAGE="http://facebook.github.io/zstd/"
+SRC_URI="https://github.com/facebook/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+src_compile() {
+ emake PREFIX="/usr" zstd
+ cd lib && emake PREFIX="/usr" libzstd
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+}