summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/zstd/zstd-1.5.4-r2.ebuild')
-rw-r--r--app-arch/zstd/zstd-1.5.4-r2.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/app-arch/zstd/zstd-1.5.4-r2.ebuild b/app-arch/zstd/zstd-1.5.4-r2.ebuild
index fc646ce06670..3d848f5e471a 100644
--- a/app-arch/zstd/zstd-1.5.4-r2.ebuild
+++ b/app-arch/zstd/zstd-1.5.4-r2.ebuild
@@ -25,13 +25,26 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
-PATCHES=(
+MESON_PATCHES=(
# Workaround until Valgrind bugfix lands
"${FILESDIR}"/${PN}-1.5.4-no-find-valgrind.patch
# Allow building tests w/o programs (useful for multilib)
"${FILESDIR}"/${PN}-1.5.4-tests-no-programs.patch
)
+PATCHES=(
+ # Fix build w/o zlib, bug #894058
+ "${FILESDIR}"/${P}-fix-no-zlib-build.patch
+)
+
+src_prepare() {
+ cd "${WORKDIR}"/${P} || die
+ default
+
+ cd "${S}" || die
+ eapply "${MESON_PATCHES[@]}"
+}
+
multilib_src_configure() {
local native_file="${T}"/meson.${CHOST}.${ABI}.ini.local