summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/makeself/Manifest1
-rw-r--r--app-arch/makeself/makeself-2.5.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-arch/makeself/Manifest b/app-arch/makeself/Manifest
index 4c489fab56ef..b4929442c908 100644
--- a/app-arch/makeself/Manifest
+++ b/app-arch/makeself/Manifest
@@ -1 +1,2 @@
DIST makeself-2.4.5.tar.gz 39012 BLAKE2B f79cf1c087e89c4fd09f328fb795a3f8a78ee38060dbbd1590e3dcdf22a346b0c12bf6837d1636efadb2a66f6a762308de7ee9dd2fc62a7c88d417d257c5f0f6 SHA512 1dae74586f6bd5afb526801b7ffa7fc7962ff74b0f190cdd51da93c21421864b72f5fe18090cb2ff6ad27f0907fbf3aeb5545f3f70e33dbc9e505a78505f5f90
+DIST makeself-2.5.0.tar.gz 43996 BLAKE2B 60e5b7a55bd03e45d25753600ddb4e0e15f05eabc95db18f1a9da10308d018bb913ba1e8bc264c3bd828c3d229aca34fae4ab1682bf6cf59c591a6fdef186061 SHA512 cd0ce98579f00a02f9559848b39e0a6efea9df1866073d419f0b6560034cc186ed8315f8b4589e03f626b040727d9ae646bc2abaebe4f4da556b87617bdd770f
diff --git a/app-arch/makeself/makeself-2.5.0.ebuild b/app-arch/makeself/makeself-2.5.0.ebuild
new file mode 100644
index 000000000000..adf02e657005
--- /dev/null
+++ b/app-arch/makeself/makeself-2.5.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Shell script that generates a self-extractible tar.gz"
+HOMEPAGE="https://makeself.io/"
+SRC_URI="https://github.com/megastep/makeself/archive/refs/tags/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+# NB: The test framework requires bashunit (which isn't a big deal), but the
+# tests themselves are not of great quality. You should avoid running them
+# yourself as they like to run commands like gpg against your own ~/ settings.
+RESTRICT="test"
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+src_compile() { :; }
+
+src_install() {
+ dobin makeself-header.sh makeself.sh
+ dosym makeself.sh /usr/bin/makeself
+ doman makeself.1
+ dodoc README.md
+}
+
+pkg_postinst() {
+ optfeature "bzip3 support" app-arch/bzip3
+ optfeature "lz4 support" app-arch/lz4
+ optfeature "lzop support" app-arch/lzop
+ optfeature "pbzip2 support" app-arch/pbzip2
+ optfeature "pigz support" app-arch/pigz
+ optfeature "zstd support" app-arch/zstd
+
+ # Also bzip2 and xz are supported but they are in @system.
+}