summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/amanda')
-rw-r--r--app-backup/amanda/amanda-3.5.1-r5.ebuild (renamed from app-backup/amanda/amanda-3.5.1-r3.ebuild)28
-rw-r--r--app-backup/amanda/files/amanda-3.5.1-configure-clang16.patch22
-rw-r--r--app-backup/amanda/metadata.xml6
3 files changed, 40 insertions, 16 deletions
diff --git a/app-backup/amanda/amanda-3.5.1-r3.ebuild b/app-backup/amanda/amanda-3.5.1-r5.ebuild
index 9498a6165145..7496f6cc59e6 100644
--- a/app-backup/amanda/amanda-3.5.1-r3.ebuild
+++ b/app-backup/amanda/amanda-3.5.1-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,13 +7,13 @@ inherit autotools perl-module systemd toolchain-funcs
DESCRIPTION="The Advanced Maryland Automatic Network Disk Archiver"
HOMEPAGE="http://www.amanda.org/"
-SRC_URI="mirror://sourceforge/amanda/${P}.tar.gz"
+SRC_URI="https://downloads.sourceforge.net/amanda/${P}.tar.gz"
LICENSE="HPND BSD BSD-2 GPL-2+ GPL-3+"
SLOT="0"
-IUSE="curl gnuplot ipv6 kerberos minimal ndmp nls readline s3 samba systemd xfs"
-
+IUSE="curl gnuplot ipv6 kerberos minimal ndmp nls readline s3 samba selinux systemd xfs"
KEYWORDS="amd64 ppc ppc64 ~sparc x86"
+
DEPEND="
acct-group/amanda
acct-user/amanda
@@ -23,9 +23,9 @@ DEPEND="
dev-lang/perl:=
dev-perl/Encode-Locale
dev-perl/JSON
- net-misc/openssh
+ virtual/openssh
sys-libs/readline:=
- virtual/awk
+ app-alternatives/awk
kerberos? ( app-crypt/mit-krb5 )
ndmp? ( net-libs/libtirpc:= )
nls? ( virtual/libintl )
@@ -42,7 +42,10 @@ DEPEND="
virtual/mailx
gnuplot? ( sci-visualization/gnuplot )
)"
-RDEPEND="${DEPEND}"
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-amanda )
+"
BDEPEND="
app-text/docbook-xsl-stylesheets
app-text/docbook-xml-dtd
@@ -51,7 +54,10 @@ BDEPEND="
virtual/pkgconfig
nls? ( sys-devel/gettext )"
-PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${PN}-3.5.1-configure-clang16.patch
+)
MYFILESDIR="${T}/files"
ENVDIR="/etc/env.d"
@@ -77,7 +83,7 @@ amanda_variable_setup() {
local currentamanda
# Grab the current settings
- currentamanda="$(set | egrep "^AMANDA_" | grep -v '^AMANDA_ENV_SETTINGS' | xargs)"
+ currentamanda="$(set | grep -E "^AMANDA_" | grep -v '^AMANDA_ENV_SETTINGS' | xargs)"
# First we set the defaults
AMANDA_GROUP_NAME=amanda
@@ -106,7 +112,7 @@ amanda_variable_setup() {
# Now pull in the old stuff
if [[ -f ${EROOT}${ENVDIR}/${ENVDFILE} ]]; then
# We don't just source it as we don't want everything in there.
- eval $(egrep "^AMANDA_" "${EROOT}${ENVDIR}/${ENVDFILE}" | grep -v '^AMANDA_ENV_SETTINGS')
+ eval $(grep -E "^AMANDA_" "${EROOT}${ENVDIR}/${ENVDFILE}" | grep -v '^AMANDA_ENV_SETTINGS')
fi
# Re-apply the new settings if any
@@ -152,7 +158,7 @@ src_prepare() {
# places for us to work in
mkdir -p "${MYFILESDIR}" || die
# Now we store the settings we just created
- set | egrep "^AMANDA_" | grep -v '^AMANDA_ENV_SETTINGS' > "${TMPENVFILE}" || die
+ set | grep -E "^AMANDA_" | grep -v '^AMANDA_ENV_SETTINGS' > "${TMPENVFILE}" || die
# Prepare our custom files
einfo "Building custom configuration files"
diff --git a/app-backup/amanda/files/amanda-3.5.1-configure-clang16.patch b/app-backup/amanda/files/amanda-3.5.1-configure-clang16.patch
new file mode 100644
index 000000000000..a95c8ed55aed
--- /dev/null
+++ b/app-backup/amanda/files/amanda-3.5.1-configure-clang16.patch
@@ -0,0 +1,22 @@
+https://github.com/zmanda/amanda/pull/220
+
+From 74610ac5522caa779b30323f1c731775083c5bbc Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Fri, 14 Apr 2023 15:45:16 +0200
+Subject: [PATCH] configure: Avoid an implicit int in the IPv6 test
+
+Otherwise, the test fails unconditionally with compilers that
+do not support implicit ints (a language feature that was removed with
+the C99 language revision).
+--- a/config/amanda/ipv6.m4
++++ b/config/amanda/ipv6.m4
+@@ -85,7 +85,7 @@ AC_DEFUN([AMANDA_CHECK_IPV6],
+ #include <sys/socket.h>
+ #include <errno.h>
+
+-main()
++int main(void)
+ {
+ int aa;
+ aa = socket(AF_INET6, SOCK_STREAM, 0);
+
diff --git a/app-backup/amanda/metadata.xml b/app-backup/amanda/metadata.xml
index 7b00f7116667..8372298b14c7 100644
--- a/app-backup/amanda/metadata.xml
+++ b/app-backup/amanda/metadata.xml
@@ -1,14 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>robbat2@gentoo.org</email>
<name>Robin H. Johnson</name>
</maintainer>
- <maintainer type="person" proxied="yes">
- <email>lists@xunil.at</email>
- <name>Stefan G. Weichinger</name>
- </maintainer>
<maintainer type="project" proxied="proxy">
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>