summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/borgbackup')
-rw-r--r--app-backup/borgbackup/Manifest4
-rw-r--r--app-backup/borgbackup/borgbackup-1.1.11-r2.ebuild44
-rw-r--r--app-backup/borgbackup/borgbackup-1.1.13.ebuild44
-rw-r--r--app-backup/borgbackup/borgbackup-1.1.14.ebuild44
-rw-r--r--app-backup/borgbackup/borgbackup-1.2.8.ebuild53
-rw-r--r--app-backup/borgbackup/borgbackup-9999.ebuild44
-rw-r--r--app-backup/borgbackup/metadata.xml12
7 files changed, 58 insertions, 187 deletions
diff --git a/app-backup/borgbackup/Manifest b/app-backup/borgbackup/Manifest
index 8c31065c9000..cec374466abc 100644
--- a/app-backup/borgbackup/Manifest
+++ b/app-backup/borgbackup/Manifest
@@ -1,3 +1 @@
-DIST borgbackup-1.1.11.tar.gz 3718055 BLAKE2B ea03d538bd7936cc12705f73c3f8e63dc28167f1930e84bdd04fc13bcc34c2b9f35e7e6ed945ba20b647dbdefe12c66c04645414c7efc974e53a312e3dff6991 SHA512 cf629f31d38d27ce6350670ff27b4937f2f30eddf9e0cd9209cd9d57a4ffa653f5a291ea1e1c79614dd2c08bcf5c50bc3e4e0f222e0d3cd1bbfb2d756b4a4573
-DIST borgbackup-1.1.13.tar.gz 3754457 BLAKE2B 3d3dce66ad685fbde53cb78e288b4edc53af449ed54379e5f0b9ab3b10d8cf43ae983de5abeccb1874fbf1283f3e2796ac35ff9de349905d03d0b0c560f4fa93 SHA512 2480dba6c842659a248361b35b478120e50df3525b8f07d89dac4e78369bb1dad2679b9efa6a4d6f38637759666095dc2dcbb7750edccd97972e2c8980a51b84
-DIST borgbackup-1.1.14.tar.gz 3769460 BLAKE2B b5a7025d9f7f0764d6532e9e0fd867b3e4c8bac3c584f7a83331a5e7ec39fda14f3f82465e9bf483596453b7cd96bffac3f273ba6171ed109e8a83fb4a1d766e SHA512 2aae851d38ec2431cd09f9390b3afa41ec44c2891a3698b01f036cebc5b64d7b7f328d7c95bf30fc29016b4bd2d2ada2613f895091e22148f3d4861f4facd35f
+DIST borgbackup-1.2.8.tar.gz 4369117 BLAKE2B f230274189716e6ecb8f73d10caa13e683e63c9d9f50c5b6235fc666a0f64f3048421e76e5b57626144c37d37d28c4371b368f780f5e32055f62d5ff10954c19 SHA512 9a62e5eec894ebffe928a08c9a0cceebde084f16524d363a3c3be01d908a7eceaea8fa11eac422acc0fdb2534d79d1ee5ec5d9167e1086f334af6a28887616d5
diff --git a/app-backup/borgbackup/borgbackup-1.1.11-r2.ebuild b/app-backup/borgbackup/borgbackup-1.1.11-r2.ebuild
deleted file mode 100644
index cc59a1e188bb..000000000000
--- a/app-backup/borgbackup/borgbackup-1.1.11-r2.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/${PN}/borg.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="amd64 x86"
-fi
-
-DESCRIPTION="Deduplicating backup program with compression and authenticated encryption"
-HOMEPAGE="https://borgbackup.readthedocs.io/"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="libressl"
-
-# Unfortunately we have a file conflict with app-office/borg, bug #580402
-RDEPEND="
- !!app-office/borg
- app-arch/lz4
- virtual/acl
- dev-python/llfuse[${PYTHON_USEDEP}]
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
-"
-
-DEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- ${RDEPEND}
-"
-
-src_install() {
- distutils-r1_src_install
- doman docs/man/*
-}
diff --git a/app-backup/borgbackup/borgbackup-1.1.13.ebuild b/app-backup/borgbackup/borgbackup-1.1.13.ebuild
deleted file mode 100644
index 7867c0219e0c..000000000000
--- a/app-backup/borgbackup/borgbackup-1.1.13.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/${PN}/borg.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="amd64 ~ppc64 x86"
-fi
-
-DESCRIPTION="Deduplicating backup program with compression and authenticated encryption"
-HOMEPAGE="https://borgbackup.readthedocs.io/"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="libressl"
-
-# Unfortunately we have a file conflict with app-office/borg, bug #580402
-RDEPEND="
- !!app-office/borg
- app-arch/lz4
- virtual/acl
- dev-python/llfuse[${PYTHON_USEDEP}]
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
-"
-
-DEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- ${RDEPEND}
-"
-
-src_install() {
- distutils-r1_src_install
- doman docs/man/*
-}
diff --git a/app-backup/borgbackup/borgbackup-1.1.14.ebuild b/app-backup/borgbackup/borgbackup-1.1.14.ebuild
deleted file mode 100644
index 6b2cd5162b06..000000000000
--- a/app-backup/borgbackup/borgbackup-1.1.14.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/${PN}/borg.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc64 ~x86"
-fi
-
-DESCRIPTION="Deduplicating backup program with compression and authenticated encryption"
-HOMEPAGE="https://borgbackup.readthedocs.io/"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="libressl"
-
-# Unfortunately we have a file conflict with app-office/borg, bug #580402
-RDEPEND="
- !!app-office/borg
- app-arch/lz4
- virtual/acl
- dev-python/llfuse[${PYTHON_USEDEP}]
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
-"
-
-DEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- ${RDEPEND}
-"
-
-src_install() {
- distutils-r1_src_install
- doman docs/man/*
-}
diff --git a/app-backup/borgbackup/borgbackup-1.2.8.ebuild b/app-backup/borgbackup/borgbackup-1.2.8.ebuild
new file mode 100644
index 000000000000..ac351d5e5724
--- /dev/null
+++ b/app-backup/borgbackup/borgbackup-1.2.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1 pypi
+
+DESCRIPTION="Deduplicating backup program with compression and authenticated encryption"
+HOMEPAGE="https://borgbackup.readthedocs.io/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
+
+# "import file mismatch" when in S, "attempted relative import with no
+# known parent package" when in BUILD_DIR/install/.../borg/testsuite.
+# Needs work.
+RESTRICT="test"
+
+DEPEND="app-arch/lz4
+ app-arch/zstd
+ dev-libs/openssl:0=
+ >=dev-libs/xxhash-0.8.1
+ virtual/acl"
+# borgbackup is *very* picky about which msgpack it work with,
+# check setup.py on bumps.
+RDEPEND="${DEPEND}
+ ~dev-python/msgpack-1.0.8[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyfuse3[${PYTHON_USEDEP}]"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ doman docs/man/*
+
+ dobashcomp scripts/shell_completions/bash/borg
+
+ insinto /usr/share/zsh/site-functions
+ doins scripts/shell_completions/zsh/_borg
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins scripts/shell_completions/fish/borg.fish
+}
diff --git a/app-backup/borgbackup/borgbackup-9999.ebuild b/app-backup/borgbackup/borgbackup-9999.ebuild
deleted file mode 100644
index 6b2cd5162b06..000000000000
--- a/app-backup/borgbackup/borgbackup-9999.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/${PN}/borg.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc64 ~x86"
-fi
-
-DESCRIPTION="Deduplicating backup program with compression and authenticated encryption"
-HOMEPAGE="https://borgbackup.readthedocs.io/"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="libressl"
-
-# Unfortunately we have a file conflict with app-office/borg, bug #580402
-RDEPEND="
- !!app-office/borg
- app-arch/lz4
- virtual/acl
- dev-python/llfuse[${PYTHON_USEDEP}]
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
-"
-
-DEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- ${RDEPEND}
-"
-
-src_install() {
- distutils-r1_src_install
- doman docs/man/*
-}
diff --git a/app-backup/borgbackup/metadata.xml b/app-backup/borgbackup/metadata.xml
index aacb2bc191d6..17284e4eaf25 100644
--- a/app-backup/borgbackup/metadata.xml
+++ b/app-backup/borgbackup/metadata.xml
@@ -1,13 +1,9 @@
-<?xml version='1.0' encoding='UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>blueness@gentoo.org</email>
- <name>Anthony G. Basile</name>
- </maintainer>
- <maintainer type="person">
- <email>slashbeast@gentoo.org</email>
- <name>Piotr Karbowski</name>
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
</maintainer>
<upstream>
<remote-id type="github">borgbackup/borg</remote-id>