summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/btrbk/btrbk-9999.ebuild')
-rw-r--r--app-backup/btrbk/btrbk-9999.ebuild31
1 files changed, 22 insertions, 9 deletions
diff --git a/app-backup/btrbk/btrbk-9999.ebuild b/app-backup/btrbk/btrbk-9999.ebuild
index f82156e37d50..dfefb0fe16b4 100644
--- a/app-backup/btrbk/btrbk-9999.ebuild
+++ b/app-backup/btrbk/btrbk-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit systemd
@@ -11,35 +11,47 @@ if [[ ${PV} == "9999" ]] ; then
SRC_URI=""
else
SRC_URI="https://digint.ch/download/btrbk/releases/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi
DESCRIPTION="Tool for creating snapshots and remote backups of btrfs subvolumes"
HOMEPAGE="https://digint.ch/btrbk/"
+
LICENSE="GPL-3+"
SLOT="0"
-IUSE="+mbuffer +doc"
-
-DEPEND="doc? ( >=dev-ruby/asciidoctor-1.5.7 )"
+IUSE="+mbuffer +doc +lsbtr"
-RDEPEND="dev-lang/perl
- net-misc/openssh
+RDEPEND="
+ dev-lang/perl
+ >=sys-fs/btrfs-progs-4.12
+ virtual/openssh
mbuffer? ( >=sys-block/mbuffer-20180505 )
- >=sys-fs/btrfs-progs-4.12"
+"
+BDEPEND="
+ doc? (
+ || (
+ app-text/asciidoc
+ >=dev-ruby/asciidoctor-1.5.7
+ )
+ )
+"
src_compile() {
emake clean
use doc && emake -C doc
}
+
src_install() {
local targets="install-bin install-etc install-share install-systemd"
use doc && targets="${targets} install-man install-doc"
+ use lsbtr && targets="${targets} install-bin-links"
emake \
DESTDIR="${D}" \
DOCDIR="/usr/share/doc/${PF}" \
SYSTEMDDIR="$(systemd_get_systemunitdir)" \
${targets}
}
+
pkg_preinst() {
if has_version "<${CATEGORY}/${PN}-0.26.0" ; then
upgrade_0_26_0_warning="1"
@@ -48,6 +60,7 @@ pkg_preinst() {
upgrade_0_27_0_warning="1"
fi
}
+
pkg_postinst() {
if [[ "${upgrade_0_26_0_warning}" == "1" ]]; then
ewarn "If you are using raw targets, make sure to run the"