summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/burp')
-rw-r--r--app-backup/burp/Manifest3
-rw-r--r--app-backup/burp/burp-2.3.30.ebuild115
-rw-r--r--app-backup/burp/burp-3.1.4.ebuild (renamed from app-backup/burp/burp-2.2.18-r1.ebuild)61
-rw-r--r--app-backup/burp/files/burp-2.1.20-protocol1_by_default.patch24
-rw-r--r--app-backup/burp/metadata.xml10
5 files changed, 42 insertions, 171 deletions
diff --git a/app-backup/burp/Manifest b/app-backup/burp/Manifest
index 30083c4b933e..b6427e2bd489 100644
--- a/app-backup/burp/Manifest
+++ b/app-backup/burp/Manifest
@@ -1,2 +1 @@
-DIST burp-2.2.18.tar.gz 632805 BLAKE2B 6106aa4bd96db035ad5893c2fe314537e620a67519295fdf99efaf2c5a639bedd15b4c8d95caa3daa3072dfac28a1ba7fd7bb4f949d9ea2b70bd13060a22f2c6 SHA512 beb14c61ace6d61b98a10fc4e6709eec9722e28990de862eef6a75984f9fbd0f903c5fe64d20ed84c95528a9889bc22618ba6d2318318cf5d515b35688db0a4d
-DIST burp-2.3.30.tar.gz 617064 BLAKE2B 62aa65da16155d2a321d4ef700a83000e9754eeee53ad7605b97c589a09e1168cd4cece3076d2c4660c098967f5b19056875b5aa4f226f135a17965fc099bb44 SHA512 c315c30c064073f864058d1ec9341b6e800964f308fa5ea298759e35a58ff27a198a3b6886cc04692bc259f1cfe5a5e077542fd45d3e89813541af2e4ca03533
+DIST burp-3.1.4.tar.gz 549879 BLAKE2B bf70051a658700fab60182b97b7ce8540fbd85ad1264ee09c9fa5b5a99046f391b91cd8673097ef869c6b762aea6d8fecdedb38425dca9e6bcbb1f2c2afa96fb SHA512 3aa9fb1512f985fa99e7cb9a45502bbdbf513935e0c62fa4327f0e6cb68d3840f59bfe1b38a7c2419b3e69bc04aef36c223313897c2e45e94f3be3f9d41714db
diff --git a/app-backup/burp/burp-2.3.30.ebuild b/app-backup/burp/burp-2.3.30.ebuild
deleted file mode 100644
index 34645f772590..000000000000
--- a/app-backup/burp/burp-2.3.30.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools systemd
-
-DESCRIPTION="Network backup and restore client and server for Unix and Windows"
-HOMEPAGE="https://burp.grke.org/"
-SRC_URI="https://github.com/grke/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="AGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="acl ipv6 libressl test xattr"
-
-RESTRICT="!test? ( test )"
-
-CDEPEND=" acct-group/burp
- acct-user/burp
- dev-libs/uthash
- net-libs/librsync
- sys-libs/ncurses:0=
- sys-libs/zlib
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- acl? ( sys-apps/acl )
- xattr? ( sys-apps/attr )"
-DEPEND="${CDEPEND}
- virtual/pkgconfig
- test? ( dev-libs/check )"
-RDEPEND="${CDEPEND}
- virtual/logger"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.1.20-no_mkdir_run.patch
- "${FILESDIR}"/${PN}-2.1.20-protocol1_by_default.patch
- "${FILESDIR}"/${PN}-2.0.54-server_user.patch
-)
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --localstatedir=/var
- --sysconfdir=/etc/burp
- --enable-largefile
- $(use_enable acl)
- $(use_enable ipv6)
- $(use_enable xattr)
- )
- # --runstatedir option will only work from autoconf-2.70 onwards
- runstatedir='/run' \
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- keepdir /var/spool/burp
- fowners -R root:${PN} /var/spool/burp
- fperms 0770 /var/spool/burp
-
- emake DESTDIR="${D}" install-configs
- fowners -R root:${PN} /etc/burp
- fperms 0750 /etc/burp
- fperms 0640 /etc/burp/burp-server.conf
- fperms 0750 /etc/burp/clientconfdir
-
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- systemd_dounit "${FILESDIR}"/${PN}.service
-}
-
-pkg_postinst() {
- ewarn
- ewarn "You are installing a development version of burp. These versions contain"
- ewarn "new features but might have unexpected issues. It is recommended by upstream"
- ewarn "to use the current stable version (i.e. currently the 2.2 branch) instead."
- ewarn
-
- elog "Burp ebuilds now support the autoupgrade mechanism in both"
- elog "client and server mode. In both cases it is disabled by"
- elog "default. You almost certainly do NOT want to enable it in"
- elog "client mode because upgrades obtained this way will not be"
- elog "managed by Portage."
-
- if [[ ! -e /etc/burp/CA/index.txt ]]; then
- elog ""
- elog "At first run burp server will generate DH parameters and SSL"
- elog "certificates. You should adjust configuration before."
- elog "Server configuration is located at"
- elog ""
- elog " /etc/burp/burp-server.conf"
- elog ""
- fi
-
- # According to PMS this can be a space-separated list of version
- # numbers, even though in practice it is typically just one.
- local oldver
- for oldver in ${REPLACING_VERSIONS}; do
- if [[ $(ver_cut 1 ${oldver}) -lt 2 ]]; then
- ewarn "Starting with version 2.0.54 we no longer patch bedup to use"
- ewarn "the server config file by default. If you use bedup, please"
- ewarn "update your scripts to invoke it as"
- ewarn ""
- ewarn " bedup -c /etc/burp/burp-server.conf"
- ewarn ""
- ewarn "Otherwise deduplication will not work!"
- break
- fi
- done
-}
diff --git a/app-backup/burp/burp-2.2.18-r1.ebuild b/app-backup/burp/burp-3.1.4.ebuild
index 7c633b85f4bf..8c7a5924016a 100644
--- a/app-backup/burp/burp-2.2.18-r1.ebuild
+++ b/app-backup/burp/burp-3.1.4.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools systemd
@@ -12,30 +12,32 @@ SRC_URI="https://github.com/grke/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="AGPL-3"
SLOT="0"
KEYWORDS="amd64 ~arm x86"
-IUSE="acl ipv6 libressl test xattr"
+IUSE="acl test xattr"
RESTRICT="!test? ( test )"
-CDEPEND=" acct-group/burp
+COMMON_DEPEND="acct-group/burp
acct-user/burp
dev-libs/uthash
- net-libs/librsync
+ dev-libs/openssl:0=
+ net-libs/librsync:=
sys-libs/ncurses:0=
+ sys-libs/libcap
sys-libs/zlib
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
+ virtual/libcrypt:=
acl? ( sys-apps/acl )
xattr? ( sys-apps/attr )"
-DEPEND="${CDEPEND}
- virtual/pkgconfig
+DEPEND="${COMMON_DEPEND}
+ elibc_musl? ( sys-libs/queue-standalone )
test? ( dev-libs/check )"
-RDEPEND="${CDEPEND}
+BDEPEND=">=dev-build/autoconf-2.71
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
virtual/logger"
PATCHES=(
- "${FILESDIR}"/${PN}-2.1.20-no_mkdir_run.patch
- "${FILESDIR}"/${PN}-2.1.20-protocol1_by_default.patch
- "${FILESDIR}"/${PN}-2.0.54-server_user.patch
+ "${FILESDIR}"/"${PN}"-2.1.20-no_mkdir_run.patch
+ "${FILESDIR}"/"${PN}"-2.0.54-server_user.patch
)
src_prepare() {
@@ -49,29 +51,34 @@ src_configure() {
--localstatedir=/var
--sysconfdir=/etc/burp
--enable-largefile
- $(use_enable acl)
- $(use_enable ipv6)
- $(use_enable xattr)
+ --runstatedir=/run
+ "$(use_enable acl)"
+ "$(use_enable xattr)"
)
- # --runstatedir option will only work from autoconf-2.70 onwards
- runstatedir='/run' \
- econf "${myeconfargs[@]}"
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # See https://bugs.gentoo.org/915690
+ local -x CK_DEFAULT_TIMEOUT=0
+ local -x CK_TIMEOUT_MULTIPLIER=0
+ default
}
src_install() {
default
keepdir /var/spool/burp
- fowners -R root:${PN} /var/spool/burp
+ fowners -R root:"${PN}" /var/spool/burp
fperms 0770 /var/spool/burp
emake DESTDIR="${D}" install-configs
- fowners -R root:${PN} /etc/burp
+ fowners -R root:"${PN}" /etc/burp
fperms 0750 /etc/burp
fperms 0640 /etc/burp/burp-server.conf
fperms 0750 /etc/burp/clientconfdir
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- systemd_dounit "${FILESDIR}"/${PN}.service
+ newinitd "${FILESDIR}"/"${PN}".initd "${PN}"
+ systemd_dounit "${FILESDIR}"/"${PN}".service
}
pkg_postinst() {
@@ -81,13 +88,13 @@ pkg_postinst() {
elog "client mode because upgrades obtained this way will not be"
elog "managed by Portage."
- if [[ ! -e /etc/burp/CA/index.txt ]]; then
+ if [[ ! -e "${EROOT}"/etc/burp/CA/index.txt ]]; then
elog ""
elog "At first run burp server will generate DH parameters and SSL"
elog "certificates. You should adjust configuration before."
elog "Server configuration is located at"
elog ""
- elog " /etc/burp/burp-server.conf"
+ elog " ${EROOT}/etc/burp/burp-server.conf"
elog ""
fi
@@ -95,12 +102,12 @@ pkg_postinst() {
# numbers, even though in practice it is typically just one.
local oldver
for oldver in ${REPLACING_VERSIONS}; do
- if [[ $(ver_cut 1 ${oldver}) -lt 2 ]]; then
+ if [[ $(ver_cut 1 "${oldver}") -lt 2 ]]; then
ewarn "Starting with version 2.0.54 we no longer patch bedup to use"
ewarn "the server config file by default. If you use bedup, please"
ewarn "update your scripts to invoke it as"
ewarn ""
- ewarn " bedup -c /etc/burp/burp-server.conf"
+ ewarn " bedup -c ${EROOT}/etc/burp/burp-server.conf"
ewarn ""
ewarn "Otherwise deduplication will not work!"
break
diff --git a/app-backup/burp/files/burp-2.1.20-protocol1_by_default.patch b/app-backup/burp/files/burp-2.1.20-protocol1_by_default.patch
deleted file mode 100644
index db9e9b6a9de5..000000000000
--- a/app-backup/burp/files/burp-2.1.20-protocol1_by_default.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/configs/client/burp.conf.in
-+++ b/configs/client/burp.conf.in
-@@ -10,7 +10,8 @@
- # 0 to decide automatically, 1 to force protocol1 mode (file level granularity
- # with a pseudo mirrored storage on the server and optional rsync). 2 forces
- # protocol2 mode (inline deduplication with variable length blocks).
--# protocol = 0
-+# WARNING: as of September 2017 protocol2 is still considered experimental.
-+protocol = 1
- pidfile = @runstatedir@/@name@.client.pid
- syslog = 0
- stdout = 1
---- a/configs/server/burp.conf.in
-+++ b/configs/server/burp.conf.in
-@@ -21,7 +21,8 @@
- # protocol2 mode (inline deduplication with variable length blocks).
- # Like many other settings, this can be set per client in the clientconfdir
- # files.
--# protocol = 0
-+# WARNING: as of September 2017 protocol2 is still considered experimental.
-+protocol = 1
- pidfile = @runstatedir@/@name@.server.pid
- hardlinked_archive = 0
- working_dir_recovery_method = delete
diff --git a/app-backup/burp/metadata.xml b/app-backup/burp/metadata.xml
index 2887b871ddd0..86199d94118a 100644
--- a/app-backup/burp/metadata.xml
+++ b/app-backup/burp/metadata.xml
@@ -1,9 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>marecki@gentoo.org</email>
- <name>Marek Szuba</name>
+ <email>github@fischl-online.de</email>
+ <name>Anton Fischl</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
</maintainer>
<longdescription lang="en">
Burp is a network backup and restore program. It uses librsync in order