summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/dar')
-rw-r--r--app-backup/dar/Manifest3
-rw-r--r--app-backup/dar/dar-2.5.11.ebuild90
-rw-r--r--app-backup/dar/dar-2.6.10.ebuild101
-rw-r--r--app-backup/dar/dar-2.7.14.ebuild97
-rw-r--r--app-backup/dar/metadata.xml12
5 files changed, 107 insertions, 196 deletions
diff --git a/app-backup/dar/Manifest b/app-backup/dar/Manifest
index af1161313c2c..06ab9425b9ea 100644
--- a/app-backup/dar/Manifest
+++ b/app-backup/dar/Manifest
@@ -1,2 +1 @@
-DIST dar-2.5.11.tar.gz 1891928 BLAKE2B 536cccca2533f7ddbc8b95972fe00e9c87a404481e6afbd7aa3634c00598403c18950eb876aefe71a818c3bf4df75bff5f3904dc69bd1d75880f6c8a349911a5 SHA512 36b90218a34ac7f41ce9ca0a2167cfb2fd243b23b8e84350153e8804f0faabf87291b4e4b061533bcb0ca079f087c074eeaa12a54ee8084dd386a072ac503847
-DIST dar-2.6.10.tar.gz 2140424 BLAKE2B 840a7a3d33825658be541157468a15bc3a3082083a35c426ecbab1cd2e8026e0a4d15671a33472068e1256878d1f60d414c2c069a3223ab5050756b13c887b69 SHA512 2fceafba6c6851c5dd11c0d1a3fda8aeddac16f39cf0051027b178703a5e821fb769c42624063d8722d80ea62bb735f3b0c6c39538c1c939234df49d6b757428
+DIST dar-2.7.14.tar.gz 2443548 BLAKE2B a68ad06a2bf53b25a0b393f3e85eef5676382d63bfd86ba77696667786a688e326c118d937cd5dae6b1e78410e40295c67d8ba4677c37f7139bbdd2794c4efeb SHA512 0436c67e0dbd8f5e96e01a0db48a469d80fb81a7c7f37aed98308bd55d60d699b21c755d95fa83891690231fd2510eaa6c6652fb99a1bad9c8210084031391d4
diff --git a/app-backup/dar/dar-2.5.11.ebuild b/app-backup/dar/dar-2.5.11.ebuild
deleted file mode 100644
index 0d7de4fe613b..000000000000
--- a/app-backup/dar/dar-2.5.11.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit flag-o-matic ltprune
-
-DESCRIPTION="A full featured backup tool, aimed for disks"
-HOMEPAGE="http://dar.linux.free.fr/"
-SRC_URI="mirror://sourceforge/dar/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc sparc x86 ~amd64-linux"
-IUSE="dar32 dar64 doc gcrypt gpg lzo nls static static-libs xattr"
-
-RESTRICT="test" # need to be run as root
-
-RDEPEND=">=sys-libs/zlib-1.2.3:=
- !static? (
- app-arch/bzip2:=
- app-arch/xz-utils:=
- sys-libs/libcap
- gcrypt? ( dev-libs/libgcrypt:0= )
- gpg? ( app-crypt/gpgme )
- lzo? ( dev-libs/lzo:= )
- xattr? ( sys-apps/attr:= )
- )"
-
-DEPEND="${RDEPEND}
- static? (
- app-arch/bzip2[static-libs]
- app-arch/xz-utils[static-libs]
- sys-libs/libcap[static-libs]
- sys-libs/zlib[static-libs]
- lzo? ( dev-libs/lzo[static-libs] )
- xattr? ( sys-apps/attr[static-libs] )
- )
- nls? (
- sys-devel/gettext
- virtual/libintl
- )
- doc? ( app-doc/doxygen )"
-
-REQUIRED_USE="?? ( dar32 dar64 )
- gpg? ( gcrypt )"
-
-#PATCHES=(
-#)
-
-src_configure() {
- local myconf=( --disable-upx )
-
- # Bug 103741
- filter-flags -fomit-frame-pointer
-
- # configure.ac is totally funked up regarding the AC_ARG_ENABLE
- # logic.
- # For example "--enable-dar-static" causes configure to DISABLE
- # static builds of dar.
- # Do _not_ use $(use_enable) until you have verified that the
- # logic has been fixed by upstream.
- use xattr || myconf+=( --disable-ea-support )
- use dar32 && myconf+=( --enable-mode=32 )
- use dar64 && myconf+=( --enable-mode=64 )
- use doc || myconf+=( --disable-build-html )
- # use examples && myconf+=( --enable-examples )
- use gcrypt || myconf+=( --disable-libgcrypt-linking )
- use gpg || myconf+=( --disable-gpgme-linking )
- use lzo || myconf+=( --disable-liblzo2-linking )
- use nls || myconf+=( --disable-nls )
- if ! use static ; then
- myconf+=( --disable-dar-static )
- if ! use static-libs ; then
- myconf+=( --disable-static )
- fi
- fi
-
- econf ${myconf[@]}
-}
-
-src_install() {
- emake DESTDIR="${D}" pkgdatadir="${EPREFIX}"/usr/share/doc/${PF}/html install
-
- local DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
- einstalldocs
-
- if ! use static-libs ; then
- prune_libtool_files --all
- fi
-}
diff --git a/app-backup/dar/dar-2.6.10.ebuild b/app-backup/dar/dar-2.6.10.ebuild
deleted file mode 100644
index c4bbb94762a5..000000000000
--- a/app-backup/dar/dar-2.6.10.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit flag-o-matic
-
-DESCRIPTION="A full featured backup tool, aimed for disks"
-HOMEPAGE="http://dar.linux.free.fr/"
-SRC_URI="mirror://sourceforge/dar/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux"
-IUSE="curl dar32 dar64 doc gcrypt gpg lzo nls static static-libs xattr"
-
-RESTRICT="test" # need to be run as root
-
-RDEPEND=">=sys-libs/zlib-1.2.3:=
- !static? (
- app-arch/bzip2:=
- app-arch/xz-utils:=
- sys-libs/libcap
- curl? ( net-misc/curl )
- gcrypt? ( dev-libs/libgcrypt:0= )
- gpg? ( app-crypt/gpgme )
- lzo? ( dev-libs/lzo:= )
- xattr? ( sys-apps/attr:= )
- )"
-
-DEPEND="${RDEPEND}
- static? (
- app-arch/bzip2[static-libs]
- app-arch/xz-utils[static-libs]
- sys-libs/libcap[static-libs]
- sys-libs/zlib[static-libs]
- curl? ( net-misc/curl[static-libs] )
- lzo? ( dev-libs/lzo[static-libs] )
- xattr? ( sys-apps/attr[static-libs] )
- )
-"
-BDEPEND="
- nls? (
- sys-devel/gettext
- virtual/libintl
- )
- doc? ( app-doc/doxygen )
-"
-
-REQUIRED_USE="?? ( dar32 dar64 )
- gpg? ( gcrypt )"
-
-#PATCHES=(
-#)
-
-src_configure() {
- # configure.ac is totally funked up regarding the AC_ARG_ENABLE
- # logic.
- # For example "--enable-dar-static" causes configure to DISABLE
- # static builds of dar.
- # Do _not_ use $(use_enable) until you have verified that the
- # logic has been fixed by upstream.
- local myconf=(
- --disable-python-binding
- --disable-upx
- $(usex curl '' --disable-libcurl-linking)
- $(usex dar32 --enable-mode=32 '')
- $(usex dar64 --enable-mode=64 '')
- $(usex doc '' --disable-build-html)
- #$(usex examples --enable-examples '')
- $(usex gcrypt '' --disable-libgcrypt-linking)
- $(usex gpg '' --disable-gpgme-linking)
- $(usex lzo '' --disable-liblzo2-linking)
- $(usex nls '' --disable-nls)
- #$(usex rsync '' --disable-librsync-linking)
- $(usex xattr '' --disable-ea-support)
- )
-
- # Bug 103741
- filter-flags -fomit-frame-pointer
-
- if ! use static ; then
- myconf+=( --disable-dar-static )
- if ! use static-libs ; then
- myconf+=( --disable-static )
- fi
- fi
-
- econf ${myconf[@]}
-}
-
-src_install() {
- emake DESTDIR="${D}" pkgdatadir="${EPREFIX}"/usr/share/doc/${PF}/html install
-
- local DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
- einstalldocs
-
- find "${ED}" -name '*.la' -delete || die
- if ! use static-libs ; then
- find "${ED}" -name '*.a' -delete || die
- fi
-}
diff --git a/app-backup/dar/dar-2.7.14.ebuild b/app-backup/dar/dar-2.7.14.ebuild
new file mode 100644
index 000000000000..88c8bb47d6cd
--- /dev/null
+++ b/app-backup/dar/dar-2.7.14.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="A full featured backup tool, aimed for disks"
+HOMEPAGE="http://dar.linux.free.fr/"
+SRC_URI="https://downloads.sourceforge.net/project/dar/dar/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86 ~amd64-linux"
+IUSE="argon2 curl dar32 dar64 doc gcrypt gpg lz4 lzo nls rsync xattr"
+
+REQUIRED_USE="
+ ?? ( dar32 dar64 )
+ gpg? ( gcrypt )
+"
+
+RESTRICT="test" # need to be run as root
+
+RDEPEND="
+ app-arch/bzip2:=
+ app-arch/xz-utils
+ app-arch/zstd:=
+ dev-libs/libthreadar
+ sys-libs/libcap
+ >=sys-libs/zlib-1.2.3:=
+ argon2? ( app-crypt/argon2:= )
+ curl? ( net-misc/curl )
+ gcrypt? (
+ dev-libs/libgcrypt:0=
+ dev-libs/libgpg-error
+ )
+ gpg? (
+ app-crypt/gpgme:=
+ dev-libs/libassuan
+ )
+ lz4? ( app-arch/lz4:= )
+ lzo? ( dev-libs/lzo:2 )
+ nls? ( virtual/libintl )
+ rsync? ( net-libs/librsync:= )
+ xattr? ( sys-apps/attr )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ doc? ( app-text/doxygen )
+ nls? ( sys-devel/gettext )
+"
+
+QA_PKGCONFIG_VERSION="" #862025 - upstream has a different numbering scheme for libdar
+
+src_configure() {
+ # configure.ac is totally funked up regarding the AC_ARG_ENABLE
+ # logic.
+ # For example "--enable-dar-static" causes configure to DISABLE
+ # static builds of dar.
+ # Do _not_ use $(use_enable) until you have verified that the
+ # logic has been fixed by upstream.
+ local myconf=(
+ --disable-dar-static
+ --disable-python-binding
+ --disable-upx
+ $(usev !argon2 --disable-libargon2-linking)
+ $(usev !curl --disable-libcurl-linking)
+ $(usev dar32 --enable-mode=32)
+ $(usev dar64 --enable-mode=64)
+ $(usev !doc --disable-build-html)
+ $(usev !gcrypt --disable-libgcrypt-linking)
+ $(usev !gpg --disable-gpgme-linking)
+ $(usev !lz4 --disable-liblz4-linking)
+ $(usev !lzo --disable-liblzo2-linking)
+ $(usev !nls --disable-nls)
+ $(usev !rsync --disable-librsync-linking)
+ $(usev !xattr --disable-ea-support)
+ )
+
+ # Bug 103741
+ filter-flags -fomit-frame-pointer
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdatadir="${EPREFIX}"/usr/share/doc/${PF}/html install
+
+ einstalldocs
+
+ find "${ED}" -name "*.la" -delete || die
+
+ # Bug 729150
+ rm "${ED}/usr/share/doc/${PF}/html/samples/MyBackup.sh.tar.gz" || die
+}
diff --git a/app-backup/dar/metadata.xml b/app-backup/dar/metadata.xml
index 31483fe9d2ff..6cdca97c7d73 100644
--- a/app-backup/dar/metadata.xml
+++ b/app-backup/dar/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>ceamac@gentoo.org</email>
+ <name>Viorel Munteanu</name>
+ </maintainer>
<longdescription>
Backup directory tree and files.
Full featured archiver with support for differential backups, slices,
@@ -9,14 +12,17 @@ compression, ATTR/ACL support. DAR also supports Pipes for remote
operations, including with ssh.
</longdescription>
<use>
+ <flag name="argon2">Enable password hashing algorithm from <pkg>app-crypt/argon2</pkg></flag>
<flag name="dar32">Enables --enable-mode=32 option, which replace infinite
by 32 bit integers</flag>
<flag name="dar64">Enables --enable-mode=64 option, which replace infinite
by 64 bit integers</flag>
<flag name="gcrypt">Enables strong encryption support</flag>
- <flag name="gpg">Enables usage of asymetric crypto algorithms</flag>
+ <flag name="gpg">Enables usage of asymmetric encryption algorithms</flag>
+ <flag name="rsync">Enables linking with <pkg>net-libs/librsync</pkg> for delta compression support</flag>
</use>
<upstream>
<remote-id type="sourceforge">dar</remote-id>
+ <remote-id type="github">Edrusb/DAR</remote-id>
</upstream>
</pkgmetadata>