summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/snapper')
-rw-r--r--app-backup/snapper/Manifest7
-rw-r--r--app-backup/snapper/files/snapper-0.10.1-testsuite.patch84
-rw-r--r--app-backup/snapper/files/snapper-0.11.0-cron-confd.patch18
-rw-r--r--app-backup/snapper/files/snapper-0.5.6-swap.patch36
-rw-r--r--app-backup/snapper/files/snapper.bash200
-rw-r--r--app-backup/snapper/metadata.xml6
-rw-r--r--app-backup/snapper/snapper-0.10.6.ebuild (renamed from app-backup/snapper/snapper-0.8.9-r1.ebuild)37
-rw-r--r--app-backup/snapper/snapper-0.10.7.ebuild (renamed from app-backup/snapper/snapper-0.8.7.ebuild)38
-rw-r--r--app-backup/snapper/snapper-0.11.0.ebuild (renamed from app-backup/snapper/snapper-0.5.6-r1.ebuild)41
-rw-r--r--app-backup/snapper/snapper-0.8.6.ebuild77
10 files changed, 183 insertions, 361 deletions
diff --git a/app-backup/snapper/Manifest b/app-backup/snapper/Manifest
index 3162b303dc6b..dd6d2ce24c65 100644
--- a/app-backup/snapper/Manifest
+++ b/app-backup/snapper/Manifest
@@ -1,4 +1,3 @@
-DIST snapper-0.5.6.tar.bz2 580047 BLAKE2B 3b945acbf734db1925dad5515323a64a2c08ee8226a593025f9160e0d1b1140734b2b498d036256946159900b50fec8567147dc0a974c281be747e977bcbd05b SHA512 392427d097cbe221bf7ca0ae20bc065dffaa4d0017ed750c41748d71128fc7ce054bb4425d6dbed7308a530df71815f80f56e60d72aab17ef3e0a16f3b3ba47e
-DIST snapper-0.8.6.tar.bz2 607016 BLAKE2B 3e496fa22b1ecce2079d79caeb530ca1538febcc6bdf04aa0256e5b43bb546ea66436e60eeaae6722bc869c60579bc47c556671c5878dd671c266102516f04bb SHA512 f01a309a8dcfff455bf480ff297108e8ec3603d469d50f08740176e22bc2b8dd211de678fa8ce12c1ccd828348a35c6d347ca51b829d7b8c30b3fbaba4e9e2d9
-DIST snapper-0.8.7.tar.bz2 622381 BLAKE2B 82d1a9c91beb309e87acfa914b55b2ff5900edc023a5ecd6f2bee6b1a15adb1336656f3f1fffea4a9971aa449b7825750e6c680806d4574faada5bba0a6d14f1 SHA512 6fa63c2453f93a724f0ac23d84ff2c5aafc654463e84a4f767bb8a75a0d4fb7ca7314811179d5fefddddce0df4441298c67b473596aa720d86eeefa43011b727
-DIST snapper-0.8.9.tar.gz 373192 BLAKE2B 55c927136518e91b45631f3087fce13e8e08228274ef7c54164a7024e382a45bfa5b40687fd5e3d770fc87019d8e93af5c681013a023cd89dcb1f16863a77421 SHA512 5a3e45839cd4b5e621425df2e1214ca5014a391d17b489fdf7d315e8ac9959741c1f6fcf7adf644276ed11488bc0f88fcfa563198bd78824867d267df204659d
+DIST snapper-0.10.6.tar.gz 423867 BLAKE2B a7d0f8c62c60c0d03bf108a8c0692dd209f170cf8227512cbc3b80eb9f58ecca845aa585859032bc6582d67e4c6ff15b75443a9ee9291d1b970efec15513571f SHA512 6eedfb9408260331f042f0a429a1104136cb88dac450f320641b0941cd06faf52f67cad2397cf4122f919876bb994455da0cfd3bb099f82217050e07b4c77d2e
+DIST snapper-0.10.7.tar.gz 428482 BLAKE2B 43c48d978296901f6584cef258ec3723de97b1d6b4b4a5b6bc39649f28b3300919616c65b8fcdb97b3ebcab08d04e4583713eef146721367de24513e80113b45 SHA512 bf098c941735b60554ff0711fa43b30ef3634e01178f5ee8ad44c65b757c3366bd5bf568cef3a787b2ddcc2fc63090056109250480e6bd360ebf27a8343373b8
+DIST snapper-0.11.0.tar.gz 445685 BLAKE2B 301e6d745d8d6d7acc6ca0c9fc431a0e46700aabd9882785bb2be38152693f9dbe897f85f6ad724c9529a0754b6146b53dda0a24141b386e59e7737855bc5da2 SHA512 fe86be4ceb1439b5be3fa61f5bc037bc51a5fe47451d0698851f83e2783d6c245ef8d40a33f79b03e8d1d8b63433743c35938ad7dca0747e0e1f650a5a766c40
diff --git a/app-backup/snapper/files/snapper-0.10.1-testsuite.patch b/app-backup/snapper/files/snapper-0.10.1-testsuite.patch
new file mode 100644
index 000000000000..84ff2ce1978a
--- /dev/null
+++ b/app-backup/snapper/files/snapper-0.10.1-testsuite.patch
@@ -0,0 +1,84 @@
+diff --git a/configure.ac b/configure.ac
+index 39def82..9b96a32 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -174,6 +174,13 @@ if test "x$enable_coverage" = "xyes"; then
+ LDFLAGS="${LDFLAGS} --coverage"
+ fi
+
++AC_ARG_ENABLE([tests], AC_HELP_STRING([--disable-tests],[Disable internal tests support]),
++ [with_tests=$enableval],[with_tests=yes])
++AM_CONDITIONAL(ENABLE_TESTS, [test "x$with_tests" = "xyes"])
++if test "x$with_tests" = "xyes"; then
++ AC_DEFINE(ENABLE_TESTS, 1, [Enable internal tests support])
++fi
++
+ PKG_CHECK_MODULES(DBUS, dbus-1)
+ PKG_CHECK_MODULES(XML2, libxml-2.0)
+ PKG_CHECK_MODULES(JSONC, json-c, [], [AC_MSG_WARN([Cannot find json-c. Please install libjson-c-devel])])
+diff --git a/testsuite-cmp/Makefile.am b/testsuite-cmp/Makefile.am
+index 81104bf..9c29477 100644
+--- a/testsuite-cmp/Makefile.am
++++ b/testsuite-cmp/Makefile.am
+@@ -2,6 +2,7 @@
+ # Makefile.am for snapper/testsuite-cmp
+ #
+
++if ENABLE_TESTS
+ AM_CPPFLAGS = -I$(top_srcdir)
+ AM_LDFLAGS = -lboost_system
+
+@@ -15,3 +16,4 @@ cmp_SOURCES = cmp.cc
+
+ EXTRA_DIST = $(noinst_SCRIPTS)
+
++endif
+diff --git a/testsuite-real/Makefile.am b/testsuite-real/Makefile.am
+index a3bb2e3..c4e88f4 100644
+--- a/testsuite-real/Makefile.am
++++ b/testsuite-real/Makefile.am
+@@ -2,6 +2,7 @@
+ # Makefile.am for snapper/testsuite-real
+ #
+
++if ENABLE_TESTS
+ CXXFLAGS += -std=gnu++11
+
+ AM_CPPFLAGS = -I$(top_srcdir)
+@@ -56,3 +57,4 @@ ascii_file_SOURCES = ascii-file.cc
+
+ EXTRA_DIST = $(test_DATA) $(test_SCRIPTS)
+
++endif
+diff --git a/testsuite/Makefile.am b/testsuite/Makefile.am
+index ccb84d3..409e265 100644
+--- a/testsuite/Makefile.am
++++ b/testsuite/Makefile.am
+@@ -2,6 +2,7 @@
+ # Makefile.am for snapper/testsuite
+ #
+
++if ENABLE_TESTS
+ AM_CPPFLAGS = -I$(top_srcdir) $(DBUS_CFLAGS)
+
+ LDADD = ../snapper/libsnapper.la ../dbus/libdbus.la -lboost_unit_test_framework
+@@ -48,3 +49,4 @@ lvm_utils_test_LDADD = -lboost_unit_test_framework ../snapper/libsnapper.la
+ range_test_LDADD = -lboost_unit_test_framework ../client/utils/libutils.la
+
+ limit_test_LDADD = -lboost_unit_test_framework ../client/utils/libutils.la
++endif
+diff --git a/zypp-plugin/testsuite/Makefile.am b/zypp-plugin/testsuite/Makefile.am
+index 7b52e13..71cb545 100644
+--- a/zypp-plugin/testsuite/Makefile.am
++++ b/zypp-plugin/testsuite/Makefile.am
+@@ -1,3 +1,5 @@
++
++if ENABLE_TESTS
+ if HAVE_ZYPP
+ TEST_LOG_DRIVER = $(SHELL) tap-driver.sh
+
+@@ -12,3 +14,4 @@ TESTS = $(check_SCRIPTS)
+
+ EXTRA_DIST = $(check_SCRIPTS) $(noinst_SCRIPTS) $(noinst_DATA) tap-driver.sh
+ endif
++endif
diff --git a/app-backup/snapper/files/snapper-0.11.0-cron-confd.patch b/app-backup/snapper/files/snapper-0.11.0-cron-confd.patch
new file mode 100644
index 000000000000..c1fc5c692c71
--- /dev/null
+++ b/app-backup/snapper/files/snapper-0.11.0-cron-confd.patch
@@ -0,0 +1,18 @@
+diff --git a/scripts/snapper-hourly b/scripts/snapper-hourly
+index 36a41f5..f36d8ec 100755
+--- a/scripts/snapper-hourly
++++ b/scripts/snapper-hourly
+@@ -9,10 +9,10 @@ export PATH
+
+
+ #
+-# get information from /etc/sysconfig/snapper
++# get information from /etc/conf.d/snapper
+ #
+-if [ -f /etc/sysconfig/snapper ] ; then
+- . /etc/sysconfig/snapper
++if [ -f /etc/conf.d/snapper ] ; then
++ . /etc/conf.d/snapper
+ fi
+
+
diff --git a/app-backup/snapper/files/snapper-0.5.6-swap.patch b/app-backup/snapper/files/snapper-0.5.6-swap.patch
deleted file mode 100644
index aa24330d7304..000000000000
--- a/app-backup/snapper/files/snapper-0.5.6-swap.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-commit 22bc1d808ebb6c3958e8231a36b73cd45a7f2c30
-Author: Spencer Janssen <spencerjanssen@gmail.com>
-Date: Mon Dec 3 17:33:49 2018 -0600
-
- Work around btrfs v4.19
-
- Addresses #459
-
-diff --git a/snapper/Btrfs.cc b/snapper/Btrfs.cc
-index cb9f7b3..c05557b 100644
---- a/snapper/Btrfs.cc
-+++ b/snapper/Btrfs.cc
-@@ -41,6 +41,9 @@
- #include <btrfs/send.h>
- #include <btrfs/send-stream.h>
- #include <btrfs/send-utils.h>
-+#ifdef swap
-+#undef swap
-+#endif
- #include <boost/version.hpp>
- #include <boost/thread.hpp>
- #endif
-diff --git a/snapper/BtrfsUtils.cc b/snapper/BtrfsUtils.cc
-index bada3f8..9edc325 100644
---- a/snapper/BtrfsUtils.cc
-+++ b/snapper/BtrfsUtils.cc
-@@ -34,6 +34,9 @@
- #ifdef HAVE_LIBBTRFS
- #include <btrfs/ioctl.h>
- #include <btrfs/send-utils.h>
-+#ifdef swap
-+#undef swap
-+#endif
- #endif
- #include <algorithm>
- #include <functional>
diff --git a/app-backup/snapper/files/snapper.bash b/app-backup/snapper/files/snapper.bash
deleted file mode 100644
index e5ca4134342a..000000000000
--- a/app-backup/snapper/files/snapper.bash
+++ /dev/null
@@ -1,200 +0,0 @@
-_snapper()
-{
- local configdir="/etc/snapper/configs"
- local cur prev words cword
- _init_completion || return
-
- local GLOGAL_SNAPPER_OPTIONS='
- -q --quiet
- -v --verbose
- --utc
- --iso
- -t --table-style
- -c --config
- -r --root
- --no-dbus
- --version
- --help
- '
-
- # see if the user selected a command already
- local COMMANDS=(
- "list-configs" "create-config" "delete-config" "set-config"
- "list" "ls"
- "create" "modify" "delete" "remove" "rm"
- "mount" "umount"
- "status" "diff" "xadiff"
- "undochange" "rollback"
- "setup-quota"
- "cleanup")
-
- local command i
- for (( i=0; i < ${#words[@]}-1; i++ )); do
- if [[ ${COMMANDS[@]} =~ ${words[i]} ]]; then
- command=${words[i]}
- break
- fi
- done
-
- case $prev in
- --version|--help)
- return 0
- ;;
- esac
-
- # supported options per command
- if [[ "$cur" == -* ]]; then
- case $command in
- create-config)
- COMPREPLY=( $( compgen -W '--fstype -f
- --templete -t' -- "$cur" ) )
- return 0
- ;;
- list|ls)
- COMPREPLY=( $( compgen -W '--type -t
- --all-configs -a' -- "$cur" ) )
- return 0
- ;;
- create)
- COMPREPLY=( $( compgen -W '--type -t
- --pre-number
- --print-number -p
- --description -d
- --cleanup-algorithm -c
- --userdata -u
- --command' -- "$cur" ) )
- return 0
- ;;
- modify)
- COMPREPLY=( $( compgen -W '--description -d
- --cleanup-algorithm -c
- --userdata -u' -- "$cur" ) )
- return 0
- ;;
- delete|remove|rm)
- COMPREPLY=( $( compgen -W '--sync -s
- ' -- "$cur" ) )
- return 0
- ;;
- status)
- COMPREPLY=( $( compgen -W '--output -o
- ' -- "$cur" ) )
- return 0
- ;;
- diff)
- COMPREPLY=( $( compgen -W '--input -i
- --diff-cmd
- --extensions -x' -- "$cur" ) )
- return 0
- ;;
- undochange)
- COMPREPLY=( $( compgen -W '--input -i
- ' -- "$cur" ) )
- return 0
- ;;
- rollback)
- COMPREPLY=( $( compgen -W '--print-number -p
- --description -d
- --cleanup-algorithm -c
- --userdata -u' -- "$cur" ) )
- return 0
- ;;
- *)
- COMPREPLY=( $( compgen -W "$GLOGAL_SNAPPER_OPTIONS" -- "$cur" ) )
- return 0
- ;;
- esac
- fi
-
- # specific command arguments
- if [[ -n $command ]]; then
- case $command in
- create-config)
- case "$prev" in
- --fstype|-f)
- COMPREPLY=( $( compgen -W 'btrfs ext4 lvm(xfs) lvm(ext4)
- ' -- "$cur" ) )
- ;;
- esac
- return 0
- ;;
- list)
- case "$prev" in
- --type|-t)
- COMPREPLY=( $( compgen -W 'all single pre-post
- ' -- "$cur" ) )
- ;;
- esac
- return 0
- ;;
- create)
- case "$prev" in
- --type|-t)
- COMPREPLY=( $( compgen -W 'single pre post
- ' -- "$cur" ) )
- ;;
- --pre-number)
- COMPREPLY=( $( compgen -W '
- ' -- "$cur" ) )
- ;;
- --cleanup-algorithm|-c)
- COMPREPLY=( $( compgen -W 'empty-pre-post timeline number
- ' -- "$cur" ) )
- ;;
- esac
- return 0
- ;;
- modify)
- case "$prev" in
- --cleanup-algorithm|-c)
- COMPREPLY=( $( compgen -W 'empty-pre-post timeline number
- ' -- "$cur" ) )
- ;;
- esac
- return 0
- ;;
- status)
- case "$prev" in
- --output|-o)
- COMPREPLY=( $( compgen -f -- "$cur" ) )
- ;;
- esac
- return 0
- ;;
- cleanup)
- case "$prev" in
- empty-pre-post|timeline|number)
- ;;
- *)
- COMPREPLY=( $( compgen -W 'empty-pre-post timeline number
- ' -- "$cur" ) )
- ;;
- esac
- return 0
- ;;
- diff)
- return 0
- ;;
- undochange)
- return 0
- ;;
- rollback)
- case "$prev" in
- --cleanup-algorithm|-c)
- COMPREPLY=( $( compgen -W 'empty-pre-post timeline number
- ' -- "$cur" ) )
- ;;
- esac
- return 0
- ;;
- esac
- fi
-
- # no command yet, show what commands we have
- if [ "$command" = "" ]; then
- COMPREPLY=( $( compgen -W '${COMMANDS[@]} ${GLOGAL_SNAPPER_OPTIONS[@]}' -- "$cur" ) )
- fi
-
- return 0
-} &&
-complete -F _snapper snapper
diff --git a/app-backup/snapper/metadata.xml b/app-backup/snapper/metadata.xml
index 1aa9b1e774ab..f060368ca7fd 100644
--- a/app-backup/snapper/metadata.xml
+++ b/app-backup/snapper/metadata.xml
@@ -1,12 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<longdescription>
Snapper is a command-line program for filesystem snapshot management.
It can create, delete and compare snapshots and undo changes done
between snapshots. It supports both btrfs and ext4.
</longdescription>
- <maintainer type="person">
+ <maintainer type="person" proxied="yes">
<email>pastas4@gmail.com</email>
<name>Dainius Masiliƫnas (GreatEmerald)</name>
</maintainer>
@@ -14,7 +14,7 @@
<email>dlan@gentoo.org</email>
<name>Yixun Lan</name>
</maintainer>
- <maintainer type="project">
+ <maintainer type="project" proxied="proxy">
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
diff --git a/app-backup/snapper/snapper-0.8.9-r1.ebuild b/app-backup/snapper/snapper-0.10.6.ebuild
index 5a5593c28464..2adf8bcfcde5 100644
--- a/app-backup/snapper/snapper-0.8.9-r1.ebuild
+++ b/app-backup/snapper/snapper-0.10.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools systemd bash-completion-r1
+inherit autotools systemd
DESCRIPTION="Command-line program for btrfs and lvm snapshot management"
HOMEPAGE="http://snapper.io/"
@@ -11,10 +11,17 @@ SRC_URI="https://github.com/openSUSE/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="lvm pam xattr"
+KEYWORDS="amd64 ~arm64 ~riscv x86"
+IUSE="lvm pam test systemd xattr"
+RESTRICT="test"
-RDEPEND="dev-libs/boost:=[threads]
+BDEPEND="app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+RDEPEND="dev-libs/boost:=
+ dev-libs/json-c:=
dev-libs/libxml2
dev-libs/icu:=
sys-apps/acl
@@ -27,14 +34,11 @@ RDEPEND="dev-libs/boost:=[threads]
pam? ( sys-libs/pam )
xattr? ( sys-apps/attr )"
-DEPEND="${RDEPEND}
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
- sys-devel/gettext
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/cron-confd.patch
+ "${FILESDIR}"/${PN}-0.10.1-testsuite.patch
)
src_prepare() {
@@ -50,13 +54,18 @@ src_configure() {
# ext4 code does not work anymore
# snapper does not build without btrfs
local myeconfargs=(
+ --disable-silent-rules
--with-conf="/etc/conf.d"
- --disable-zypp
+ --enable-zypp
--enable-rollback
+ --enable-btrfs-quota
--disable-ext4
--enable-btrfs
+ --enable-doc
$(use_enable lvm)
$(use_enable pam)
+ $(use_enable test tests)
+ $(use_enable systemd)
$(use_enable xattr xattrs)
)
@@ -69,7 +78,6 @@ src_install() {
keepdir /etc/snapper/configs
newconfd data/sysconfig.snapper snapper
find "${D}" -name '*.la' -delete || die
- newbashcomp "${FILESDIR}"/${PN}.bash ${PN}
}
pkg_postinst() {
@@ -77,5 +85,6 @@ pkg_postinst() {
elog "at least one config first. To do this, run:"
elog "snapper create-config <subvolume>"
elog "For more information, see man (8) snapper or"
- elog "http://snapper.io/documentation.html"
+ elog "http://snapper.io/documentation.html and"
+ elog "https://wiki.gentoo.org/wiki/Snapper"
}
diff --git a/app-backup/snapper/snapper-0.8.7.ebuild b/app-backup/snapper/snapper-0.10.7.ebuild
index bcefeb713f17..9d04eeeb2e14 100644
--- a/app-backup/snapper/snapper-0.8.7.ebuild
+++ b/app-backup/snapper/snapper-0.10.7.ebuild
@@ -1,20 +1,27 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit systemd bash-completion-r1
+inherit autotools systemd
DESCRIPTION="Command-line program for btrfs and lvm snapshot management"
HOMEPAGE="http://snapper.io/"
-SRC_URI="ftp://ftp.suse.com/pub/projects/snapper/${P}.tar.bz2"
+SRC_URI="https://github.com/openSUSE/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="lvm pam xattr"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="lvm pam test systemd xattr"
+RESTRICT="test"
-RDEPEND="dev-libs/boost:=[threads]
+BDEPEND="app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+RDEPEND="dev-libs/boost:=
+ dev-libs/json-c:=
dev-libs/libxml2
dev-libs/icu:=
sys-apps/acl
@@ -27,12 +34,11 @@ RDEPEND="dev-libs/boost:=[threads]
pam? ( sys-libs/pam )
xattr? ( sys-apps/attr )"
-DEPEND="${RDEPEND}
- sys-devel/gettext
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/cron-confd.patch
+ "${FILESDIR}"/${PN}-0.10.1-testsuite.patch
)
src_prepare() {
@@ -41,19 +47,25 @@ src_prepare() {
sed -e "s,/usr/lib/systemd/system,$(systemd_get_systemunitdir),g" \
-i data/Makefile.* \
|| die "Failed to fix systemd services and timers installation path"
+ eautoreconf
}
src_configure() {
# ext4 code does not work anymore
# snapper does not build without btrfs
local myeconfargs=(
+ --disable-silent-rules
--with-conf="/etc/conf.d"
- --disable-zypp
+ --enable-zypp
--enable-rollback
+ --enable-btrfs-quota
--disable-ext4
--enable-btrfs
+ --enable-doc
$(use_enable lvm)
$(use_enable pam)
+ $(use_enable test tests)
+ $(use_enable systemd)
$(use_enable xattr xattrs)
)
@@ -66,7 +78,6 @@ src_install() {
keepdir /etc/snapper/configs
newconfd data/sysconfig.snapper snapper
find "${D}" -name '*.la' -delete || die
- newbashcomp "${FILESDIR}"/${PN}.bash ${PN}
}
pkg_postinst() {
@@ -74,5 +85,6 @@ pkg_postinst() {
elog "at least one config first. To do this, run:"
elog "snapper create-config <subvolume>"
elog "For more information, see man (8) snapper or"
- elog "http://snapper.io/documentation.html"
+ elog "http://snapper.io/documentation.html and"
+ elog "https://wiki.gentoo.org/wiki/Snapper"
}
diff --git a/app-backup/snapper/snapper-0.5.6-r1.ebuild b/app-backup/snapper/snapper-0.11.0.ebuild
index c6f5ffca2a55..0e9331554272 100644
--- a/app-backup/snapper/snapper-0.5.6-r1.ebuild
+++ b/app-backup/snapper/snapper-0.11.0.ebuild
@@ -1,20 +1,27 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit systemd
+inherit autotools systemd
DESCRIPTION="Command-line program for btrfs and lvm snapshot management"
HOMEPAGE="http://snapper.io/"
-SRC_URI="ftp://ftp.suse.com/pub/projects/snapper/${P}.tar.bz2"
+SRC_URI="https://github.com/openSUSE/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="lvm pam xattr"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="lvm pam test systemd xattr"
+RESTRICT="test"
-RDEPEND="dev-libs/boost:=[threads]
+BDEPEND="app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+RDEPEND="dev-libs/boost:=
+ dev-libs/json-c:=
dev-libs/libxml2
dev-libs/icu:=
sys-apps/acl
@@ -27,13 +34,11 @@ RDEPEND="dev-libs/boost:=[threads]
pam? ( sys-libs/pam )
xattr? ( sys-apps/attr )"
-DEPEND="${RDEPEND}
- sys-devel/gettext
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
PATCHES=(
- "${FILESDIR}"/cron-confd.patch
- "${FILESDIR}"/${P}-swap.patch
+ "${FILESDIR}"/${P}-cron-confd.patch
+ "${FILESDIR}"/${PN}-0.10.1-testsuite.patch
)
src_prepare() {
@@ -42,19 +47,25 @@ src_prepare() {
sed -e "s,/usr/lib/systemd/system,$(systemd_get_systemunitdir),g" \
-i data/Makefile.* \
|| die "Failed to fix systemd services and timers installation path"
+ eautoreconf
}
src_configure() {
# ext4 code does not work anymore
# snapper does not build without btrfs
local myeconfargs=(
+ --disable-silent-rules
--with-conf="/etc/conf.d"
- --disable-zypp
+ --enable-zypp
--enable-rollback
+ --enable-btrfs-quota
--disable-ext4
--enable-btrfs
+ --enable-doc
$(use_enable lvm)
$(use_enable pam)
+ $(use_enable test tests)
+ $(use_enable systemd)
$(use_enable xattr xattrs)
)
@@ -64,6 +75,7 @@ src_configure() {
src_install() {
default
# Existing configuration file required to function
+ keepdir /etc/snapper/configs
newconfd data/sysconfig.snapper snapper
find "${D}" -name '*.la' -delete || die
}
@@ -73,5 +85,6 @@ pkg_postinst() {
elog "at least one config first. To do this, run:"
elog "snapper create-config <subvolume>"
elog "For more information, see man (8) snapper or"
- elog "http://snapper.io/documentation.html"
+ elog "http://snapper.io/documentation.html and"
+ elog "https://wiki.gentoo.org/wiki/Snapper"
}
diff --git a/app-backup/snapper/snapper-0.8.6.ebuild b/app-backup/snapper/snapper-0.8.6.ebuild
deleted file mode 100644
index 1fcb91d42362..000000000000
--- a/app-backup/snapper/snapper-0.8.6.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit systemd bash-completion-r1
-
-DESCRIPTION="Command-line program for btrfs and lvm snapshot management"
-HOMEPAGE="http://snapper.io/"
-SRC_URI="ftp://ftp.suse.com/pub/projects/snapper/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="lvm pam xattr"
-
-RDEPEND="dev-libs/boost:=[threads]
- dev-libs/libxml2
- dev-libs/icu:=
- sys-apps/acl
- sys-apps/dbus
- sys-apps/util-linux
- >=sys-fs/btrfs-progs-3.17.1
- sys-libs/zlib
- virtual/libintl
- lvm? ( sys-fs/lvm2 )
- pam? ( sys-libs/pam )
- xattr? ( sys-apps/attr )"
-
-DEPEND="${RDEPEND}
- sys-devel/gettext
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/cron-confd.patch
-)
-
-src_prepare() {
- default
-
- sed -e "s,/usr/lib/systemd/system,$(systemd_get_systemunitdir),g" \
- -i data/Makefile.* \
- || die "Failed to fix systemd services and timers installation path"
-}
-
-src_configure() {
- # ext4 code does not work anymore
- # snapper does not build without btrfs
- local myeconfargs=(
- --with-conf="/etc/conf.d"
- --disable-zypp
- --enable-rollback
- --disable-ext4
- --enable-btrfs
- $(use_enable lvm)
- $(use_enable pam)
- $(use_enable xattr xattrs)
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- # Existing configuration file required to function
- newconfd data/sysconfig.snapper snapper
- find "${D}" -name '*.la' -delete || die
- newbashcomp "${FILESDIR}"/${PN}.bash ${PN}
-}
-
-pkg_postinst() {
- elog "In order to use Snapper, you need to set up"
- elog "at least one config first. To do this, run:"
- elog "snapper create-config <subvolume>"
- elog "For more information, see man (8) snapper or"
- elog "http://snapper.io/documentation.html"
-}