summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/btrbk/Manifest1
-rw-r--r--app-backup/btrbk/btrbk-0.26.1.ebuild45
-rw-r--r--app-backup/btrbk/btrbk-9999.ebuild2
3 files changed, 47 insertions, 1 deletions
diff --git a/app-backup/btrbk/Manifest b/app-backup/btrbk/Manifest
index 3296b5ae7229..f433db79d295 100644
--- a/app-backup/btrbk/Manifest
+++ b/app-backup/btrbk/Manifest
@@ -1,3 +1,4 @@
DIST btrbk-0.24.0.tar.xz 72308 BLAKE2B 425811455087a5aec4443d8a7bc7ed23cd49813d839a17c818f3e61f4b162518f282da69aa0b1c100b24c47684a7c6d83765332cfbf1893496dbf7e0aeabff87 SHA512 fbe180743743ead1241968765b5ae6eff37b2925bee8379443568c126426f2098d280a3f62d13e5f5b63f967ac9889ad9331d73f354d0cd441c907ba92258267
DIST btrbk-0.25.1.tar.xz 74904 BLAKE2B 12f0a1e9c383b1c736cba190bae6f948df5db608a689e2469af05716d2ed15f0206c9336148af1a09f29da44c44314d4d153c8d2e5eea8f7e425a185c9040d6d SHA512 6802e379f49c5433a811f6f844cf2663c752b23d8d678f001bb8cba9b099c7527983e23169814c7469ab8682b95fa0f742d1088415747ebebfe0fcc36425cd05
DIST btrbk-0.26.0.tar.xz 82472 BLAKE2B 06effda16b2173e6d3dc3ea896ed9729d6f2840a29aebc0d271935a88fd54fbbc08bf0b257c8424976a2668907c74f1b34fe46465ba6457d60cacf0b15316052 SHA512 a08ec4e2e0d164b9a9a17b3d4b8417eb3890994c8aa2233ecda9d616659fce917311a94fdfd6762acacb40dc25a60fe8f6880703c980ccd4a176b14e24a2bb00
+DIST btrbk-0.26.1.tar.xz 83624 BLAKE2B a99c66dc16432edb1da38ac51e68ed939207ad8553108258346d4261c243a1a478a3e1dca1cf6d39d03e10a8a5c44e45a7784aec131246e060aded4fc24d708e SHA512 ee0043f468e11545ca28b5bd456aa9dab1b994ed6d8899ab0f53d455f78bb44f83bcf493e32fdecfec82b3029d5dabc2db72a2f32de80b709a12930df6d53b22
diff --git a/app-backup/btrbk/btrbk-0.26.1.ebuild b/app-backup/btrbk/btrbk-0.26.1.ebuild
new file mode 100644
index 000000000000..621ad7e2a0a0
--- /dev/null
+++ b/app-backup/btrbk/btrbk-0.26.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/digint/btrbk.git"
+ inherit git-r3
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://digint.ch/download/btrbk/releases/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Tool for creating snapshots and remote backups of btrfs subvolumes"
+HOMEPAGE="https://digint.ch/btrbk/"
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+pv"
+
+DEPEND=">=app-text/asciidoc-8.6.0
+ app-text/xmlto"
+
+RDEPEND="dev-lang/perl
+ net-misc/openssh
+ pv? ( sys-apps/pv )
+ >=sys-fs/btrfs-progs-3.18.2"
+
+src_install() {
+ emake DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" SYSTEMDDIR="$(systemd_get_systemunitdir)" install
+}
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-0.26.0" ; then
+ upgrade_0_26_0_warning="1"
+ fi
+}
+pkg_postinst() {
+ if [[ "${upgrade_0_26_0_warning}" == "1" ]]; then
+ ewarn "If you are using raw targets, make sure to run the"
+ ewarn "\"raw_suffix2sidecar\" utility in each target directory."
+ fi
+}
diff --git a/app-backup/btrbk/btrbk-9999.ebuild b/app-backup/btrbk/btrbk-9999.ebuild
index 78df68d02414..621ad7e2a0a0 100644
--- a/app-backup/btrbk/btrbk-9999.ebuild
+++ b/app-backup/btrbk/btrbk-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6