summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/mirdir/files/mirdir-2.1-implicit-function-decl.patch11
-rw-r--r--app-backup/mirdir/mirdir-2.1-r3.ebuild39
2 files changed, 50 insertions, 0 deletions
diff --git a/app-backup/mirdir/files/mirdir-2.1-implicit-function-decl.patch b/app-backup/mirdir/files/mirdir-2.1-implicit-function-decl.patch
new file mode 100644
index 000000000000..e9e824d9f019
--- /dev/null
+++ b/app-backup/mirdir/files/mirdir-2.1-implicit-function-decl.patch
@@ -0,0 +1,11 @@
+https://bugs.gentoo.org/854213
+--- a/mirdir.c
++++ b/mirdir.c
+@@ -88,6 +88,7 @@
+ #include <fcntl.h>
+ #include <dirent.h>
+ #include <time.h>
++#include <unistd.h>
+
+ /*
+ #include <sys/types.h>
diff --git a/app-backup/mirdir/mirdir-2.1-r3.ebuild b/app-backup/mirdir/mirdir-2.1-r3.ebuild
new file mode 100644
index 000000000000..ac0a24f319bd
--- /dev/null
+++ b/app-backup/mirdir/mirdir-2.1-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Synchronize two directory trees in a fast way"
+HOMEPAGE="https://sourceforge.net/projects/mirdir/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-Unix.tar.gz"
+S="${WORKDIR}/${P}-UNIX"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1-implicit-function-decl.patch
+)
+
+src_prepare() {
+ default
+
+ # Disable stripping, bug #239939
+ sed -i -e 's:strip .*::' Makefile.in || die
+}
+
+src_configure() {
+ # Old autoconf gets this test wrong with -flto(!) and there's
+ # no source configure.in/.ac in the tarball. bug #854213
+ export ac_cv_func_lutime=no
+
+ econf
+}
+
+src_install() {
+ dobin bin/${PN}
+ doman ${PN}.1
+
+ einstalldocs
+}