summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/bootchart2')
-rw-r--r--app-benchmarks/bootchart2/Manifest2
-rw-r--r--app-benchmarks/bootchart2/bootchart2-0.14.9-r1.ebuild (renamed from app-benchmarks/bootchart2/bootchart2-0.14.8-r1.ebuild)52
-rw-r--r--app-benchmarks/bootchart2/files/bootchart2-0.14.7-sysmacros.patch30
-rw-r--r--app-benchmarks/bootchart2/files/bootchart2-0.14.9-glibc-2.36.patch24
-rw-r--r--app-benchmarks/bootchart2/metadata.xml2
5 files changed, 66 insertions, 44 deletions
diff --git a/app-benchmarks/bootchart2/Manifest b/app-benchmarks/bootchart2/Manifest
index 34f275c76d38..25884e051afb 100644
--- a/app-benchmarks/bootchart2/Manifest
+++ b/app-benchmarks/bootchart2/Manifest
@@ -1 +1 @@
-DIST bootchart2-0.14.8.tar.gz 1175527 BLAKE2B 623ca2269420eda79b09d955ab9d4a37af004e9e97ad0e0c6014e53b4b0c63239661cb5359345306504980b060ccd11488970cb0aa3d832bfb55392724e715dd SHA512 58303db91d22ccc44c0dc765e7a6672fb277840555fd87ce64b8987cba85250cfe3db17f3ec7e0e1e726ad59166a5d3d01a7a262c07b5690c595877b46c66bd0
+DIST bootchart2-0.14.9.tar.gz 1175710 BLAKE2B af472193c7de313e770da1a88baf00e9ee38e36c0d3c900bab2657bfa5d2398dd9edc616ec770f49a6c5fa8e29f738ddf2c0951ea039a48a2a89b0ffd94759fb SHA512 7ee1220b0add027fc39f710cc01119d7aaa22fe11736497b089c26955216cef10552216ed29ca55bf08aa848f92bb11d74deeb3aa69769dfecf3a55aa988e58b
diff --git a/app-benchmarks/bootchart2/bootchart2-0.14.8-r1.ebuild b/app-benchmarks/bootchart2/bootchart2-0.14.9-r1.ebuild
index 6cb11cd3e6ea..fe460f6fbd0a 100644
--- a/app-benchmarks/bootchart2/bootchart2-0.14.8-r1.ebuild
+++ b/app-benchmarks/bootchart2/bootchart2-0.14.9-r1.ebuild
@@ -1,49 +1,75 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit linux-info systemd toolchain-funcs
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit linux-info python-single-r1 systemd toolchain-funcs
DESCRIPTION="Performance analysis and visualization of the system boot process"
-HOMEPAGE="https://github.com/mmeeks/bootchart/"
-SRC_URI="https://github.com/mmeeks/bootchart/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/xrmx/bootchart"
+SRC_URI="https://github.com/xrmx/bootchart/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+cairo"
-RESTRICT="test"
+REQUIRED_USE="cairo? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!cairo? ( test )"
RDEPEND="
- !app-benchmarks/bootchart
- sys-apps/lsb-release"
+ cairo? ( ${PYTHON_DEPS} $(python_gen_cond_dep 'dev-python/pycairo[${PYTHON_USEDEP}]') )
+ sys-apps/lsb-release
+"
+BDEPEND="cairo? ( ${PYTHON_DEPS} )"
S="${WORKDIR}"/${PN%2}-${PV}
CONFIG_CHECK="~PROC_EVENTS ~TASKSTATS ~TASK_DELAY_ACCT ~TMPFS"
PATCHES=(
- "${FILESDIR}"/${PN}-0.14.7-sysmacros.patch # bug 579922
- "${FILESDIR}"/${P}-no-compressed-man.patch
+ "${FILESDIR}"/${PN}-0.14.8-no-compressed-man.patch
+ "${FILESDIR}"/${P}-glibc-2.36.patch
)
src_prepare() {
default
+ python_setup
tc-export CC
+
+ # Redirects systemd unit directory,
+ # as well as disable the built-in python setup.
sed -i \
- -e "/^install/s:py-install-compile::g" \
-e "/^SYSTEMD_UNIT_DIR/s:=.*:= $(systemd_get_systemunitdir):g" \
+ -e "/^install/s:py-install-compile::g" \
+ -e "/pybootchartgui.1/d" \
Makefile || die
+
sed -i \
-e '/^EXIT_PROC/s:^.*$:EXIT_PROC="agetty mgetty mingetty:g' \
bootchartd.conf bootchartd.in || die
}
+src_test() {
+ emake test
+}
+
src_install() {
export DOCDIR=/usr/share/doc/${PF}
default
+ if use cairo; then
+ doman pybootchartgui.1
+
+ python_scriptinto /usr/bin
+ python_newscript pybootchartgui{.py,}
+
+ python_domodule pybootchartgui
+ python_optimize
+ fi
+
# Note: LIBDIR is hardcoded as /lib in collector/common.h, so we shouldn't
# just change it. Since no libraries are installed, /lib is fine.
keepdir /lib/bootchart/tmpfs
@@ -54,5 +80,7 @@ src_install() {
pkg_postinst() {
elog "If you are using an initrd during boot"
elog "please add the init script to your default runlevel"
- elog "rc-update add bootchart2 default"
+ if has_version sys-apps/openrc; then
+ elog "rc-update add bootchart2 default"
+ fi
}
diff --git a/app-benchmarks/bootchart2/files/bootchart2-0.14.7-sysmacros.patch b/app-benchmarks/bootchart2/files/bootchart2-0.14.7-sysmacros.patch
deleted file mode 100644
index 48cf685c0ca6..000000000000
--- a/app-benchmarks/bootchart2/files/bootchart2-0.14.7-sysmacros.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-https://bugs.gentoo.org/579922
-https://github.com/xrmx/bootchart/commit/add58c3b57064afd6f7d2fd5f09006d28a3e770e
-
-From add58c3b57064afd6f7d2fd5f09006d28a3e770e Mon Sep 17 00:00:00 2001
-From: Mike Frysinger <vapier@gentoo.org>
-Date: Thu, 21 Apr 2016 00:19:32 -0400
-Subject: [PATCH] include sys/sysmacros.h for major/minor/makedev
-
-These funcs are defined in the sys/sysmacros.h header, not sys/types.h.
-Linux C libraries are updating to drop the implicit include, so we need
-to include it explicitly.
----
- collector/collector.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/collector/collector.c b/collector/collector.c
-index cfdcb26..2f3ce6b 100644
---- a/collector/collector.c
-+++ b/collector/collector.c
-@@ -33,6 +33,7 @@
- #include "common.h"
-
- #include <sys/mount.h>
-+#include <sys/sysmacros.h>
- #include <linux/fs.h>
- #include <linux/genetlink.h>
- #include <linux/taskstats.h>
---
-2.7.4
-
diff --git a/app-benchmarks/bootchart2/files/bootchart2-0.14.9-glibc-2.36.patch b/app-benchmarks/bootchart2/files/bootchart2-0.14.9-glibc-2.36.patch
new file mode 100644
index 000000000000..720079e9d794
--- /dev/null
+++ b/app-benchmarks/bootchart2/files/bootchart2-0.14.9-glibc-2.36.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/864205
+https://github.com/xrmx/bootchart/commit/8591c1e3edaea8f17396e3d2819d9064b2818cfb
+
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 6 Aug 2022 20:39:01 -0700
+Subject: [PATCH] Do not include linux/fs.h
+
+This header is not needed to be included anymore, moreover it conflicts
+with sys/mount.h from glibc 2.36+ see [1]
+
+[1] https://sourceware.org/glibc/wiki/Release/2.36
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/collector/collector.c
++++ b/collector/collector.c
+@@ -34,7 +34,6 @@
+
+ #include <sys/mount.h>
+ #include <sys/sysmacros.h>
+-#include <linux/fs.h>
+ #include <linux/genetlink.h>
+ #include <linux/taskstats.h>
+ #include <linux/cgroupstats.h>
+
diff --git a/app-benchmarks/bootchart2/metadata.xml b/app-benchmarks/bootchart2/metadata.xml
index b714966c25dd..bfa8fcd41ce7 100644
--- a/app-benchmarks/bootchart2/metadata.xml
+++ b/app-benchmarks/bootchart2/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
<upstream>