summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/ioping')
-rw-r--r--app-benchmarks/ioping/Manifest2
-rw-r--r--app-benchmarks/ioping/ioping-1.2.ebuild24
-rw-r--r--app-benchmarks/ioping/ioping-1.3.ebuild24
-rw-r--r--app-benchmarks/ioping/metadata.xml2
4 files changed, 51 insertions, 1 deletions
diff --git a/app-benchmarks/ioping/Manifest b/app-benchmarks/ioping/Manifest
index eb34bea72664..3e64362c4df6 100644
--- a/app-benchmarks/ioping/Manifest
+++ b/app-benchmarks/ioping/Manifest
@@ -1 +1,3 @@
DIST ioping-1.1.tar.gz 29251 BLAKE2B 2f0ec642c3545b8e603f90187f48bf44e1ef665a99bc04af4d5e6441016c9509875e8e05c1cc8715fd080c8a498c7374cf5db562a3203d7075edbe85683ccdbb SHA512 67802a6ab552ad1fdb8894f4d814601c2f66154f4bfc50fa0001d881694864c1a70882b4ba2d0f50cbd484472dc649a22b312f802a3bacc3317671971bdc0201
+DIST ioping-1.2.tar.gz 30819 BLAKE2B 5f46ee783d51e4bea88a6036fba97c053e507f53183344d17fbfa6dd304d6cb76737ccff23c46ccce1fff8107d94e4e192264a3bf22062a7ea96b2a4475fb311 SHA512 4029f1b50dc292734088dc741e594c56021610aad16a0b9f42875b5fe91fbdf8d566a41dab0384aa739350f74e62688efdaf88168ab0d838b9c848ddd1c5dd96
+DIST ioping-1.3.tar.gz 33507 BLAKE2B 91d5eb2337aa4d403f9b335a2212ae3eec5c8786f382abec5bce852f5fd79cb0e0f25d83856cb42b1598032d10630b49bf1905eaa04856b5438e9e1e494c0c7d SHA512 52ca9596d0d54a02e58e40b777d31b44a3f10fd45b76d25ab491f7e6d126dfb9c4205c9b427b69bdc2012282ec8c5846db964d420913f4d91fa5101baa99089d
diff --git a/app-benchmarks/ioping/ioping-1.2.ebuild b/app-benchmarks/ioping/ioping-1.2.ebuild
new file mode 100644
index 000000000000..4be915c0f72e
--- /dev/null
+++ b/app-benchmarks/ioping/ioping-1.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple disk I/0 latency measuring tool"
+HOMEPAGE="https://github.com/koct9i/ioping"
+SRC_URI="https://github.com/koct9i/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+
+ dodoc changelog README.md
+}
diff --git a/app-benchmarks/ioping/ioping-1.3.ebuild b/app-benchmarks/ioping/ioping-1.3.ebuild
new file mode 100644
index 000000000000..d466ce4f1b5c
--- /dev/null
+++ b/app-benchmarks/ioping/ioping-1.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple disk I/0 latency measuring tool"
+HOMEPAGE="https://github.com/koct9i/ioping"
+SRC_URI="https://github.com/koct9i/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+
+ dodoc changelog README.md
+}
diff --git a/app-benchmarks/ioping/metadata.xml b/app-benchmarks/ioping/metadata.xml
index 55ad5be23a2b..25d98b1f3af9 100644
--- a/app-benchmarks/ioping/metadata.xml
+++ b/app-benchmarks/ioping/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>shell-tools@gentoo.org</email>