summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/cddetect/cddetect-2.1.ebuild')
-rw-r--r--app-cdr/cddetect/cddetect-2.1.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/app-cdr/cddetect/cddetect-2.1.ebuild b/app-cdr/cddetect/cddetect-2.1.ebuild
index 5de6bf19692a..ed051629ee1b 100644
--- a/app-cdr/cddetect/cddetect-2.1.ebuild
+++ b/app-cdr/cddetect/cddetect-2.1.ebuild
@@ -1,23 +1,21 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
+
inherit toolchain-funcs
-DESCRIPTION="A tool for detecting the type of a CD/DVD without mounting it"
+DESCRIPTION="Tool for detecting the type of a CD/DVD without mounting it"
HOMEPAGE="http://www.bellut.net/projects.html"
SRC_URI="http://www.bellut.net/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
S=${WORKDIR}
-src_prepare() {
- sed -i -e '1i#include <limits.h>' ${PN}.c || die #337628
-}
+PATCHES=( "${FILESDIR}"/"${P}"-fix-include.patch ) #337628
src_compile() {
emake CC="$(tc-getCC)" CFLAGS="-Wall ${CFLAGS}"