summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/cdw')
-rw-r--r--app-cdr/cdw/cdw-0.8.1-r3.ebuild (renamed from app-cdr/cdw/cdw-0.8.1-r1.ebuild)13
-rw-r--r--app-cdr/cdw/cdw-0.8.1.ebuild34
-rw-r--r--app-cdr/cdw/cdw-9999.ebuild40
-rw-r--r--app-cdr/cdw/files/cdw-0.8.1-fix-ar-call.patch4
-rw-r--r--app-cdr/cdw/metadata.xml8
5 files changed, 9 insertions, 90 deletions
diff --git a/app-cdr/cdw/cdw-0.8.1-r1.ebuild b/app-cdr/cdw/cdw-0.8.1-r3.ebuild
index c524d89d06de..d60619dc4f39 100644
--- a/app-cdr/cdw/cdw-0.8.1-r1.ebuild
+++ b/app-cdr/cdw/cdw-0.8.1-r3.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit autotools toolchain-funcs
DESCRIPTION="An ncurses based console frontend for cdrtools and dvd+rw-tools"
@@ -10,14 +11,14 @@ SRC_URI="mirror://sourceforge/cdw/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ~ppc x86"
RDEPEND="
+ app-cdr/cdrtools
app-cdr/dvd+rw-tools
dev-libs/libburn
dev-libs/libcdio:=[-minimal]
- sys-libs/ncurses:0=[unicode]
- virtual/cdrtools
+ sys-libs/ncurses:=
"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
@@ -32,5 +33,5 @@ src_prepare() {
}
src_configure() {
- econf LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses )"
+ econf LIBS="$( $(tc-getPKG_CONFIG) --libs ncursesw )"
}
diff --git a/app-cdr/cdw/cdw-0.8.1.ebuild b/app-cdr/cdw/cdw-0.8.1.ebuild
deleted file mode 100644
index 3b50e3848a7f..000000000000
--- a/app-cdr/cdw/cdw-0.8.1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit toolchain-funcs
-
-DESCRIPTION="An ncurses based console frontend for cdrtools and dvd+rw-tools"
-HOMEPAGE="http://cdw.sourceforge.net"
-SRC_URI="mirror://sourceforge/cdw/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-
-RDEPEND="
- virtual/cdrtools
- app-cdr/dvd+rw-tools
- dev-libs/libburn
- dev-libs/libcdio[-minimal]
- sys-libs/ncurses:*[unicode]
-"
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
-
-src_configure() {
- econf LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses )"
-}
-
-src_install() {
- DOCS="AUTHORS ChangeLog NEWS README THANKS cdw.conf" \
- default
-}
diff --git a/app-cdr/cdw/cdw-9999.ebuild b/app-cdr/cdw/cdw-9999.ebuild
deleted file mode 100644
index f23f85b84c76..000000000000
--- a/app-cdr/cdw/cdw-9999.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-ECVS_SERVER="cdw.cvs.sourceforge.net:/cvsroot/cdw"
-ECVS_MODULE="cdw"
-ECVS_TOPDIR="${DISTDIR}/cvs-src/${ECVS_MODULE}"
-
-inherit autotools cvs toolchain-funcs
-
-DESCRIPTION="An ncurses based console frontend for cdrtools and dvd+rw-tools"
-HOMEPAGE="http://cdw.sourceforge.net"
-
-LICENSE="GPL-2+"
-SLOT="0"
-
-RDEPEND="
- app-cdr/dvd+rw-tools
- dev-libs/libburn
- dev-libs/libcdio:=[-minimal]
- sys-libs/ncurses:0=[unicode]
- virtual/cdrtools
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-S=${WORKDIR}/${ECVS_MODULE}
-
-PATCHES=( "${FILESDIR}/${PN}-0.8.1-fix-ar-call.patch" )
-
-DOCS=( AUTHORS ChangeLog NEWS README THANKS cdw.conf )
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses )"
-}
diff --git a/app-cdr/cdw/files/cdw-0.8.1-fix-ar-call.patch b/app-cdr/cdw/files/cdw-0.8.1-fix-ar-call.patch
index a578696c1c82..3ad1aaa6a935 100644
--- a/app-cdr/cdw/files/cdw-0.8.1-fix-ar-call.patch
+++ b/app-cdr/cdw/files/cdw-0.8.1-fix-ar-call.patch
@@ -1,5 +1,3 @@
-diff --git a/configure.ac b/configure.ac
-index 76627c7..527e2cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -119,7 +119,7 @@ AC_TYPE_UINT16_T
@@ -11,8 +9,6 @@ index 76627c7..527e2cb 100644
-diff --git a/src/user_interface/Makefile.in b/src/user_interface/Makefile.in
-index 5d5f1fc..4d8214b 100644
--- a/src/user_interface/Makefile.in
+++ b/src/user_interface/Makefile.in
@@ -88,7 +88,7 @@ CONFIG_HEADER = $(top_builddir)/config_cdw.h
diff --git a/app-cdr/cdw/metadata.xml b/app-cdr/cdw/metadata.xml
index 9325abc85670..ffc106331422 100644
--- a/app-cdr/cdw/metadata.xml
+++ b/app-cdr/cdw/metadata.xml
@@ -1,14 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>arthurzam+gentoo@gmail.com</email>
+ <email>arthurzam@gentoo.org</email>
<name>Arthur Zamarin</name>
</maintainer>
- <maintainer type="project">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
<upstream>
<remote-id type="sourceforge">cdw</remote-id>
</upstream>