summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/dolphin-plugins-mountiso')
-rw-r--r--app-cdr/dolphin-plugins-mountiso/Manifest5
-rw-r--r--app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-23.04.3.ebuild (renamed from app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-21.04.3.ebuild)23
-rw-r--r--app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-23.08.5.ebuild (renamed from app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-20.12.3-r1.ebuild)27
-rw-r--r--app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.02.2.ebuild61
-rw-r--r--app-cdr/dolphin-plugins-mountiso/files/dolphin-plugins-mountiso-20.12.3-dont-mount-ISO-multiple-times.patch41
-rw-r--r--app-cdr/dolphin-plugins-mountiso/metadata.xml6
6 files changed, 89 insertions, 74 deletions
diff --git a/app-cdr/dolphin-plugins-mountiso/Manifest b/app-cdr/dolphin-plugins-mountiso/Manifest
index f6002974130f..6ccdd0183bd1 100644
--- a/app-cdr/dolphin-plugins-mountiso/Manifest
+++ b/app-cdr/dolphin-plugins-mountiso/Manifest
@@ -1,2 +1,3 @@
-DIST dolphin-plugins-20.12.3.tar.xz 239340 BLAKE2B 141e5d2bb6190edaef98cec2a271e41b916966118300d69f4eb5e7da15e51730476f23a20312b76fca0fc1490501e83528b4f0cb62f9f6c64e4caf5ac5b2cd37 SHA512 1d5303e92d912bc80c5260263b081205d36372f1f15205ebd3e705697a114f8481edd1ad31004d7906c3088d43a74cb1e33dac6e1196c247e702a544d67db11b
-DIST dolphin-plugins-21.04.3.tar.xz 253244 BLAKE2B c5c0e302dfc4eb82e2de1a635824bf8fd2c70bcac65c261253f0e52e7d9242fa339fe2dc619b927b0379477b2c80a22ec210080af8f2370e0a0182af3347df6a SHA512 e4beba0d596782951b149d42e930d76b12a36bea83f35eb0cff9e49b3e02d4b2aa55f4245d4b8708044a49770d477badc964752828eef4caeaefd4f16e5f9dad
+DIST dolphin-plugins-23.04.3.tar.xz 272912 BLAKE2B f0eb8bbab16d66f1e964131b436af7d3ae8febc26cf4fe394489a978c701ef2f5689bea7daf9eed8d7ef2f1f2bdba000a487cf7f0704ad30bd25e2d403ce5fae SHA512 8f487ba0bcbe561915064247ddb2327c3b7c8fa6ffc5c511d9c9ef37bd4f28a624533ce7a2da2a86b10b65f37915ca10840517872b40c2fd014cead6da5972c8
+DIST dolphin-plugins-23.08.5.tar.xz 274124 BLAKE2B c8b43bd7f87c7221023e75e3f66b450844b379d5bfc95e37ce01dfe983ba3dc234a319da2aaf0596e6eb54319bc4310c718b57d52d070f0f86cd67c6f67a8c4b SHA512 2dd30070660df63b988cda2e14f3ddc27a0cf451119d2a6b121cb9cbeb8788b94498ef25ca434501843784a8e24c4539fe17cc0ab5a158befbc9db5792944852
+DIST dolphin-plugins-24.02.2.tar.xz 298356 BLAKE2B e40f64b6a97961ba9f614ba2a795d42c460b65073e1ab5c502cbd87f4810e0e381562890646501446af544aec5e7f790be266ec41407ef156e8a27ac0ba0d555 SHA512 585249422ef1637c2caee044a71d11c621127ef578131d2323e879b12bee2f17082c4811273e6bb0013d1386f7010ded187627965bfce0b1b412b25048cd11d8
diff --git a/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-21.04.3.ebuild b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-23.04.3.ebuild
index d0900ab81df2..757e800a8fd2 100644
--- a/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-21.04.3.ebuild
+++ b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-23.04.3.ebuild
@@ -1,24 +1,23 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
ECM_HANDBOOK="false"
-KDE_GEAR="true"
KDE_ORG_CATEGORY="sdk"
KDE_ORG_NAME="dolphin-plugins"
MY_PLUGIN_NAME="mountiso"
-KFMIN=5.80.0
+KFMIN=5.106.0
PVCUT=$(ver_cut 1-3)
-QTMIN=5.15.2
-inherit ecm kde.org
+QTMIN=5.15.9
+inherit ecm gear.kde.org
DESCRIPTION="Dolphin plugin for ISO loopback device mounting"
HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
-LICENSE="GPL-2" # TODO: CHECK
+LICENSE="GPL-2+"
SLOT="5"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+KEYWORDS="amd64 arm64 ~loong ~ppc64 x86"
IUSE=""
DEPEND="
@@ -39,12 +38,10 @@ RDEPEND="${DEPEND}"
src_prepare() {
ecm_src_prepare
# kxmlgui, qtnetwork only required by dropbox
- ecm_punt_bogus_dep Qt5 Network
- ecm_punt_bogus_dep KF5 XmlGui
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
# delete non-${PN} translations
- if [[ ${KDE_BUILD_TYPE} = release ]]; then
- find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
- fi
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
}
src_configure() {
diff --git a/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-20.12.3-r1.ebuild b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-23.08.5.ebuild
index ba1a5e701209..31c30bf004dc 100644
--- a/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-20.12.3-r1.ebuild
+++ b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-23.08.5.ebuild
@@ -1,24 +1,23 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
ECM_HANDBOOK="false"
-KDE_RELEASE_SERVICE="true"
KDE_ORG_CATEGORY="sdk"
KDE_ORG_NAME="dolphin-plugins"
MY_PLUGIN_NAME="mountiso"
-KFMIN=5.75.0
+KFMIN=5.106.0
PVCUT=$(ver_cut 1-3)
-QTMIN=5.15.2
-inherit ecm kde.org
+QTMIN=5.15.9
+inherit ecm gear.kde.org
DESCRIPTION="Dolphin plugin for ISO loopback device mounting"
HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
-LICENSE="GPL-2" # TODO: CHECK
+LICENSE="GPL-2+"
SLOT="5"
-KEYWORDS="amd64 arm64 ~ppc64 x86"
+KEYWORDS="amd64 arm64 ~loong ~ppc64 x86"
IUSE=""
DEPEND="
@@ -36,19 +35,13 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-PATCHES=(
- "${FILESDIR}/${P}-dont-mount-ISO-multiple-times.patch" # KDE-bug 434617
-)
-
src_prepare() {
ecm_src_prepare
# kxmlgui, qtnetwork only required by dropbox
- ecm_punt_bogus_dep Qt5 Network
- ecm_punt_bogus_dep KF5 XmlGui
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
# delete non-${PN} translations
- if [[ ${KDE_BUILD_TYPE} = release ]]; then
- find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
- fi
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
}
src_configure() {
diff --git a/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.02.2.ebuild b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.02.2.ebuild
new file mode 100644
index 000000000000..11419012f809
--- /dev/null
+++ b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.02.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_CATEGORY="sdk"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="mountiso"
+KFMIN=6.0.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for ISO loopback device mounting"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets]
+ >=kde-apps/dolphin-${PVCUT}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+ >=kde-frameworks/solid-${KFMIN}:6
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # delete non-${PN} translations
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_makefileactions=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}
diff --git a/app-cdr/dolphin-plugins-mountiso/files/dolphin-plugins-mountiso-20.12.3-dont-mount-ISO-multiple-times.patch b/app-cdr/dolphin-plugins-mountiso/files/dolphin-plugins-mountiso-20.12.3-dont-mount-ISO-multiple-times.patch
deleted file mode 100644
index fc59e1718503..000000000000
--- a/app-cdr/dolphin-plugins-mountiso/files/dolphin-plugins-mountiso-20.12.3-dont-mount-ISO-multiple-times.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From f136702d2adc8643ea12f1b6e3bf97925f1b33f0 Mon Sep 17 00:00:00 2001
-From: Kwon-Young Choi <kwon-young.choi@hotmail.fr>
-Date: Fri, 19 Mar 2021 17:10:31 +0100
-Subject: [PATCH] BackingFile property should be use with StorageVolume instead
- of StorageAccess
-
-BUG: 434617
-
-When mounting an iso with `udisksctl`, first a loop device is created
-`/dev/loop0` then a second device `/dev/loop0p1` is used to mount it on
-a filesystem location.
-
-Querying for StorageAccess devices sometimes only returns the `/dev/loop0p1`
-device without the `/dev/loop0` device and the BackingFile property does not
-work on `/dev/loop0p1`.
-
-Solution: query for StorageVolume instead which returns all loop devices:
-`/dev/loop0` and `/dev/loop1`.
-
-Warning: Because StorageVolume returns more devices, the function
-`getDeviceFromBackingFile` could be a little bit slower.
----
- mountiso/mountisoaction.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/mountiso/mountisoaction.cpp b/mountiso/mountisoaction.cpp
-index e5575ae..d198a89 100644
---- a/mountiso/mountisoaction.cpp
-+++ b/mountiso/mountisoaction.cpp
-@@ -78,7 +78,7 @@ MountIsoAction::MountIsoAction(QObject *parent, const QVariantList &)
- const Solid::Device getDeviceFromBackingFile(const QString &backingFile)
- {
- const QList<Solid::Device> blockDevices =
-- Solid::Device::listFromQuery("[ IS StorageAccess AND IS GenericInterface ]");
-+ Solid::Device::listFromQuery("[ IS StorageVolume AND IS GenericInterface ]");
-
- for (const Solid::Device &device : blockDevices) {
- auto genericDevice = device.as<Solid::GenericInterface>();
---
-GitLab
-
diff --git a/app-cdr/dolphin-plugins-mountiso/metadata.xml b/app-cdr/dolphin-plugins-mountiso/metadata.xml
index 2fdbf33d963d..858b75c358bc 100644
--- a/app-cdr/dolphin-plugins-mountiso/metadata.xml
+++ b/app-cdr/dolphin-plugins-mountiso/metadata.xml
@@ -1,8 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>kde@gentoo.org</email>
<name>Gentoo KDE Project</name>
</maintainer>
+ <upstream>
+ <bugs-to>https://bugs.kde.org/</bugs-to>
+ <remote-id type="kde-invent">sdk/dolphin-plugins</remote-id>
+ </upstream>
</pkgmetadata>