summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/plextor-tool/plextor-tool-0.5.0.ebuild')
-rw-r--r--app-cdr/plextor-tool/plextor-tool-0.5.0.ebuild21
1 files changed, 15 insertions, 6 deletions
diff --git a/app-cdr/plextor-tool/plextor-tool-0.5.0.ebuild b/app-cdr/plextor-tool/plextor-tool-0.5.0.ebuild
index 39a125aaf854..0822d71769e4 100644
--- a/app-cdr/plextor-tool/plextor-tool-0.5.0.ebuild
+++ b/app-cdr/plextor-tool/plextor-tool-0.5.0.ebuild
@@ -1,34 +1,43 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="Tool to change the parameters of a Plextor CD-ROM drive"
HOMEPAGE="http://plextor-tool.sourceforge.net/"
SRC_URI="mirror://sourceforge/plextor-tool/${P}.src.tar.bz2"
+S="${WORKDIR}"/${PN}/src
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="static"
-S=${WORKDIR}/${PN}/src
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${P}-build.patch
+ default
+
gunzip plextor-tool.8.gz || die
}
src_compile() {
local targets="plextor-tool"
+
use static && targets="${targets} pt-static"
- echo ${targets} > my-make-targets
+
+ echo ${targets} > my-make-targets || die
+
emake CC="$(tc-getCC)" ${targets}
}
src_install() {
local targets=$(<my-make-targets)
+
dodoc ../doc/{NEWS,README} TODO
dobin ${targets}
doman plextor-tool.8