summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/containers-common/containers-common-9999.ebuild')
-rw-r--r--app-containers/containers-common/containers-common-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/app-containers/containers-common/containers-common-9999.ebuild b/app-containers/containers-common/containers-common-9999.ebuild
index 8963de7d6a47..f96e1c184a69 100644
--- a/app-containers/containers-common/containers-common-9999.ebuild
+++ b/app-containers/containers-common/containers-common-9999.ebuild
@@ -3,10 +3,10 @@
EAPI=8
-DESCRIPTION="Common config files and docs for Containers eco-system"
+DESCRIPTION="Common config files and docs for Containers stack"
HOMEPAGE="https://github.com/containers/common"
-if [[ ${PV} == *9999* ]]; then
+if [[ ${PV} == 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/containers/common.git"
else
@@ -39,10 +39,10 @@ BDEPEND="
src_prepare() {
default
- [[ -f docs/Makefile ]] || die
- sed -i -e 's|/usr/local|/usr|g;' docs/Makefile || die
+ [[ -f docs/Makefile && -f Makefile ]] || die
+ sed -i -e 's|/usr/local|/usr|g;' docs/Makefile Makefile || die
- eapply "${FILESDIR}/fix-warnings.patch"
+ # add comments to mounts.conf
eapply "${FILESDIR}/examplify-mounts-conf.patch"
}
@@ -51,7 +51,7 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install
+ emake DESTDIR="${ED}" install
insinto /etc/containers
# https://github.com/containers/skopeo/raw/main/default-policy.json