summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/containers-image/containers-image-9999.ebuild')
-rw-r--r--app-containers/containers-image/containers-image-9999.ebuild14
1 files changed, 3 insertions, 11 deletions
diff --git a/app-containers/containers-image/containers-image-9999.ebuild b/app-containers/containers-image/containers-image-9999.ebuild
index a29e5e602b78..7e9e9b9dad81 100644
--- a/app-containers/containers-image/containers-image-9999.ebuild
+++ b/app-containers/containers-image/containers-image-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DESCRIPTION="Default config and docs related to Containers' images"
HOMEPAGE="https://github.com/containers/image"
-if [[ ${PV} == *9999* ]]; then
+if [[ ${PV} == 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/containers/image.git"
else
@@ -18,27 +18,19 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
-DEPEND=">=dev-go/go-md2man-2.0.2"
+BDEPEND=">=dev-go/go-md2man-2.0.2"
src_prepare() {
default
eapply "${FILESDIR}/fix-warnings.patch"
}
-src_configure() {
- return
-}
-
src_compile() {
emake docs
}
-src_test() {
- return
-}
-
src_install() {
- emake DESTDIR="${D}" install
+ emake DESTDIR="${ED}" install
insinto /etc/containers
doins registries.conf