summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/distrobox/distrobox-9999.ebuild')
-rw-r--r--app-containers/distrobox/distrobox-9999.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/app-containers/distrobox/distrobox-9999.ebuild b/app-containers/distrobox/distrobox-9999.ebuild
index 123c5f82a360..ddd8a782dfb3 100644
--- a/app-containers/distrobox/distrobox-9999.ebuild
+++ b/app-containers/distrobox/distrobox-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,13 +7,15 @@ DESCRIPTION="Use any Linux distribution inside your terminal (powered by docker/
HOMEPAGE="https://distrobox.privatedns.org/
https://github.com/89luca89/distrobox/"
-if [[ ${PV} == *9999* ]] ; then
+if [[ "${PV}" == *9999* ]] ; then
inherit git-r3
+
EGIT_REPO_URI="https://github.com/89luca89/${PN}.git"
else
SRC_URI="https://github.com/89luca89/${PN}/archive/${PV}.tar.gz
-> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~riscv ~x86"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
fi
LICENSE="GPL-3" # GPL-3.0-only !
@@ -27,6 +29,7 @@ RDEPEND="
"
src_install() {
- sh ./install --prefix "${ED}"/usr || die "${PN} install script failed"
+ sh ./install --prefix "${ED}/usr" || die "${PN} install script failed"
+
dodoc *.md
}