summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/netavark/netavark-1.8.0.ebuild')
-rw-r--r--app-containers/netavark/netavark-1.8.0.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/app-containers/netavark/netavark-1.8.0.ebuild b/app-containers/netavark/netavark-1.8.0.ebuild
deleted file mode 100644
index a029fc6efe59..000000000000
--- a/app-containers/netavark/netavark-1.8.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-[[ ${PV} == *9999* ]] || CRATES="${PN}@${PV}"
-
-inherit cargo systemd
-
-DESCRIPTION="A container network stack"
-HOMEPAGE="https://github.com/containers/netavark"
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/containers/netavark.git"
-else
- SRC_URI="${CARGO_CRATE_URIS} https://github.com/containers/netavark/releases/download/v${PV}/${PN}-v${PV}-vendor.tar.gz"
- KEYWORDS="amd64 arm64 ~ppc64 ~riscv"
-fi
-LICENSE="Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD BSD-2 Boost-1.0 MIT Unicode-DFS-2016 Unlicense ZLIB"
-SLOT="0"
-BDEPEND="dev-go/go-md2man
- dev-libs/protobuf"
-
-QA_FLAGS_IGNORED="
- usr/libexec/podman/${PN}"
-QA_PRESTRIPPED="
- usr/libexec/podman/${PN}"
-
-ECARGO_VENDOR="${WORKDIR}/vendor"
-
-src_unpack() {
- if [[ ${PV} == *9999* ]]; then
- git-r3_src_unpack
- cargo_live_src_unpack
- else
- cargo_src_unpack
- fi
-}
-
-src_prepare() {
- default
- sed -i -e "s|m0755 bin|m0755 target/$(usex debug debug release)|g;" Makefile || die
-}
-
-src_compile() {
- cargo_src_compile
- export PREFIX="${EPREFIX}"/usr SYSTEMDDIR="$(systemd_get_systemunitdir)"
- emake docs
-}
-
-src_install() {
- default
-}