summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/skopeo/skopeo-9999.ebuild')
-rw-r--r--app-containers/skopeo/skopeo-9999.ebuild50
1 files changed, 19 insertions, 31 deletions
diff --git a/app-containers/skopeo/skopeo-9999.ebuild b/app-containers/skopeo/skopeo-9999.ebuild
index b7a859d817d5..ab892d6789a8 100644
--- a/app-containers/skopeo/skopeo-9999.ebuild
+++ b/app-containers/skopeo/skopeo-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -38,9 +38,6 @@ RDEPEND="
BDEPEND="dev-go/go-md2man"
RESTRICT="test"
-PATCHES=(
- "${FILESDIR}"/makefile-1.14.0.patch
-)
pkg_setup() {
use btrfs && CONFIG_CHECK+=" ~BTRFS_FS"
@@ -48,34 +45,25 @@ pkg_setup() {
linux-info_pkg_setup
}
-src_prepare() {
- default
- local file
- for file in btrfs_installed_tag btrfs_tag libdm_tag libsubid_tag; do
- [[ -f hack/"${file}".sh ]] || die
- done
-
- echo -e "#!/usr/bin/env bash\n echo" > hack/btrfs_installed_tag.sh || die
- cat <<-EOF > hack/btrfs_tag.sh || die
- #!/usr/bin/env bash
- $(usex btrfs echo 'echo exclude_graphdriver_btrfs btrfs_noversion')
- EOF
-
- cat <<-EOF > hack/libdm_tag.sh || die
- #!/usr/bin/env bash
- $(usex device-mapper echo "echo libdm_no_deferred_remove exclude_graphdriver_devicemapper")
- EOF
-
- cat <<-EOF > hack/libsubid_tag.sh || die
- #!/usr/bin/env bash
- $(usex rootless "echo libsubid" echo)
- EOF
+run_make() {
+ emake \
+ BTRFS_BUILD_TAG="$(usex btrfs '' 'btrfs_noversion exclude_graphdriver_btrfs')" \
+ CONTAINERSCONFDIR="${EPREFIX}/etc/containers" \
+ LIBDM_BUILD_TAG="$(usex device-mapper '' 'libdm_no_deferred_remove exclude_graphdriver_devicemapper')" \
+ LIBSUBID_BUILD_TAG="$(usex rootless 'libsubid' '')" \
+ PREFIX="${EPREFIX}/usr" \
+ $@
}
src_compile() {
- # export variables which 'make install' is also going to use
- export PREFIX="${EPREFIX}/usr" \
- CONTAINERSCONFDIR="${EPREFIX}/etc/containers"
- # compile binary, docs, completions
- emake all completions
+ run_make all completions
+}
+
+src_install() {
+ # The install target in the Makefile tries to rebuild the binary and
+ # installs things that are already installed by containers-common.
+ dobin bin/skopeo
+ einstalldocs
+ doman docs/*.1
+ run_make "DESTDIR=${D}" install-completions
}