summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/adcli')
-rw-r--r--app-crypt/adcli/Manifest1
-rw-r--r--app-crypt/adcli/adcli-0.9.2.ebuild35
-rw-r--r--app-crypt/adcli/metadata.xml15
3 files changed, 51 insertions, 0 deletions
diff --git a/app-crypt/adcli/Manifest b/app-crypt/adcli/Manifest
new file mode 100644
index 000000000000..9dc8e534d160
--- /dev/null
+++ b/app-crypt/adcli/Manifest
@@ -0,0 +1 @@
+DIST adcli-0.9.2.tar.bz2 93680 BLAKE2B b5958b276ee43a0ee54aa922f27ed266d4e9fbd1c86e0c007dac9fcf9cc022e1b3ba043b782fceb00066be2577390773dc99fb8d476a6b5e6523d44d008fb667 SHA512 ae8414a0af389b6845dd92d41446a80a9dc1734b874175323c0e491d99944eab442b95ae6d3a29fc69638d2e73bf8d2c369f6fa50e9ed3968527444b78606286
diff --git a/app-crypt/adcli/adcli-0.9.2.ebuild b/app-crypt/adcli/adcli-0.9.2.ebuild
new file mode 100644
index 000000000000..37fb304f40a8
--- /dev/null
+++ b/app-crypt/adcli/adcli-0.9.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Tool for performing actions on an Active Directory domain"
+HOMEPAGE="https://www.freedesktop.org/software/realmd/adcli/adcli.html"
+SRC_URI="https://gitlab.freedesktop.org/realmd/adcli/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ app-crypt/mit-krb5
+ net-nds/openldap:=[sasl]"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ doc? (
+ app-text/docbook-xml-dtd:4.3
+ app-text/xmlto
+ dev-libs/libxslt
+ )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable doc)
+}
diff --git a/app-crypt/adcli/metadata.xml b/app-crypt/adcli/metadata.xml
new file mode 100644
index 000000000000..99303bacc412
--- /dev/null
+++ b/app-crypt/adcli/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>henning@hennsch.de</email>
+ <name>Henning Schild</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="freedesktop-gitlab">realmd/adcli</remote-id>
+ </upstream>
+</pkgmetadata>