summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/ccrypt')
-rw-r--r--app-crypt/ccrypt/ccrypt-1.11-r2.ebuild15
-rw-r--r--app-crypt/ccrypt/ccrypt-1.11-r3.ebuild22
-rw-r--r--app-crypt/ccrypt/ccrypt-1.11-r4.ebuild37
-rw-r--r--app-crypt/ccrypt/files/ccrypt-1.11-refresh-macro-clang16.patch64
-rw-r--r--app-crypt/ccrypt/metadata.xml2
5 files changed, 102 insertions, 38 deletions
diff --git a/app-crypt/ccrypt/ccrypt-1.11-r2.ebuild b/app-crypt/ccrypt/ccrypt-1.11-r2.ebuild
deleted file mode 100644
index aed93c8e1a10..000000000000
--- a/app-crypt/ccrypt/ccrypt-1.11-r2.ebuild
+++ /dev/null
@@ -1,15 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-DESCRIPTION="Encryption and decryption"
-HOMEPAGE="https://sourceforge.net/projects/ccrypt/"
-SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-
-RDEPEND="virtual/libcrypt:="
-DEPEND="${RDEPEND}"
diff --git a/app-crypt/ccrypt/ccrypt-1.11-r3.ebuild b/app-crypt/ccrypt/ccrypt-1.11-r3.ebuild
deleted file mode 100644
index 76e2a655467b..000000000000
--- a/app-crypt/ccrypt/ccrypt-1.11-r3.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-DESCRIPTION="Encryption and decryption"
-HOMEPAGE="https://sourceforge.net/projects/ccrypt/"
-SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="emacs"
-
-RDEPEND="virtual/libcrypt:="
-DEPEND="${RDEPEND}
- emacs? ( >=app-editors/emacs-23.1:* )"
-
-src_configure() {
- econf \
- $(use_enable emacs)
-}
diff --git a/app-crypt/ccrypt/ccrypt-1.11-r4.ebuild b/app-crypt/ccrypt/ccrypt-1.11-r4.ebuild
new file mode 100644
index 000000000000..9b49d44cd3a6
--- /dev/null
+++ b/app-crypt/ccrypt/ccrypt-1.11-r4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Encryption and decryption"
+HOMEPAGE="https://sourceforge.net/projects/ccrypt/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="emacs"
+
+RDEPEND="virtual/libcrypt:="
+DEPEND="
+ ${RDEPEND}
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.11-refresh-macro-clang16.patch
+)
+
+src_prepare() {
+ default
+
+ # Clang 16 patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable emacs)
+}
diff --git a/app-crypt/ccrypt/files/ccrypt-1.11-refresh-macro-clang16.patch b/app-crypt/ccrypt/files/ccrypt-1.11-refresh-macro-clang16.patch
new file mode 100644
index 000000000000..f610a1c38065
--- /dev/null
+++ b/app-crypt/ccrypt/files/ccrypt-1.11-refresh-macro-clang16.patch
@@ -0,0 +1,64 @@
+https://bugs.gentoo.org/900130
+
+Refresh macro from gettext.
+--- a/m4/intdiv0.m4
++++ b/m4/intdiv0.m4
+@@ -1,5 +1,5 @@
+-# intdiv0.m4 serial 6 (gettext-0.18.2)
+-dnl Copyright (C) 2002, 2007-2008, 2010-2016 Free Software Foundation, Inc.
++# intdiv0.m4 serial 9 (gettext-0.21.1)
++dnl Copyright (C) 2002, 2007-2008, 2010-2020 Free Software Foundation, Inc.
+ dnl This file is free software; the Free Software Foundation
+ dnl gives unlimited permission to copy and/or distribute it,
+ dnl with or without modifications, as long as this notice is preserved.
+@@ -12,7 +12,7 @@ AC_DEFUN([gt_INTDIV0],
+ AC_REQUIRE([AC_CANONICAL_HOST])dnl
+
+ AC_CACHE_CHECK([whether integer division by zero raises SIGFPE],
+- gt_cv_int_divbyzero_sigfpe,
++ [gt_cv_int_divbyzero_sigfpe],
+ [
+ gt_cv_int_divbyzero_sigfpe=
+ changequote(,)dnl
+@@ -31,8 +31,11 @@ changequote([,])dnl
+ if test -z "$gt_cv_int_divbyzero_sigfpe"; then
+ AC_RUN_IFELSE(
+ [AC_LANG_SOURCE([[
+-#include <stdlib.h>
++#include <stdlib.h> /* for exit() */
+ #include <signal.h>
++#if !(defined _WIN32 && !defined __CYGWIN__)
++#include <unistd.h> /* for _exit() */
++#endif
+
+ static void
+ sigfpe_handler (int sig)
+@@ -44,7 +47,7 @@ sigfpe_handler (int sig)
+ int x = 1;
+ int y = 0;
+ int z;
+-int nan;
++int inan;
+
+ int main ()
+ {
+@@ -59,7 +62,7 @@ int main ()
+ #endif
+
+ z = x / y;
+- nan = y / y;
++ inan = y / y;
+ exit (2);
+ }
+ ]])],
+@@ -79,8 +82,8 @@ changequote([,])dnl
+ fi
+ ])
+ case "$gt_cv_int_divbyzero_sigfpe" in
+- *yes) value=1;;
+- *) value=0;;
++ *yes) value=1 ;;
++ *) value=0 ;;
+ esac
+ AC_DEFINE_UNQUOTED([INTDIV0_RAISES_SIGFPE], [$value],
+ [Define if integer division by zero raises signal SIGFPE.])
diff --git a/app-crypt/ccrypt/metadata.xml b/app-crypt/ccrypt/metadata.xml
index 0edb7210b8c1..6bda026e6d09 100644
--- a/app-crypt/ccrypt/metadata.xml
+++ b/app-crypt/ccrypt/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
<upstream>